FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=14702&edit=1

ID: 14702
Updated by: helgith@gmail.com
Reported By: jzuckerman at gmail dot com
Summary: PEAR package installer ignores installed packages
-Status: Open
+Status: No Feedback
Type: Bug
Package: PEAR
Operating System: debian
Package Version: 1.6.1
PHP Version: 5.2.0
-Roadmap Versions: 1.8.0alpha1, 1.8.0RC1
+Roadmap Versions:
New Comment:

-Status: Open
+Status: No Feedback
-Roadmap Versions: 1.8.0alpha1, 1.8.0RC1
+Roadmap Versions:

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

Been a month, no feedback.

I also tried to install PEAR 1.6.1 and create a dummy package.xml file
with that required statement and made sure I had pecl_http 1.6.0
installed, it still worked fine so I do require more of the package.xml
or an isolated case if possible.


Previous Comments:
------------------------------------------------------------------------

[2009-03-07 20:44:41] dufuz

-Package Version: 1.7.2
+Package Version: 1.6.1

Wanted to check up on you and see if you have managed to try this out
on a computer that had newer PEAR versions on it ? :)

------------------------------------------------------------------------

[2009-02-09 22:02:00] dufuz

-Roadmap Versions: 1.8.0alpha1
+Roadmap Versions: 1.8.0alpha1, 1.8.0alpha2

Move to alpha2

------------------------------------------------------------------------

[2009-02-09 21:49:13] dufuz

You are not able to do a test with 1.7.2 on your personal computer with
said package.xml if you can't provide it to me ? :)

------------------------------------------------------------------------

[2009-02-07 18:41:22] dufuz

-Roadmap Versions:
+Roadmap Versions: 1.8.0alpha1


------------------------------------------------------------------------

[2008-09-24 19:10:18] jonz

Description:
------------
I am requiring pecl_http in a package with this code:

<package>
<name>pecl_http</name>
<channel>pecl.php.net</channel>
<recommended>1.6.0</recommended>
</package>

I know that it is currently installed: $ pecl list
Installed packages, channel pecl.php.net:
=========================================
Package Version State
APC 3.0.14 stable
memcache 2.2.3 stable
pecl_http 1.6.0 stable
xdebug 2.0.2 stable

However when I go to install the pear package it tries to re-install
pecl_http. I am using PEAR 1.6.1 and not at liberty to upgrade it atm.
I apologize if this has been fixed in the present stable version, boss
told me to submit the bug ;)

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedApr 4, '09 at 1:20a
activeApr 4, '09 at 1:20a
posts1
users1
websitepear.php.net

1 user in discussion

Helgith: 1 post

People

Translate

site design / logo © 2022 Grokbase