FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=14523&edit=1

ID: 14523
Updated by: helgith@gmail.com
Reported By: sharon_correll at sil dot org
Summary: results are consistently corrupted
Status: Open
Type: Bug
Package: Archive_Tar
Operating System: Windows XP
Package Version: 1.3.2
PHP Version: 5.2.5
Roadmap Versions:
New Comment:

Does revision 1.39 or above fix it ? 1.39 contains a rewrite of exactly
what is diffed between 1.29 and 1.32

Archive_Tar-1.3.3 will soon be out, be on a look out and see if the
issue still persists.


Previous Comments:
------------------------------------------------------------------------

[2008-12-12 10:01:58] chrisdunavant

I'm seeing the same issue on an Ubuntu platform. I did a little more
testing and found that the problem doesn't occur when just doing a
"tar"
file output but occurs when adding "gzip" compression. I also found
that
Revision 1.29 of Tar.php worked fine and Revision 1.32 had the problem.

I tried to do a diff between the two revisions to see if I could see
anything obvious but it wasn't clear what might be the culprit. BTW, I

am using "addString" to add all the files to the archive. Another odd
fact
is that it works fine if I only add things like PDF files, JPG files,
XLS files
but if I add a Word doc (I tried several different Word files) it
doesn't
work. I'd be happy to provide more information if needed. Thanks!

------------------------------------------------------------------------

[2008-08-19 17:32:12] sharoncorrell

Even without the .PNG...just trying to zip up an .XML file (8 K)
doesn't work--the file is truncated by a handful of characters (about
17-18). In one case I tried zipping 3 files. The first file is truncated
and the name of the second file is embedded in it.

------------------------------------------------------------------------

[2008-08-19 00:26:07] doconnor

Flickr or photobucket or something?

------------------------------------------------------------------------

[2008-08-18 15:40:08] sharoncorrell

Sorry, I thought there would be a way to attch my sample files, but it
doesn't seem to be possible to attach my .PNG.

------------------------------------------------------------------------

[2008-08-18 15:36:30] sharoncorrell

Description:
------------
It seems like I MUST be doing something wrong, but this package is not
working for me at all. It seemed to work fine for very small text files,
but when I tried life-sized files of various types, the results always
seem corrupted in various ways. The files are missing or truncated, or
the names are truncated, and graphics files (eg PNG) are never readable.

Test script:
---------------
$files_to_zip = array();
$files_to_zip[] = "C:/Cree.png";
$files_to_zip[] = "C:/data.xml";
$zip_filename = "C:/test.tgz";
$oTar = new Archive_Tar( $zip_filename, "gz" );
$oTar->create( $files_to_zip );


Expected result:
----------------
I would expect it to generate a file called "test.tgz" that I could
open with WinZIP (which is generally happy to open .TAR and .TGZ files).
The tar file would contain two files: Cree.png and data.xml.


Actual result:
--------------
For the example above, I get a .TGZ file containing only the .PNG file,
not the .XML one. And when I tried to open the .PNG, it is corrupted.

When I tried using a different directory, I got slightly different but
equally unsatisfactory results.

I get similar results trying to generate an uncompressed .TAR file.

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedMar 27, '09 at 2:33a
activeMar 27, '09 at 2:33a
posts1
users1
websitepear.php.net

1 user in discussion

Helgith: 1 post

People

Translate

site design / logo © 2022 Grokbase