FAQ
The DBD::mysql CPAN module has been updated to 4.025 to address many
Windows related issues.

The DBD::mysql version packaged with Strawberry Perl v5.18.1.1 is 4.023.

I have had no luck in building the 4.025 myself, and was wondering if
anyone has a binary install, or knows if the next Strawberry Perl
maintenance release will include the newer version.

Thanks,
Paul

Search Discussions

  • Kmx at Dec 28, 2013 at 5:54 pm
    try:

    C:\> cpanm DBD::mysql --configure-args="--mysql_config=mysql_config"
    --verbose --force

    --
    kmx
    On 28.12.2013 16:19, Paul Durden wrote:
    The DBD::mysql CPAN module has been updated to 4.025 to address many
    Windows related issues.

    The DBD::mysql version packaged with Strawberry Perl v5.18.1.1 is 4.023.

    I have had no luck in building the 4.025 myself, and was wondering if
    anyone has a binary install, or knows if the next Strawberry Perl
    maintenance release will include the newer version.

    Thanks,
    Paul
  • Michiel Beijen at Dec 29, 2013 at 8:29 am

    On 28.12.2013 16:19, Paul Durden wrote:

    The DBD::mysql CPAN module has been updated to 4.025 to address many Windows
    related issues.

    The DBD::mysql version packaged with Strawberry Perl v5.18.1.1 is 4.023.
    You'd be able to compile it using kmx's instructions.
    Also, the 4.023 version in Strawberry does have the most important fix
    that is in 4.024 and later for Win32, it was separately added to
    StrawberryPerl by kmx.
    --
    Mike
  • Paul Durden at Dec 29, 2013 at 3:01 pm
    Mike,
    Thanks for the info. The change log for 4.025 indicates more Windows
    related fixes, so I thought I'd try it.

    If this fixes it, I'll let you know.

    Thanks,
    Paul

    On Sun, Dec 29, 2013 at 2:28 AM, Michiel Beijen wrote:

    On 28.12.2013 16:19, Paul Durden wrote:

    The DBD::mysql CPAN module has been updated to 4.025 to address many Windows
    related issues.

    The DBD::mysql version packaged with Strawberry Perl v5.18.1.1 is 4.023.
    You'd be able to compile it using kmx's instructions.
    Also, the 4.023 version in Strawberry does have the most important fix
    that is in 4.024 and later for Win32, it was separately added to
    StrawberryPerl by kmx.
    --
    Mike
  • Paul Durden at Dec 29, 2013 at 2:57 pm
    Thanks, I will give this a try.

    On Sat, Dec 28, 2013 at 11:54 AM, kmx wrote:

    try:

    C:\> cpanm DBD::mysql --configure-args="--mysql_config=mysql_config"
    --verbose --force

    --
    kmx

    On 28.12.2013 16:19, Paul Durden wrote:

    The DBD::mysql CPAN module has been updated to 4.025 to address many
    Windows related issues.

    The DBD::mysql version packaged with Strawberry Perl v5.18.1.1 is 4.023.

    I have had no luck in building the 4.025 myself, and was wondering if
    anyone has a binary install, or knows if the next Strawberry Perl
    maintenance release will include the newer version.

    Thanks,
    Paul

  • Paul Durden at Dec 30, 2013 at 4:12 pm
    Updated my mysql_config.bat file to provide the various --testXXX
    parameters, and everything worked great!

    Also, the change to DBD::mysql 4.025 resolved my problem.

    Using the 4.023 that shipped with Strawberry Perl, whenever I attempted to
    add a row with a duplicate key, I received the following exception:
         "DBIx::Class::Storage::DBI::_dbh_execute(): Unknown error: execute()
    returned false, but error flags were not set... "

    Now, with 4.025 I get the more reasonable exception:
         "DBIx::Class::Storage::DBI::_dbh_execute(): DBI Exception:
    DBD::mysql::st execute failed: Duplicate entry 'Chamber 03' for key
    'chamber_name'..."

    Perl -v reports "This is perl 5, version 18, subversion 1 (v5.18.1) built
    for MSWin32-x86-multi-thread-64int"


    On Sat, Dec 28, 2013 at 11:54 AM, kmx wrote:

    try:

    C:\> cpanm DBD::mysql --configure-args="--mysql_config=mysql_config"
    --verbose --force

    --
    kmx

    On 28.12.2013 16:19, Paul Durden wrote:

    The DBD::mysql CPAN module has been updated to 4.025 to address many
    Windows related issues.

    The DBD::mysql version packaged with Strawberry Perl v5.18.1.1 is 4.023.

    I have had no luck in building the 4.025 myself, and was wondering if
    anyone has a binary install, or knows if the next Strawberry Perl
    maintenance release will include the newer version.

    Thanks,
    Paul

  • Paul Durden at Jan 10, 2014 at 7:22 pm
    I hope this is not considered bad form, but I just wanted to add this in
    case someone comes across this thread searching for a problem at a later
    date.

    It looks like DBD::mysql 4.025 is now included in Strawberry Perl 5.18.2.1
    according to the "List of distributions installed on top of Perl 5.18.2"
    section of the release notes.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupwin32-vanilla @
categoriesperl
postedDec 28, '13 at 3:19p
activeJan 10, '14 at 7:22p
posts7
users3
websitestrawberryperl.com

People

Translate

site design / logo © 2019 Grokbase