FAQ
In the past with a 5.8 version of Strawberry, I was able to install modules using cpan. For some reason this stopped working. I nuked my previous version of Strawberry and installed 5.10.1 (compiled Oct 21 2009 13:54:15). I still get the same result. It seems that I can extract the files and sub-directories into a temporary directory but the sub-directories under the module install directory in the cpan\build directory is not being created. I have pasted the messages I get below. Can someone point in the right direction to figure this out? I do have administrator rights on this WinXP Professional.
cpan> install IO::All
Running install for module 'IO::All'
Running make for I/IN/INGY/IO-All-0.39.tar.gz
Checksum for C:\strawberry\cpan\sources\authors\id\I\IN\INGY\IO-All-0.39.tar.gz
ok
Scanning cache C:\strawberry\cpan\build for sizes
............................................................................DONE
Catching error: "Couldn't move C:\\strawberry\\cpan\\build\\tmp-1704\\IO-All-0.3
9\\inc to C:\\strawberry\\cpan\\build\\IO-All-0.39-4_dinr\\inc: No such file or
directory at C:\\strawberry\\perl\\lib/CPAN/Distribution.pm line 516\cJ\cICPAN::
Distribution::run_preps_on_packagedir('CPAN::Distribution=HASH(0x26b8ebc)') call
ed at C:\\strawberry\\perl\\lib/CPAN/Distribution.pm line 347\cJ\cICPAN::Distrib
ution::get('CPAN::Distribution=HASH(0x26b8ebc)') called at C:\\strawberry\\perl\
\lib/CPAN/Distribution.pm line 1685\cJ\cICPAN::Distribution::make('CPAN::Distrib
ution=HASH(0x26b8ebc)') called at C:\\strawberry\\perl\\lib/CPAN/Distribution.pm
line 2903\cJ\cICPAN::Distribution::test('CPAN::Distribution=HASH(0x26b8ebc)') c
alled at C:\\strawberry\\perl\\lib/CPAN/Distribution.pm line 3293\cJ\cICPAN::Dis
tribution::install('CPAN::Distribution=HASH(0x26b8ebc)') called at C:\\strawberr
y\\perl\\lib/CPAN/Module.pm line 479\cJ\cIeval {...} called at C:\\strawberry\\p
erl\\lib/CPAN/Module.pm line 478\cJ\cICPAN::Module::rematein('CPAN::Module=HASH(
0x26b8cfc)', 'install') called at C:\\strawberry\\perl\\lib/CPAN/Module.pm line
581\cJ\cICPAN::Module::install('CPAN::Module=HASH(0x26b8cfc)') called at C:\\str
awberry\\perl\\lib/CPAN/Shell.pm line 1767\cJ\cICPAN::Shell::rematein('CPAN::She
ll', 'install', 'IO::All') called at C:\\strawberry\\perl\\lib/CPAN/Shell.pm lin
e 1947\cJ\cICPAN::Shell::__ANON__('CPAN::Shell', 'IO::All') called at C:/strawbe
rry/perl/lib/CPAN.pm line 375\cJ\cIeval {...} called at C:/strawberry/perl/lib/C
PAN.pm line 372\cJ\cICPAN::shell() called at C:\\strawberry\\perl\\bin/cpan line
195\cJ" at C:/strawberry/perl/lib/CPAN.pm line 391
CPAN::shell() called at C:\strawberry\perl\bin/cpan line 195

Regards,
John
513-723-7527
john.kington@convergys.com

Search Discussions

  • Kmx at Jan 26, 2010 at 10:04 pm

    Dne 26.1.2010 18:19, john.kington@convergys.com napsal(a):
    ...
    Can someone point in the right direction to figure this out? I do have administrator rights on this WinXP Professional.
    ...
    Try to disable your anti-virus SW and run "cpan install IO::All" again.
    I have experienced exactly the same issue on a computer with Microsoft
    Security Essentials.

    My theory is:
    - cpan clients unpacks a bunch of data
    - immediately after that cpan clients tries to move the whole upacked
    dir somewhere else
    - however AV has kind of a lock on the original directory as it did not
    finish the scanning of new files before "move dir" was called
    - from the outside it simply seems like "move failed"

    You can even try to run the same command multiple times and you will see
    that the reported error is not 100% deterministic.

    --
    kmx

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupwin32-vanilla @
categoriesperl
postedJan 26, '10 at 5:20p
activeJan 26, '10 at 10:04p
posts2
users2
websitestrawberryperl.com

2 users in discussion

Kmx: 1 post John Kington: 1 post

People

Translate

site design / logo © 2018 Grokbase