Rich Bowen wrote:
On Tue, 5 Feb 2002, Clemens Giegerich wrote:
I didn't get any respons of my last e-mail (some weeks ago). I request a
new script category for my perltk script mkFilter.pl:
mkFilter.pl is a script with GUI (perltk) for testing perl regular
expressions, filtering input data (text) and generating template
scripts. You can use the script like a debugger for a single regular
expression. You can't step into an expression but you can change the
expression and see immediately the change on the input string and all
auto set perl variables. Input separator can be changed so it can also
be used to work on structured data. The resulting expression can be
written to a template script (including loop, ...), applied inplace or
coppied to the clipboard. ...
My first request for a new category was Text::Filter.
Another (perhaps bettter) idea from a reply of my request was Regex::.
I seem to recall that there were a number of responses to it, some
discussion of the relative merits of the "Text" top-level-category,
some other random discussion.
Personally, I think that the name mkFilter is sufficiently
undescriptive that folks will have a hard time recognizing from its
what it is, and so are likely to go past it in a listing.
The name results from a beginner point of view. In our department there
are many users which have only basic knowledge about programming
therefore the script was called after the primary function for this
users: making filter scripts. This is the reason why my first category
request was Text::Filter too.
My opinion, for what it's worth, is that "Regex" might be a more
appropriate category for this particular program, if I am correctly
understanding what it does.
If you see the primary function of the script to develop regular
expression than the right category should be Regex:: but the script
should also get a new name as you already mentioned (e.g mkRegex.pl,
regexEvaluater.pl, ...). I developed the script for exactly this purpose
but after some time I mainly used it for filtering too. Now I think the
script should be named and categorized by the beginner point of view
(the primary users).
Rich Bowen - email@example.com
... and another brother out of his mind, and another brother out at
York (not the same, though it might appear so)
Somebody's Luggage (Charles Dickens)
Any further comments?
What do you think about Regex:: and regexEvaluater.pl?