Grokbase Groups Perl qa March 2008
FAQ
Has anyone seen this error?

Unknown arguments to TAP::Harness::new (verbosity color) at /Users/
chris/perl/lib/perl5/Test/Harness.pm line 274

It's causing both CPAN and CPANPLUS to fail all installs on my
development machine. Web search turned up only this comment, with no
real solution:
http://www.perlmonks.org/?node_id=666453
I've grepped and acked ~/perl/lib and ~/.cpan but cannot figure out
where the problem arguments are coming from. Has anyone else seen
this? I'm posting here rather than RT because I can't figure out who
is at fault. It very well could be me, because this is happening on
just one machine.

Perl 5.8.6 (Apple's dist for OSX 10.4)
Test::Harness 3.10
TAP::Harness 0.54
TAP::Parser 0.54
CPAN 1.9205
CPANPLUS 0.82

Chris

Search Discussions

  • Andy Armstrong at Mar 8, 2008 at 6:00 pm

    On 8 Mar 2008, at 17:54, Chris Dolan wrote:

    Has anyone seen this error?

    Unknown arguments to TAP::Harness::new (verbosity color) at /Users/
    chris/perl/lib/perl5/Test/Harness.pm line 274

    It's causing both CPAN and CPANPLUS to fail all installs on my
    development machine. Web search turned up only this comment, with
    no real solution:
    http://www.perlmonks.org/?node_id=666453
    I've grepped and acked ~/perl/lib and ~/.cpan but cannot figure out
    where the problem arguments are coming from. Has anyone else seen
    this? I'm posting here rather than RT because I can't figure out
    who is at fault. It very well could be me, because this is
    happening on just one machine.

    Perl 5.8.6 (Apple's dist for OSX 10.4)
    Test::Harness 3.10
    TAP::Harness 0.54
    TAP::Parser 0.54
    CPAN 1.9205
    CPANPLUS 0.82

    Yeah, you have a mixture of Test::Harness and TAP::Parser installed.
    You need to delete those old versions of TAP::Harness and TAP::Parser.
    TAP::* and Test::Harness should be the same versions.

    --
    Andy Armstrong, Hexten
  • Chris Dolan at Mar 8, 2008 at 6:12 pm

    On Mar 8, 2008, at 11:59 AM, Andy Armstrong wrote:
    On 8 Mar 2008, at 17:54, Chris Dolan wrote:

    Perl 5.8.6 (Apple's dist for OSX 10.4)
    Test::Harness 3.10
    TAP::Harness 0.54
    TAP::Parser 0.54
    CPAN 1.9205
    CPANPLUS 0.82
    Yeah, you have a mixture of Test::Harness and TAP::Parser
    installed. You need to delete those old versions of TAP::Harness
    and TAP::Parser. TAP::* and Test::Harness should be the same versions.
    Arg, not again! PREFIX vs. --install_base vs. vendorlib vs. sitelib
    vs. Apple vs. Fink
    The variety of places that Perl modules can be installed on a Mac is
    really insane, and things keep changing. I really should just build
    my own Perl from source, but then I'd break Apple's mod_perl...

    Thanks very much Andy!

    Chris
  • Andy Armstrong at Mar 8, 2008 at 6:13 pm

    On 8 Mar 2008, at 18:12, Chris Dolan wrote:
    Yeah, you have a mixture of Test::Harness and TAP::Parser
    installed. You need to delete those old versions of TAP::Harness
    and TAP::Parser. TAP::* and Test::Harness should be the same
    versions.
    Arg, not again! PREFIX vs. --install_base vs. vendorlib vs. sitelib
    vs. Apple vs. Fink
    The variety of places that Perl modules can be installed on a Mac is
    really insane, and things keep changing. I really should just build
    my own Perl from source, but then I'd break Apple's mod_perl...

    That's what I do. I have 5.10 in /alt/local/bin/perl and rebuild
    eveything, including Apache and mod_perl. Seems safer than dicking
    around with the system Perl.

    --
    Andy Armstrong, Hexten
  • Michael G Schwern at Mar 8, 2008 at 11:15 pm

    Chris Dolan wrote:
    On Mar 8, 2008, at 11:59 AM, Andy Armstrong wrote:
    On 8 Mar 2008, at 17:54, Chris Dolan wrote:

    Perl 5.8.6 (Apple's dist for OSX 10.4)
    Test::Harness 3.10
    TAP::Harness 0.54
    TAP::Parser 0.54
    CPAN 1.9205
    CPANPLUS 0.82
    Yeah, you have a mixture of Test::Harness and TAP::Parser installed.
    You need to delete those old versions of TAP::Harness and TAP::Parser.
    TAP::* and Test::Harness should be the same versions.
    Arg, not again! PREFIX vs. --install_base vs. vendorlib vs. sitelib vs.
    Apple vs. Fink
    Either use INSTALL_BASE with --install_base or PREFIX with --prefix but don't
    mix them.


    --
    On error resume stupid

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupqa @
categoriesperl
postedMar 8, '08 at 5:54p
activeMar 8, '08 at 11:15p
posts5
users3
websiteqa.perl.org

People

Translate

site design / logo © 2021 Grokbase