FAQ
Attached is a patch to upgrade the Locale-Codes distribution (containing
the core modules Locale::Country, Locale::Language, and
Locale::Currency) to the most recent version.

====
Background:

The core modules Locale::Country, Locale::Language, and Locale::Currency
(all part of the Locale-Codes distribution) should be updated on a
regular basis. They contain "codes" from various internet standards
which change over time.

I plan on releasing new versions at least twice a year to keep the codes
up-to-date. At this point, I'm not planning on any significant code
changes (other than bug fixes), so the only significant changes
betweenreleases should be to update the codes.

Search Discussions

  • Steffen Mueller at Sep 28, 2010 at 5:22 pm
    Hi Sullivan,

    Sullivan Beck wrote:
    Attached is a patch to upgrade the Locale-Codes distribution (containing
    the core modules Locale::Country, Locale::Language, and
    Locale::Currency) to the most recent version.
    thanks applied as e45e19666b26391.

    One minor nit: I had to change the permissions of the test files to not
    be executable. All executable files within the core perl distribution
    apparently need to be registered or tests fail. Since there's no reason
    to have test file executable, next time around, could you try to submit
    a patch that doesn't make them so? Anyway. No big deal.

    --Steffen

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupperl5-porters @
categoriesperl
postedSep 28, '10 at 4:30p
activeSep 28, '10 at 5:22p
posts2
users2
websiteperl.org

2 users in discussion

Steffen Mueller: 1 post Sullivan Beck: 1 post

People

Translate

site design / logo © 2021 Grokbase