FAQ

On Wed, Jun 30, 2010 at 01:14, Perl 5 commit summary wrote:

Update Test-Harness to CPAN version 3.21
Chris 'BinGOs' Williams     113 files changed, 5055 insertions(+), 1451 dele
http://perl5.git.perl.org/perl.git/commit/6d3136644eb73f7a
This bumped Test::Harness from 3.17 to 3.21. I discovered a
regression. in 3.17_01 which broke the use of Test::Harness in Git's
own test suite, and will probably affect a lot of other external users
of Test::Harness that aren't implementing their tests in Perl:

https://rt.cpan.org/Public/Bug/Display.html?id=59186#txn-801685

I'm unsure what this should mean for core (if anything), but 5.13.3
would be the first Perl version to ship with this bug, so I thought
I'd at least note it.

The bug only affects tests that aren't written in Perl, that need to
pass options via prove's `prove ./some-test.sh :: --some option'
facility.

Search Discussions

  • Demerphq at Jul 10, 2010 at 2:21 pm

    On 10 July 2010 16:07, Ævar Arnfjörð Bjarmason wrote:
    On Wed, Jun 30, 2010 at 01:14, Perl 5 commit summary wrote:

    Update Test-Harness to CPAN version 3.21
    Chris 'BinGOs' Williams     113 files changed, 5055 insertions(+), 1451 dele
    http://perl5.git.perl.org/perl.git/commit/6d3136644eb73f7a
    This bumped Test::Harness from 3.17 to 3.21. I discovered a
    regression. in 3.17_01 which broke the use of Test::Harness in Git's
    own test suite, and will probably affect a lot of other external users
    of Test::Harness that aren't implementing their tests in Perl:

    https://rt.cpan.org/Public/Bug/Display.html?id=59186#txn-801685

    I'm unsure what this should mean for core (if anything), but 5.13.3
    would be the first Perl version to ship with this bug, so I thought
    I'd at least note it.

    The bug only affects tests that aren't written in Perl, that need to
    pass options via prove's `prove ./some-test.sh :: --some option'
    facility.
    This is a faily serious bug i think shouldnt we file a ticket in OUR
    RT about this one?

    yves




    --
    perl -Mre=debug -e "/just|another|perl|hacker/"
  • Andy Armstrong at Jul 10, 2010 at 4:46 pm

    On 10 Jul 2010, at 15:07, Ævar Arnfjörð Bjarmason wrote:
    This bumped Test::Harness from 3.17 to 3.21. I discovered a
    regression. in 3.17_01 which broke the use of Test::Harness in Git's
    own test suite, and will probably affect a lot of other external users
    of Test::Harness that aren't implementing their tests in Perl:

    https://rt.cpan.org/Public/Bug/Display.html?id=59186#txn-801685

    I'm unsure what this should mean for core (if anything), but 5.13.3
    would be the first Perl version to ship with this bug, so I thought
    I'd at least note it.

    The bug only affects tests that aren't written in Perl, that need to
    pass options via prove's `prove ./some-test.sh :: --some option'
    facility.

    I'm going to look at this today or tomorrow.

    --
    Andy Armstrong, Hexten

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupperl5-porters @
categoriesperl
postedJul 10, '10 at 2:07p
activeJul 10, '10 at 4:46p
posts3
users3
websiteperl.org

People

Translate

site design / logo © 2021 Grokbase