FAQ
Hi,

We have upgraded the Apache with SSL enabled along with Perl and compiled with DBI and DBD-Oracle Modules.. We have following versions installed..

Apache - Apache/2.2.4 (Unix)
Solaris - 8
Perl - v5.8.8
DBI - DBI-1.56
DBD-Oracle - 1.19
Oracle client - 10.2.0.1

We were able to get the Apache with SSL enabled with a sample perl and tested it successfully.. We were also able to compile the DBI & DBD-Oracle versions respectively with Apache without any issues/errors..

However when we tried to query/access the Oracle database with Perl DB module, we are getting following errors..

We have tried several ways by updating the PATH and LD_LIBRARY_PATH with "$ORACLE_HOME/lib32 & $ORACLE_HOME/lib & /usr/local/lib/perl5/site_perl/5.8.8/sun4-solaris/auto/DBD/Oracle/Oracle.so" and restarted the Apache.. Still the same issue persists with below errors..

[Mon Jul 23 16:44:29 2007] [error] [client 169.188.205.211] install_driver(Oracle) failed: Can't load '/usr/local/lib/perl5/site_perl/5.8.8/sun4-solaris/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: ld.so.1: dbtest.pl: fatal: /data01/oracle/product/10.2.0.1/db_1/lib/libclntsh.so.10.1: wrong ELF class: ELFCLASS64 at /usr/local/lib/perl5/5.8.8/sun4-solaris/DynaLoader.pm line 230.
[Mon Jul 23 16:44:29 2007] [error] [client 169.188.205.211] at (eval 3) line 3
[Mon Jul 23 16:44:29 2007] [error] [client 169.188.205.211] Compilation failed in require at (eval 3) line 3.
[Mon Jul 23 16:44:29 2007] [error] [client 169.188.205.211] Perhaps a required shared library or dll isn't installed where expected
[Mon Jul 23 16:44:29 2007] [error] [client 169.188.205.211] at /usr/local/apache2/htdocs/dbtest.pl line 15
bash-2.03#

-Thanks

Search Discussions

  • Ron Savage at Jul 25, 2007 at 3:59 am
    Prasad, Nagendra wrote:

    Hi Nagendra
    We were able to get the Apache with SSL enabled with a sample perl and tested it successfully.. We were also able to compile the DBI & DBD-Oracle versions respectively with Apache without any issues/errors..
    When you say '...tested it...', what /exactly/ do you mean by 'it'?
    [Mon Jul 23 16:44:29 2007] [error] [client 169.188.205.211] install_driver(Oracle) failed: Can't load '/usr/local/lib/perl5/site_perl/5.8.8/sun4-solaris/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: ld.so.1: dbtest.pl: fatal: /data01/oracle/product/10.2.0.1/db_1/lib/libclntsh.so.10.1: wrong ELF class: ELFCLASS64 at /usr/local/lib/perl5/5.8.8/sun4-solaris/DynaLoader.pm line 230.
    I'll let others deal with the 'wrong ELF class error'.
    [Mon Jul 23 16:44:29 2007] [error] [client 169.188.205.211] at /usr/local/apache2/htdocs/dbtest.pl line 15
    You can't be serious! Surely you /don't/ have a Perl script in the
    htdocs directory. Why isn't it in the cgi-bin directory?

    Also, you did not tell us whether or not you could run this Perl script
    (or any other) from the command line, and successfully connect to Oracle.

    --
    Ron Savage
    ron@savage.net.au
    http://savage.net.au/

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdbi-users @
categoriesperl
postedJul 23, '07 at 9:00p
activeJul 25, '07 at 3:59a
posts2
users2
websitedbi.perl.org

2 users in discussion

Prasad, Nagendra: 1 post Ron Savage: 1 post

People

Translate

site design / logo © 2022 Grokbase