FAQ
Hi,



I am having problems running DBI-1.48 using DBD-DB2-0.78.
The issue is that when I run a "make test" prior to running a "make
install" for the compilation of the Perl DBD-DB2-0.78 module on AIX 5.3
using the client libraries that come with DB2 UDB v8.2 (installed on AIX
5.3 as well) only 60% of the tests pass (The IBM VAC v6.0 C/C++
compiler was used for compilation) . The "make install" when invoked
complains that it cannot load the following two libraries: "libdb2.a and
libdb2osse.a" even though the "$DB2_HOME" directory is set using the
"export DB2_HOME=/db2home/db2fald1"; both of the aforementioned
libraries exist under the "$DB2_HOME/sqllib/lib" directory.



The "make install" for the DBD-DB2-0.78 Perl module will
compile without any fatal errors. However, when the DBI-1.48/
DBD-DB2-0.78 combination is called within the body of a "main" Perl
script the following errors are produced:



Can't load
'/usr/opt/perl5/lib/site_perl/5.8.2/aix-thread-multi/auto/DBD/DB2/DB2.so
' for module DBD::DB2: 0509-022 Cannot load module
/db2home/db2fald1/sqllib/lib/libdb2.a(shr.o).

0509-150 Dependent module
/db2home/db2fald1/sqllib/lib/libdb2osse.a(shr.o) could not be loaded.

0509-152 Member shr.o is not found in archive

0509-022 Cannot load module
/usr/opt/perl5/lib/site_perl/5.8.2/aix-thread-multi/auto/DBD/DB2/DB2.so.

0509-150 Dependent module
/db2home/db2fald1/sqllib/lib/libdb2.a(shr.o) could not be loaded. at
/usr/opt/perl5/lib/5.8.2/aix-thread-multi/DynaLoader.pm line 229.

at ./falcon_bmg.pl line 5

Compilation failed in require at ./falcon_bmg.pl line 5.

BEGIN failed--compilation aborted at ./falcon_bmg.pl line 5.



It still complains about not being able to load the shared object
libraries "libdb2.a" and "libdb2osse.a" ; any thoughts and/or insights
you might have to possibly solve this, would be highly appreciated.





Thanks



C.L. Grassi

Search Discussions

  • Dan Scott at Jun 23, 2005 at 1:46 am
    Chris:

    This sounds very much like the problem noted under "Hints" at
    http://www-306.ibm.com/software/data/db2/perl/:

    Having trouble running perl with DB2 UDB Version 8 64-bit for AIX
    5.2? Check out this technote.
    (http://www-1.ibm.com/support/docview.wss?rs=71&context=SSEPGG&uid=swg21181032&loc=en_US&cs=utf-8&lang=en)
    which goes on to describe an incompatibility between 32-bit and 64-bit
    libraries (and a solution, thankfully!)

    Dan
    On 6/21/05, Chris.L.Grassi@wellsfargo.com wrote:
    Hi,



    I am having problems running DBI-1.48 using DBD-DB2-0.78.
    The issue is that when I run a "make test" prior to running a "make
    install" for the compilation of the Perl DBD-DB2-0.78 module on AIX 5.3
    using the client libraries that come with DB2 UDB v8.2 (installed on AIX
    5.3 as well) only 60% of the tests pass (The IBM VAC v6.0 C/C++
    compiler was used for compilation) . The "make install" when invoked
    complains that it cannot load the following two libraries: "libdb2.a and
    libdb2osse.a" even though the "$DB2_HOME" directory is set using the
    "export DB2_HOME=/db2home/db2fald1"; both of the aforementioned
    libraries exist under the "$DB2_HOME/sqllib/lib" directory.



    The "make install" for the DBD-DB2-0.78 Perl module will
    compile without any fatal errors. However, when the DBI-1.48/
    DBD-DB2-0.78 combination is called within the body of a "main" Perl
    script the following errors are produced:



    Can't load
    '/usr/opt/perl5/lib/site_perl/5.8.2/aix-thread-multi/auto/DBD/DB2/DB2.so
    ' for module DBD::DB2: 0509-022 Cannot load module
    /db2home/db2fald1/sqllib/lib/libdb2.a(shr.o).

    0509-150 Dependent module
    /db2home/db2fald1/sqllib/lib/libdb2osse.a(shr.o) could not be loaded.

    0509-152 Member shr.o is not found in archive

    0509-022 Cannot load module
    /usr/opt/perl5/lib/site_perl/5.8.2/aix-thread-multi/auto/DBD/DB2/DB2.so.

    0509-150 Dependent module
    /db2home/db2fald1/sqllib/lib/libdb2.a(shr.o) could not be loaded. at
    /usr/opt/perl5/lib/5.8.2/aix-thread-multi/DynaLoader.pm line 229.

    at ./falcon_bmg.pl line 5

    Compilation failed in require at ./falcon_bmg.pl line 5.

    BEGIN failed--compilation aborted at ./falcon_bmg.pl line 5.



    It still complains about not being able to load the shared object
    libraries "libdb2.a" and "libdb2osse.a" ; any thoughts and/or insights
    you might have to possibly solve this, would be highly appreciated.





    Thanks



    C.L. Grassi





Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdbi-users @
categoriesperl
postedJun 22, '05 at 1:38a
activeJun 23, '05 at 1:46a
posts2
users2
websitedbi.perl.org

2 users in discussion

Chris L Grassi: 1 post Dan Scott: 1 post

People

Translate

site design / logo © 2022 Grokbase