FAQ
I have problem to install DBD Informix module on Red Hat Enterprise Linux ES release 3


#####
perl Makefile.PL

Configuring IBM Informix Database Driver for Perl Version 2003.04 (2003-03-05) (aka DBD::Informix)
You are using DBI version 1.45 and Perl version 5.008
Remember to actually read the README file!

Perl: perl5.008 i386-linux-thread-multi dl_dlopen.xs
System: linux tweet
Compiler: gcc -O2 -g -pi -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm

Using IBM Informix CSDK Version 2.81, IBM Informix-ESQL Version 9.53.UC2X5 from /opt/informix

Beware: DBD::Informix is not yet aware of all the new IUS data types.

Assert macro will be disabled!

lib/DBD/Informix/Defaults.pm written OK
esqlvrsn.h written OK
esqlinfo.h written OK


Gosh! Perl doesn't think your compiler handles prototypes.
Well, even though I don't believe it, we'll take Perl's word
for it and we won't try to force them into use. Don't you
need to upgrade your compiler? If you run into compilation
problems with the test program, you will need to revisit this
issue.
Testing whether your Informix test environment will work...
sh: -c: line 2: unexpected EOF while looking for matching `''
sh: -c: line 3: syntax error: unexpected end of file
Failed to compile esqltest.ec to esqltestub

########

any suggestions ?

thanks for help

Marco

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdbi-users @
categoriesperl
postedOct 8, '04 at 8:34a
activeOct 8, '04 at 8:34a
posts1
users1
websitedbi.perl.org

1 user in discussion

Marco Avvisano: 1 post

People

Translate

site design / logo © 2022 Grokbase