FAQ
Since there seem to be a few persistent bugs (particularly one that's new
with Perl 5.8+), I'm release 0.73 as a bug fix release. I'm still working
0.80, which will have many more feature additions, and bug fixes, but
hopefully this release will at least let people install Alzabo under Perl
5.8.0. It also fixes some bugs in how Alzabo interacted with newer
versions of MySQL and Postgres.

0.73 October 5, 2003

BACKWARDS INCOMPATIBILITIES:

- This release no longer includes the Mason schema creation GUI. It
can be installed separately via the Alzabo::GUI::Mason package.

BUG FIXES:

- Fixed a bug in Alzabo::Create::Schema that only seems to be
triggered by newer Perls. The symptom was an error like "Alzabo does
not support the 'MySQL' RDBMS" when trying to create a new schema.

- Fixed a warning in Alzabo::RDBMSRules.

- The 01-driver.t test ignored any user-supplied RDBMS connection
parameters. Reported by Barry Hoggard.

- Newer versions of MySQL may return quoted table names, which broke
reverse engineering.

- Added a quick and nasty hack to remove the schema name from table
names when reverse engineering Postgres schemas.

- Reverse engineering of indexes for MySQL 4.0+ was broken.



-dave

/*=======================
House Absolute Consulting
www.houseabsolute.com
=======================*/

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdbi-users @
categoriesperl
postedOct 6, '03 at 3:29a
activeOct 6, '03 at 3:29a
posts1
users1
websitedbi.perl.org

1 user in discussion

Dave Rolsky: 1 post

People

Translate

site design / logo © 2022 Grokbase