FAQ
I am having trouble installing the DBD::Informix (version 2003.04). I have
installed a 64 bit perl and the DB1 1.35. Here is the specs:


Summary of my perl5 (revision 5.0 version 8 subversion 0) configuration:
Platform:
osname=solaris, osvers=2.9, archname=sun4-solaris
uname='sunos carbon01 5.9 generic_112233-06 sun4u sparc
sunw,sun-fire-880 '
config_args='-Dcc=gcc -des -Duse64bitall -Aldflags=-mcpu=v9 -m64
-Alddlflags
=-mcpu=v9 -m64 -G'
hint=previous, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef
usemultiplicity=unde
f
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=define use64bitall=define uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='gcc', ccflags ='-mcpu=v9 -m64 -Wa,-xarch=v9 -fno-strict-aliasing
-D_LARG
EFILE_SOURCE -D_FILE_OFFSET_BITS=64',
optimize='-O',
cppflags='-mcpu=v9 -m64 -Wa,-xarch=v9 -fno-strict-aliasing -mcpu=v9 -m64
-Wa
,-xarch=v9 -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
ccversion='', gccversion='3.2.3', gccosandvers='solaris2.9'
intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=87654321
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t',
lseeksize
=8
alignbytes=8, prototype=define
Linker and Libraries:
ld='gcc', ldflags =' -mcpu=v9 -m64 -L/usr/local/lib -L/usr/lib/sparcv9
-mcp
u=v9 -m64'
libpth=/usr/local/lib /usr/lib/sparcv9 /usr/lib /usr/ccs/lib
libs=-lsocket -lnsl -ldl -lm -lc
perllibs=-lsocket -lnsl -ldl -lm -lc
libc=/usr/lib/sparcv9/libc.so, so=so, useshrplib=false,
libperl=libperl.a
gnulibc_version=''
Dynamic Linking:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
cccdlflags='-fPIC', lddlflags='-G -L/usr/local/lib -L/usr/lib/sparcv9
-mcpu=
v9 -m64 -G'


Characteristics of this binary (from libperl):
Compile-time options: USE_64_BIT_INT USE_64_BIT_ALL USE_LARGE_FILES
Built under solaris
Compiled at Sep 11 2003 07:51:58
@INC:
/usr/local/lib/perl5/5.8.0/sun4-solaris
/usr/local/lib/perl5/5.8.0
/usr/local/lib/perl5/site_perl/5.8.0/sun4-solaris
/usr/local/lib/perl5/site_perl/5.8.0
/usr/local/lib/perl5/site_perl
.

Prior to doing the Makefile.PL I have set the ENV vars:
DBD_INFORMIX_ESQLCC_REMOVE_OPTIONS_REGEX=^-xarch=(sparc)?v9$ AND
INFORMIXC=gcc -m64 but I am still getting errors when doing the perl
Makefile.pl. Below is the output and errors:

Configuring IBM Informix Database Driver for Perl Version 2003.04
(2003-03-05) (
aka DBD::Informix)
You are using DBI version 1.35 and Perl version 5.008
Remember to actually read the README file!

Perl: perl5.008 sun4-solaris dl_dlopen.xs
System: sunos carbon01 5.9 generic_112233-06 sun4u sparc sunw,sun-fire-880
Compiler: gcc -O -mcpu=v9 -m64 -Wa,-xarch=v9 -fno-strict-aliasing
-D_LARGEFILE_S
OURCE -D_FILE_OFFSET_BITS=64

Using IBM Informix CSDK Version 2.81, IBM Informix-ESQL Version 9.53.FC1
from /i
nformix-sparc_prod_ctrl1_1

Beware: DBD::Informix is not yet aware of all the new IUS data types.

Assert macro will be disabled!

lib/DBD/Informix/Defaults.pm written OK
esqlvrsn.h written OK
esqlinfo.h written OK

Testing whether your Informix test environment will work...
# DBD_INFORMIX_ESQLCC_REMOVE_OPTIONS_REGEX set.
# Removing options that match regex m%^-xarch=(sparc)?v9$%
# DBD_INFORMIX_ESQLCC_REMOVE_OPTIONS_REGEX set.
# Removing options that match regex m%^-xarch=(sparc)?v9$%
# DBD_INFORMIX_ESQLCC_REMOVE_OPTIONS_REGEX set.
# Removing options that match regex m%^-xarch=(sparc)?v9$%
ld: fatal: file esqltest.o: wrong ELF class: ELFCLASS64
ld: fatal: File processing errors. No output written to esqltest
collect2: ld returned 1 exit status
Failed to link test program esqltest

Does anyone have any suggestions?

Thanks

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdbi-users @
categoriesperl
postedSep 11, '03 at 6:59p
activeSep 11, '03 at 6:59p
posts1
users1
websitedbi.perl.org

1 user in discussion

Curling, Daniel: 1 post

People

Translate

site design / logo © 2022 Grokbase