FAQ
Greetings,
I have spent about two weeks going over the archives and reading
everything I can find out the DBD on hpux. I still can't get it to work

Short form:
HPUX 11.11 64 bit
Oracle 8.1.7 32 bit
HP extra cost compiler
Perl 5.8.0 and 5.6.1 used
DBI 1.18, 1,25 and 1.30 all tried
DBD 1.07 and 1.12 tried.
Non threading, -lcl and lpthreads added, +z added,
+Z also tried alone and in combo with +z
perl Makefile.PL -l tried

Can not shl_load()....etc....

Static builds also tried they will not link properly
used the symbol finder script to find the missing symbols, add the
libraries and they are still not found.

At this point I have tried each and every thing I can find on google. I
still can't make it work.

Can anyone offer additional suggestions?

I am new to HPUX but have been working with unix since 1985.

Thanks
Brian

Search Discussions

  • NIPP, SCOTT V (SBCSI) at Dec 12, 2002 at 9:49 pm
    This may or may not be obvious... Did you add the -lcl and
    -lpthreads as the first in the list of libraries? I have learned from
    experience they absolutely have to be the first two in the list in that
    order. Also, maybe obvious, you were compiling Perl with the -lcl and
    -lpthreads, right? Not only DBI?

    -----Original Message-----
    From: Brian D. Silverio
    Sent: Thursday, December 12, 2002 3:35 PM
    To: dbi-users@perl.org
    Subject: DBD on HPUX


    Greetings,
    I have spent about two weeks going over the archives and reading
    everything I can find out the DBD on hpux. I still can't get it to work

    Short form:
    HPUX 11.11 64 bit
    Oracle 8.1.7 32 bit
    HP extra cost compiler
    Perl 5.8.0 and 5.6.1 used
    DBI 1.18, 1,25 and 1.30 all tried
    DBD 1.07 and 1.12 tried.
    Non threading, -lcl and lpthreads added, +z added,
    +Z also tried alone and in combo with +z
    perl Makefile.PL -l tried

    Can not shl_load()....etc....

    Static builds also tried they will not link properly
    used the symbol finder script to find the missing symbols, add the
    libraries and they are still not found.

    At this point I have tried each and every thing I can find on google. I
    still can't make it work.

    Can anyone offer additional suggestions?

    I am new to HPUX but have been working with unix since 1985.

    Thanks
    Brian
  • Lbaxter at Dec 12, 2002 at 11:32 pm
    Yep... that is ABSOLUTELY correct.

    Also not that he is using 32bit oracle, which is different from my setup. I
    suggested he try the 64bit oracle client.

    To mention some thing else that should be obvious... is SHLIB_PATH set to
    the oracle lib dir?

    Lincoln


    -----Original Message-----
    From: NIPP, SCOTT V (SBCSI)
    Sent: Thursday, December 12, 2002 4:48 PM
    To: 'Brian D. Silverio'; dbi-users@perl.org
    Subject: RE: DBD on HPUX

    This may or may not be obvious... Did you add the -lcl and
    -lpthreads as the first in the list of libraries? I have learned from
    experience they absolutely have to be the first two in the list in that
    order. Also, maybe obvious, you were compiling Perl with the -lcl and
    -lpthreads, right? Not only DBI?

    -----Original Message-----
    From: Brian D. Silverio
    Sent: Thursday, December 12, 2002 3:35 PM
    To: dbi-users@perl.org
    Subject: DBD on HPUX


    Greetings,
    I have spent about two weeks going over the archives and reading
    everything I can find out the DBD on hpux. I still can't get it to work

    Short form:
    HPUX 11.11 64 bit
    Oracle 8.1.7 32 bit
    HP extra cost compiler
    Perl 5.8.0 and 5.6.1 used
    DBI 1.18, 1,25 and 1.30 all tried
    DBD 1.07 and 1.12 tried.
    Non threading, -lcl and lpthreads added, +z added,
    +Z also tried alone and in combo with +z
    perl Makefile.PL -l tried

    Can not shl_load()....etc....

    Static builds also tried they will not link properly
    used the symbol finder script to find the missing symbols, add the
    libraries and they are still not found.

    At this point I have tried each and every thing I can find on google. I
    still can't make it work.

    Can anyone offer additional suggestions?

    I am new to HPUX but have been working with unix since 1985.

    Thanks
    Brian
  • Brian D. Silverio at Dec 13, 2002 at 2:35 pm
    Thank you all for your comments.
    I will try to work through them and send one answer to all the
    suggestions.

    Hopefully with a "this one worked!"

    Thanks for the help

    Brian
  • Brian D. Silverio at Dec 16, 2002 at 6:56 pm
    The answer to the problem was supplied by Lincoln Baxter.
    His suggestion was to use the 64bit Oracle client.

    THANK YOU VERY MUCH Lincoln! It is really appreciated.

    And thank you to all who tried to help.

    So for the record, the DBD does not work on HPUX with the 64bit OS and
    the 32bit Oracle client. I expect someone else will be running into
    this.

    And thanks to all who tried to help out with suggestions on what I could
    try.

    Brian
    -----Original Message-----
    From: LBaxter@FLEETCC.COM
    Sent: Thursday, December 12, 2002 4:44 PM
    To: bsilverio@necc.mass.edu
    Subject: RE: DBD on HPUX

    Here is a makefile the builds a working DBD-Oracle on:

    $ uname -a
    HP-UX hostname B.11.11 U 9000/800 612309363 unlimited-user license
    $

    Using the /opt/softbench compiler.


    AH... I think I see what might be a problem... have you thought about asking
    your DBA's to put up atleast the binaries for the 64 bit oracle.

    You can still run your databases in the 32 bit version if you insist, but
    connect with perl through the 64bit client.

    Lincoln


    -----Original Message-----
    From: Brian D. Silverio
    Sent: Thursday, December 12, 2002 4:35 PM
    To: dbi-users@perl.org
    Subject: DBD on HPUX

    Greetings,
    I have spent about two weeks going over the archives and reading
    everything I can find out the DBD on hpux. I still can't get it to work
    Short form:
    HPUX 11.11 64 bit
    Oracle 8.1.7 32 bit
    HP extra cost compiler
    Perl 5.8.0 and 5.6.1 used
    DBI 1.18, 1,25 and 1.30 all tried
    DBD 1.07 and 1.12 tried.
    Non threading, -lcl and lpthreads added, +z added,
    +Z also tried alone and in combo with +z
    perl Makefile.PL -l tried

    Can not shl_load()....etc....

    Static builds also tried they will not link properly
    used the symbol finder script to find the missing symbols, add the
    libraries and they are still not found.

    At this point I have tried each and every thing I can find on google. I
    still can't make it work.

    Can anyone offer additional suggestions?

    I am new to HPUX but have been working with unix since 1985.

    Thanks
    Brian

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdbi-users @
categoriesperl
postedDec 12, '02 at 9:33p
activeDec 16, '02 at 6:56p
posts5
users3
websitedbi.perl.org

People

Translate

site design / logo © 2022 Grokbase