FAQ
Hi there,

I was trying to install the DBI module in a windows 2000 OS and Im using the
activeperl.

I was not able to install successfully below is the issue I'm encountering.

Thanks.


D:\Downloads\DBI-1.20.tar\DBI-1.20>perl Makefile.pl

*** You are using a perl with experimental threading enabled!
*** You should be aware that using multiple threads is unstable
*** are should NOT be done in production environments.
DBI thread mutex protection is enabled

*** Note:
The optional PlRPC-modules (RPC::PlServer etc) are not installed.
If you want to use the DBD::Proxy driver and DBI::ProxyServer
modules, then you'll need to install the RPC::PlServer, RPC::PlClient,
Storable and Net::Daemon modules. The CPAN Bundle::DBI may help you.
You can install them any time after installing the DBI.
You do *not* need these modules for typical DBI usage.

Optional modules are available from any CPAN mirror, in particular
http://www.perl.com/CPAN/modules/by-module
http://www.perl.org/CPAN/modules/by-module
ftp://ftp.funet.fi/pub/languages/perl/CPAN/modules/by-module

Writing Makefile for DBI

Remember to actually *read* the README file!
Use 'make' to build the software (dmake or nmake on Windows).
Then 'make test' to execute self tests.
Then 'make install' to install the DBI and then delete this working
directory before unpacking and building any DBD::* drivers.

Windows users need to use the correct make command.
That may be nmake or dmake depending on which Perl you are using.
If using the Win32 ActiveState build then it is recommended that you
use the ppm utility to fetch and install a prebuilt DBI instead.

Search Discussions

  • KAWAI,Takanori at May 9, 2002 at 12:30 am
    ----- Original Message -----
    From: <Reynv@aol.com>
    To: <dbi-users@perl.org>
    Sent: Thursday, May 09, 2002 8:20 AM
    Subject: Trying to install DBI

    Hi there,

    I was trying to install the DBI module in a windows 2000 OS and Im using the
    activeperl.

    I was not able to install successfully below is the issue I'm
    encountering.
    (snip)

    Did you read last these lines?
    If using the Win32 ActiveState build then it is recommended that you
    use the ppm utility to fetch and install a prebuilt DBI instead.
    And this page may be a help for you.

    Using PPM to install modules:
    http://aspn.activestate.com/ASPN/Products/ActivePerl/faq/ActivePerl-faq2.htm
    l

    ==============================================
    Kawai, Takanori(Hippo2000)
    Mail: GCD00051@nifty.ne.jp kwitknr@cpan.org
    http://member.nifty.ne.jp/hippo2000/index_e.htm
    http://www.hippo2000.info/cgi-bin/KbWikiE/KbWiki.pl
    ==============================================

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdbi-users @
categoriesperl
postedMay 8, '02 at 11:21p
activeMay 9, '02 at 12:30a
posts2
users2
websitedbi.perl.org

2 users in discussion

KAWAI,Takanori: 1 post Reynv: 1 post

People

Translate

site design / logo © 2022 Grokbase