FAQ
Hi - can't build DBD-Pg because it can't find version.pm.

OS version=CentOS 5.3
Perl version=5.8.8
DBI version=1.609
DBD-Pg version=2.16.1
PostrgeSQL version=8.3.7

Enclosed is the error message.

-- Cinaed


Configuring DBD::Pg 2.16.1
PostgreSQL version: 80307 (default port: 5432)
POSTGRES_HOME: /usr/pgsql
POSTGRES_INCLUDE: /usr/pgsql/include
POSTGRES_LIB: /usr/pgsql/lib
OS: linux
Warning: prerequisite version 0 not found.
Could not eval '
package ExtUtils::MakeMaker::_version;
no strict;
BEGIN { eval {
# Ensure any version() routine which might have leaked
# into this package has been deleted. Interferes with
# version->import()
undef *version;
require version;
"version"->import;
} }

local $VERSION;
$VERSION=undef;
do {
use version; our $VERSION = qv('2.16.1');

- };
$VERSION;
' in Pg.pm: Can't locate version.pm in @INC (@INC
contains:t/lib /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_per/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/li/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl /usr/lib/perl5/vendor_p/5.8.8/
i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl
/5.8.5 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at
(eval 9) line 16, <$fh> line 20.
BEGIN failed--compilation aborted at (eval 9) line 16, <$fh> line 20.
WARNING: Setting VERSION via file 'Pg.pm' failed at
/usr/lib/perl5/5.8./ExtUtils/MakeMaker.pm line 571 Using DBI 1.609 (for
perl 5.008008on i386-linux-thread-multi) installed in
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/DBI/ Writing
Makefile for DBD::Pg




--

"We are drowning in information and starving for knowledge."

- Rutherford D. Roger

Search Discussions

  • David E. Wheeler at Feb 13, 2010 at 9:41 pm

    On Feb 10, 2010, at 12:55 PM, Cinaed Simson wrote:

    Hi - can't build DBD-Pg because it can't find version.pm.

    OS version=CentOS 5.3
    Perl version=5.8.8
    DBI version=1.609
    DBD-Pg version=2.16.1
    PostrgeSQL version=8.3.7

    Enclosed is the error message.
    cpan version

    Best,

    David
  • Alvar Freude at Feb 13, 2010 at 9:48 pm
    Hi,

    -- Cinaed Simson wrote:
    Hi - can't build DBD-Pg because it can't find version.pm.
    the best way to install Perl Modules is always to use the CPAN shell. It
    handles prerequisite automatically.

    Just type "cpan" (usually as root), and there "install DBD::Pg". Perhaps
    you may configure it at the first time ...


    Ciao
    Alvar


    --
    ** Alvar C.H. Freude, http://alvar.a-blast.org/
    ** http://www.assoziations-blaster.de/
    ** http://www.wen-waehlen.de/
    ** http://www.perl-blog.de/

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdbd-pg @
categoriesperl
postedFeb 10, '10 at 8:57p
activeFeb 13, '10 at 9:48p
posts3
users3
websiteperl.org

People

Translate

site design / logo © 2022 Grokbase