FAQ
Running Windows XPSP3

I've added several cygwin packages;
Postgresql 8.2.9-1
postgresql-client 8.2.9-1
postgresql-devel 8.2.9-1
libpq5 8.2.9-1

I've compiled
DBI-1.607

$ perl Makefile.PL
Configuring DBD::Pg 2.10.3
PostgreSQL version: 80209 (default port: 5432)
POSTGRES_HOME: (not set)
POSTGRES_INCLUDE: /usr/include
POSTGRES_LIB: /lib
OS: cygwin
Checking if your kit is complete...
Looks good
Using DBI 1.607 (for perl 5.010000 on cygwin-thread-multi-64int) installed in /u
sr/lib/perl5/site_perl/5.10/i686-cygwin/auto/DBI/
Writing Makefile for DBD::Pg

$ make
cp lib/Bundle/DBD/Pg.pm blib/lib/Bundle/DBD/Pg.pm
cp Pg.pm blib/lib/DBD/Pg.pm
/usr/bin/perl.exe -p -e "s/~DRIVER~/Pg/g; s/^do\(/dontdo\(/" /usr/lib/perl5/site
_perl/5.10/i686-cygwin/auto/DBI/Driver.xst > Pg.xsi
/usr/bin/perl.exe /usr/lib/perl5/5.10/ExtUtils/xsubpp -typemap /usr/lib/perl5/5
.10/ExtUtils/typemap Pg.xs > Pg.xsc && mv Pg.xsc Pg.c
gcc -c -I/usr/include -I/usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/DBI -DPE
RL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -fno-strict-aliasing -pipe -I/usr/local/inc
lude -DPGLIBVERSION=80209 -DPGDEFPORT=5432 -DUSEIMPORTLIB -O3 -DVERSION=\"2.10
.3\" -DXS_VERSION=\"2.10.3\" "-I/usr/lib/perl5/5.10/i686-cygwin/CORE" Pg.c
gcc -c -I/usr/include -I/usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/DBI -DPE
RL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -fno-strict-aliasing -pipe -I/usr/local/inc
lude -DPGLIBVERSION=80209 -DPGDEFPORT=5432 -DUSEIMPORTLIB -O3 -DVERSION=\"2.10
.3\" -DXS_VERSION=\"2.10.3\" "-I/usr/lib/perl5/5.10/i686-cygwin/CORE" dbdimp.
c
gcc -c -I/usr/include -I/usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/DBI -DPE
RL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -fno-strict-aliasing -pipe -I/usr/local/inc
lude -DPGLIBVERSION=80209 -DPGDEFPORT=5432 -DUSEIMPORTLIB -O3 -DVERSION=\"2.10
.3\" -DXS_VERSION=\"2.10.3\" "-I/usr/lib/perl5/5.10/i686-cygwin/CORE" quote.c

gcc -c -I/usr/include -I/usr/lib/perl5/site_perl/5.10/i686-cygwin/auto/DBI -DPE
RL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -fno-strict-aliasing -pipe -I/usr/local/inc
lude -DPGLIBVERSION=80209 -DPGDEFPORT=5432 -DUSEIMPORTLIB -O3 -DVERSION=\"2.10
.3\" -DXS_VERSION=\"2.10.3\" "-I/usr/lib/perl5/5.10/i686-cygwin/CORE" types.c

rm -f blib/arch/auto/DBD/Pg/Pg.dll
g++ --shared -Wl,--enable-auto-import -Wl,--export-all-symbols -Wl,--stack,838
8608 -Wl,--enable-auto-image-base -L/usr/local/lib Pg.o dbdimp.o quote.o types.o
-o blib/arch/auto/DBD/Pg/Pg.dll \
/usr/lib/perl5/5.10/i686-cygwin/CORE/libperl.dll.a -L/lib -lpq \

chmod 755 blib/arch/auto/DBD/Pg/Pg.dll
test -s Pg.bs && cp Pg.bs blib/arch/auto/DBD/Pg/Pg.bs && \
chmod 644 blib/arch/auto/DBD/Pg/Pg.bs
make: [blib/arch/auto/DBD/Pg/Pg.dll] Error 1 (ignored)

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdbd-pg @
categoriesperl
postedSep 12, '08 at 3:45p
activeSep 12, '08 at 3:45p
posts1
users1
websiteperl.org

1 user in discussion

Mouse: 1 post

People

Translate

site design / logo © 2022 Grokbase