It seems that the new PERL5OPT trick for enabling Devel::Autoflush may
cause that old module versions will be used while testing. See
http://rt.cpan.org/Ticket/Display.html?id=37437

Regards,
Slaven

--
Slaven Rezic - slaven <at> rezic <dot> de

tktimex - time recording tool
http://sourceforge.net/projects/ptktools/

Search Discussions

  • Andy Armstrong at Jul 5, 2008 at 4:12 pm

    On 5 Jul 2008, at 16:37, Slaven Rezic wrote:

    It seems that the new PERL5OPT trick for enabling Devel::Autoflush may
    cause that old module versions will be used while testing. See
    http://rt.cpan.org/Ticket/Display.html?id=37437

    Ah - that would explain some of the 'impossible' failures I've been
    seeing :)

    Like:
    http://www.nntp.perl.org/group/perl.cpan.testers/2008/07/msg1854435.html

    --
    Andy Armstrong, Hexten
  • David Golden at Jul 5, 2008 at 5:08 pm

    On Sat, Jul 5, 2008 at 12:12 PM, Andy Armstrong wrote:
    On 5 Jul 2008, at 16:37, Slaven Rezic wrote:

    It seems that the new PERL5OPT trick for enabling Devel::Autoflush may
    cause that old module versions will be used while testing. See
    http://rt.cpan.org/Ticket/Display.html?id=37437
    Fixed in 1.1601. Sorry about that.

    That problem was caused by 1.15_56 (out since the middle of June) and
    there were no problem reports with it. I suspected that releasing
    1.16 would flush out bugs in a hurry. And it did.

    David

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcpan-testers-discuss @
categoriesperl
postedJul 5, '08 at 3:37p
activeJul 5, '08 at 5:08p
posts3
users3
websitecpan.org

People

Translate

site design / logo © 2021 Grokbase