FAQ
- installing Tk on macosx 10.2.6 with perl 5.6


hola

i agree it is not a pure perl question yet
but it will be one soon

i downloaded Tk800.025.tar.gz from cpan

% perl Makefile.pl
gives me this outpouring :

perl is installed in /System/Library/Perl/darwin okay
PPM for perl5.006
Test Compiling config/signedchar.c
Test Compiling config/Ksprintf.c
Test Compiling config/tod.c
Test Compiling -DTIMEOFDAY_TZ config/tod.c
TZ gettimeofday()
Using -L/usr/X11R6/lib to find /usr/X11R6/lib/libX11.6.dylib
Cannot find X include files via /usr/X11R6/include
Cannot find X include files anywhere at ./myConfig line 312.
Compilation failed in require at Makefile.pl line 31.
BEGIN failed--compilation aborted at Makefile.pl line 33.

i have X11R6 installed

i have also tried to run the makefile with arguments
X11=/usr/X11R6
even with arguments to the lib and include folders

i have looked very hard at ./myConfig file
and tried to manipulate the process
but of no avail

does anybody know a solution ?

thank you !

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupbeginners @
categoriesperl
postedJan 24, '04 at 7:57p
activeJan 24, '04 at 7:57p
posts1
users1
websiteperl.org

1 user in discussion

Johan Meskens CS3 jmcs3: 1 post

People

Translate

site design / logo © 2022 Grokbase