FAQ
Hi all,

maybe someone could help me with this.
I have a x:dataTable and one column is displaying checkboxes which
values are bound to a backing bean property.
So when I now check a checkbox and then use dataScroller to scroll
through the table, the value of the checkbox is not updated, will say,
when I scroll back, the "checked" value of the box is disappeared.

With commandSortHeader the value remains.

Any ideas?

Best rgds
Alex

Search Discussions

  • Slawek at May 15, 2005 at 5:02 pm
    notice that all data and actions that submits that data must be in form
    (the same form)

    slawek
    Hi all,

    maybe someone could help me with this.
    I have a x:dataTable and one column is displaying checkboxes which
    values are bound to a backing bean property.
    So when I now check a checkbox and then use dataScroller to scroll
    through the table, the value of the checkbox is not updated, will say,
    when I scroll back, the "checked" value of the box is disappeared.

    With commandSortHeader the value remains.

    Any ideas?

    Best rgds
    Alex
  • Alex at May 15, 2005 at 5:18 pm

    Slawek wrote:

    notice that all data and actions that submits that data must be in
    form (the same form)
    They are in the same form. This is, why it is so strange.
  • Slawek at May 15, 2005 at 5:29 pm
    just guessing (cause i have seen such a problem few times): maybe u have
    access to database in getter of your datamodel?
    if so, than data is feetch everytime u go to the next page and your
    checkoboxes are set to false.

    Slawek
    Slawek wrote:
    notice that all data and actions that submits that data must be in form
    (the same form)
    They are in the same form. This is, why it is so strange.
  • Alex at May 15, 2005 at 5:41 pm

    Slawek wrote:

    just guessing (cause i have seen such a problem few times): maybe u
    have access to database in getter of your datamodel?
    No, I have a logger which logs database access. When using dataScroller
    the logger has no outcome. And it cannot have, because the datamodel is
    populated by an actionmethod of a backing bean bound to a button.
  • Sean Schofield at May 15, 2005 at 7:01 pm
    There could be a bug. There are known problems with input components
    and sort header (See MYFACES-228.) I'm hoping to look into more of
    the dataTable stuff over the next few weeks so I will try and look
    into this issue as well. Keep us posted on what you find and if
    you're convinced there is a bug (or even suspect if) make sure to add
    an issue in JIRA.

    sean
    On 5/15/05, alex wrote:
    Slawek wrote:
    just guessing (cause i have seen such a problem few times): maybe u
    have access to database in getter of your datamodel?
    No, I have a logger which logs database access. When using dataScroller
    the logger has no outcome. And it cannot have, because the datamodel is
    populated by an actionmethod of a backing bean bound to a button.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriesmyfaces
postedMay 15, '05 at 2:09p
activeMay 15, '05 at 7:01p
posts6
users3
websitemyfaces.apache.org

3 users in discussion

Alex: 3 posts Slawek: 2 posts Sean Schofield: 1 post

People

Translate

site design / logo © 2019 Grokbase