FAQ
I've just upgraded Apache and Embperl won't compile.

Embperl 2.2.0
GenToo Linux
Apache 2.2.6
apr 1.2.8
libapreq2 2.08

These are the error messages I get:
---------------------------------------------------------------
/usr/bin/perl5.8.8 /usr/lib/perl5/5.8.8/ExtUtils/xsubpp -typemap /usr/lib/perl5/5.8.8/ExtUtils/typemap -typemap ../../typemap App.xs > App.xsc && mv App.xsc App.c
i686-pc-linux-gnu-gcc -c -I/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0 -I/usr/include/apache2 -I/usr/include/apache2/regex -I/usr/include/apache2/os/unix -I/usr/include/apr-1 -I/usr/include/libxml2 -I/usr/include/libxml2 -I/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/xs -fno-strict-aliasing -pipe -Wdeclaration-after-statement -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -march=prescott -O2 -pipe -fomit-frame-pointer -DVERSION=\"2.2.0\" -DXS_VERSION=\"2.2.0\" -fPIC "-I/usr/lib/perl5/5.8.8/i686-linux/CORE" -DAPACHE -DAPACHE2 -DEP2 -DLIBXSLT App.c
In file included from /usr/include/apache2/ap_config.h:25,
from /usr/include/apache2/httpd.h:43,
from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
from App.xs:13:
/usr/include/apr-1/apr.h:270: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'apr_off_t'
In file included from /usr/include/apr-1/apr_file_io.h:29,
from /usr/include/apr-1/apr_network_io.h:26,
from /usr/include/apache2/httpd.h:53,
from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
from App.xs:13:
/usr/include/apr-1/apr_file_info.h:204: error: expected specifier-qualifier-list before 'apr_off_t'
In file included from /usr/include/apr-1/apr_network_io.h:26,
from /usr/include/apache2/httpd.h:53,
from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
from App.xs:13:
/usr/include/apr-1/apr_file_io.h:551: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_file_io.h:746: error: expected declaration specifiers or '...' before 'apr_off_t'
In file included from /usr/include/apache2/httpd.h:53,
from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
from App.xs:13:
/usr/include/apr-1/apr_network_io.h:545: error: expected declaration specifiers or '...' before 'apr_off_t'
In file included from /usr/include/apr-1/apr_buckets.h:32,
from /usr/include/apache2/httpd.h:54,
from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
from App.xs:13:
/usr/include/apr-1/apr_mmap.h:134: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_mmap.h:161: error: expected declaration specifiers or '...' before 'apr_off_t'
In file included from /usr/include/apache2/httpd.h:54,
from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
from App.xs:13:
/usr/include/apr-1/apr_buckets.h:242: error: expected specifier-qualifier-list before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:706: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:718: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:754: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:890: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:891: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:1168: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:1367: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:1381: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:1431: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_buckets.h:1447: error: expected declaration specifiers or '...' before 'apr_off_t'
In file included from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
from App.xs:13:
/usr/include/apache2/httpd.h:848: error: expected specifier-qualifier-list before 'apr_off_t'
In file included from /usr/include/apache2/http_protocol.h:34,
from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:150,
from App.xs:13:
/usr/include/apache2/util_filter.h:142: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apache2/util_filter.h:299: error: expected declaration specifiers or '...' before 'apr_off_t'
In file included from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:150,
from App.xs:13:
/usr/include/apache2/http_protocol.h:111: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apache2/http_protocol.h:203: error: expected declaration specifiers or '...' before 'apr_off_t'
In file included from /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:159,
from App.xs:13:
/usr/include/apr-1/apr_strings.h:299: error: expected declaration specifiers or '...' before 'apr_off_t'
/usr/include/apr-1/apr_strings.h:315: error: expected ')' before '*' token
/usr/include/apr-1/apr_strings.h:351: error: expected ')' before 'size'
make[3]: *** [App.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/xs/Embperl/App'
make[2]: *** [subdirs] Error 2
make[2]: Leaving directory `/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/xs/Embperl'
make[1]: *** [subdirs] Error 2
make[1]: Leaving directory `/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/xs'
make: *** [subdirs] Error 2
---------------------------------------------------------------

Help!
My website is now completely broken because I no longer have a working
Embperl. Trying to downgrade didn't work.

Kathryn Andersen
--
_--_|\ | Kathryn Andersen <http://www.katspace.com>
/ \ |
\_.--.*/ | GenFicCrit mailing list <http://www.katspace.com/gen_fic_crit/>
v |
------------| Melbourne -> Victoria -> Australia -> Southern Hemisphere
Maranatha! | -> Earth -> Sol -> Milky Way Galaxy -> Universe

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org

Search Discussions

  • Kathryn Andersen at Sep 13, 2007 at 9:20 pm

    On Thu, Sep 13, 2007 at 08:32:43AM +1000, Kathryn Andersen wrote:
    I've just upgraded Apache and Embperl won't compile.

    Embperl 2.2.0
    GenToo Linux
    Apache 2.2.6
    apr 1.2.8
    libapreq2 2.08
    Is there any further information I need to provide? I desperately need
    help on this!

    Kathryn Andersen
    --
    _--_|\ | Kathryn Andersen <http://www.katspace.com>
    / \ |
    \_.--.*/ | GenFicCrit mailing list <http://www.katspace.com/gen_fic_crit/>
    v |
    ------------| Melbourne -> Victoria -> Australia -> Southern Hemisphere
    Maranatha! | -> Earth -> Sol -> Milky Way Galaxy -> Universe

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Matthew A. Bockol at Sep 13, 2007 at 11:08 pm
    Hi Kathryn,

    I suspect part of your problem is the APR 1.2.8. Httpd2.2.6 seems to come with 1.2.11 -- Make sure to push apr-1-config and apu-1-config out of your path, the configuration step is probably detecting the older version and trying to build against it. I'd try re-running ./configure and rebuilding for httpd , then re doing the perl Makefile.PL ; make ; make install for mod_perl, and embperl.

    Good luck,
    Matt


    ----- Original Message -----
    From: "Kathryn Andersen" <kat_lists@katspace.homelinux.org>
    To: embperl@perl.apache.org
    Sent: Thursday, September 13, 2007 4:20:15 PM (GMT-0600) America/Chicago
    Subject: Re: Problem with Apache 2.2.6
    On Thu, Sep 13, 2007 at 08:32:43AM +1000, Kathryn Andersen wrote:
    I've just upgraded Apache and Embperl won't compile.

    Embperl 2.2.0
    GenToo Linux
    Apache 2.2.6
    apr 1.2.8
    libapreq2 2.08
    Is there any further information I need to provide? I desperately need
    help on this!

    Kathryn Andersen
    --
    _--_|\ | Kathryn Andersen <http://www.katspace.com>
    / \ |
    \_.--.*/ | GenFicCrit mailing list <http://www.katspace.com/gen_fic_crit/>
    v |
    ------------| Melbourne -> Victoria -> Australia -> Southern Hemisphere
    Maranatha! | -> Earth -> Sol -> Milky Way Galaxy -> Universe

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org



    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Kathryn Andersen at Sep 14, 2007 at 12:52 am

    On Thu, Sep 13, 2007 at 06:07:20PM -0500, Matthew A. Bockol wrote:
    I suspect part of your problem is the APR 1.2.8. Httpd2.2.6 seems to
    come with 1.2.11 -- Make sure to push apr-1-config and apu-1-config
    out of your path, the configuration step is probably detecting the
    older version and trying to build against it. I'd try re-running
    ./configure and rebuilding for httpd , then re doing the perl
    Makefile.PL ; make ; make install for mod_perl, and embperl.
    Thanks, I'll try that. Though I'm puzzled a bit because GenToo has
    marked apr 1.2.11 as unstable while Apache 2.2.6 is marked stable, so
    they must think that Apache 2.2.6 goes with apr 1.2.8; I fear that
    something will break. But since things are already broken, I guess it
    can't hurt much.

    Kathryn Andersen
    --
    _--_|\ | Kathryn Andersen <http://www.katspace.com>
    / \ |
    \_.--.*/ | GenFicCrit mailing list <http://www.katspace.com/gen_fic_crit/>
    v |
    ------------| Melbourne -> Victoria -> Australia -> Southern Hemisphere
    Maranatha! | -> Earth -> Sol -> Milky Way Galaxy -> Universe

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Kathryn Andersen at Sep 15, 2007 at 1:41 am

    On Thu, Sep 13, 2007 at 06:07:20PM -0500, Matthew A. Bockol wrote:
    I suspect part of your problem is the APR 1.2.8. Httpd2.2.6 seems to
    come with 1.2.11 -- Make sure to push apr-1-config and apu-1-config
    out of your path, the configuration step is probably detecting the
    older version and trying to build against it. I'd try re-running
    ./configure and rebuilding for httpd , then re doing the perl
    Makefile.PL ; make ; make install for mod_perl, and embperl.
    I tried this; I made sure that the only apr that was installed was
    1.2.11, but the same errors occurred. This is really BAD.

    HELP!!!!!!!!!!!!!!!!!!!!!!

    Kathryn Andersen
    --
    _--_|\ | Kathryn Andersen <http://www.katspace.com>
    / \ |
    \_.--.*/ | GenFicCrit mailing list <http://www.katspace.com/gen_fic_crit/>
    v |
    ------------| Melbourne -> Victoria -> Australia -> Southern Hemisphere
    Maranatha! | -> Earth -> Sol -> Milky Way Galaxy -> Universe

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Kathryn Andersen at Sep 15, 2007 at 5:39 am

    On Thu, Sep 13, 2007 at 06:07:20PM -0500, Matthew A. Bockol wrote:
    I suspect part of your problem is the APR 1.2.8. Httpd2.2.6 seems to
    come with 1.2.11 -- Make sure to push apr-1-config and apu-1-config
    out of your path, the configuration step is probably detecting the
    older version and trying to build against it. I'd try re-running
    ./configure and rebuilding for httpd , then re doing the perl
    Makefile.PL ; make ; make install for mod_perl, and embperl.
    Well, I have now done the *opposite* of what you suggested, and that is
    to downgrade to Apache 2.0.59 and apr 0.9.12, and that seems to have
    done the trick, though it's obviously only a temporary solution.

    Guess I'll just have to use the time to find something else to use
    instead of Embperl.

    Kathryn Andersen
    --
    _--_|\ | Kathryn Andersen <http://www.katspace.com>
    / \ |
    \_.--.*/ | GenFicCrit mailing list <http://www.katspace.com/gen_fic_crit/>
    v |
    ------------| Melbourne -> Victoria -> Australia -> Southern Hemisphere
    Maranatha! | -> Earth -> Sol -> Milky Way Galaxy -> Universe

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Andrew O'Brien at Sep 16, 2007 at 11:19 pm
    Hi Kathryn,
    Well, I have now done the *opposite* of what you suggested,
    and that is
    to downgrade to Apache 2.0.59 and apr 0.9.12, and that seems to have
    done the trick, though it's obviously only a temporary solution.
    So this was the original configuration?

    I'm curious - what features in 2.2.6 do you need that 2.0.59 (latest is
    .61 I think) doesn't provide? Any distro (and apache for that matter)
    will keep releasing security fixes for quite a while yet if that was the
    driver?
    Guess I'll just have to use the time to find something else to use
    instead of Embperl.
    Seems a bit drastic based on 4 days of no solution to a problem with the
    absolute latest version of apache 2.2 but if there are other drivers
    then by all means.
    From previous messages to the list the embperl crowd seems to be slower
    to move to the latest and greatest - I know for myself I still have at
    least one large production site running on 1.3.6 and apache 1.3.x. If it
    ain't broke and all that :) This may well be the reason noone has piped
    up.

    What is the latest combination of apache/embperl that is supported by
    your distro?

    - andrew


    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Kathryn Andersen at Sep 17, 2007 at 12:06 am

    On Mon, Sep 17, 2007 at 09:20:26AM +1000, Andrew O'Brien wrote:
    What is the latest combination of apache/embperl that is supported by
    your distro?
    Apache 2.2.6 *is* the current supported version of Apache on my distro
    (GenToo). That's why I was installing it; it was a routine upgrade as
    far as I was concerned.

    I've been using Embperl 2.2.0 ever since there's been an Embperl 2.2.0.

    Kathryn Andersen
    --
    _--_|\ | Kathryn Andersen <http://www.katspace.com>
    / \ |
    \_.--.*/ | GenFicCrit mailing list <http://www.katspace.com/gen_fic_crit/>
    v |
    ------------| Melbourne -> Victoria -> Australia -> Southern Hemisphere
    Maranatha! | -> Earth -> Sol -> Milky Way Galaxy -> Universe

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Andrew O'Brien at Sep 17, 2007 at 12:58 am

    On Mon, Sep 17, 2007 at 09:20:26AM +1000, Andrew O'Brien wrote:
    What is the latest combination of apache/embperl that is
    supported by
    your distro?
    Apache 2.2.6 *is* the current supported version of Apache on my distro
    (GenToo). That's why I was installing it; it was a routine upgrade as
    far as I was concerned.
    Wasn't what I asked - I asked what *combination* is supported by GenToo.
    I'm assuming from your response that embperl is not in the GenToo
    package system? Ie that it is not available with local patches to
    support the GenToo environment and software.

    I've currently got embperl 2.2.0 deployed on debian stable (etch) with
    some local patches for cookie handling but that was a small matter of
    recompiling based on pre-provided and pre-patched source code. I can
    attest to the fact that it does work fine with the following
    environment:

    Apache 2.2.3
    Modperl 2.0.2
    Libapr 1.2.7
    Embperl 2.2.0

    Looking at the most recent debian packages, the unstable branch has the
    following packages:

    Apache 2.2.6
    Modperl 2.0.2
    Libapr 1.2.7 <---
    Embperl 2.2.0

    So I can assume that the older libapr did the trick with the more recent
    apache version.

    If you use lower versions of libapr with later apache 2.2.6 then how do
    you go?

    If that is still failing then my advice to you at this point would be to
    stick to 2.0.59 and set up a VM with the latest and greatest for
    testing.

    If you're the first person to hit bugs with this particular comination
    of software then you'll want a platform available to work with the
    embperl powers-that-be (ie those that can actually remember how to
    program in C ;-) ) which , unfortunately, is not me any longer.

    Hope that helps.

    - andrew


    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Gerald Richter - ECOS GmbH at Sep 28, 2007 at 10:01 pm

    I've just upgraded Apache and Embperl won't compile.

    Embperl 2.2.0
    GenToo Linux
    Apache 2.2.6
    apr 1.2.8
    libapreq2 2.08

    These are the error messages I get:
    As far as I can see that is something you have to blame your
    distribution for.

    I have no problems running Embperl with Apache 2.2.6, but I have
    installed Apache, mod_perl and Embperl from the sources.

    It seems that on your system the type off64_t is not defined, which it
    normaly should.

    Maybe on your system there is some additional include file necessary or
    some additional compiler setting or simply your perl, mod_perl and
    apache are compiled with different settings (which is the most likely
    reason).

    You can try to recompile Perl, mod_perl and Apache and make sure that to
    use all the same compiler and settings.

    If this doesn't help, you have to figure out where the type off64_t is
    defined on your system and why it is not available to the Apache include
    files.

    Gerald



    ---------------------------------------------------------------
    /usr/bin/perl5.8.8 /usr/lib/perl5/5.8.8/ExtUtils/xsubpp
    -typemap /usr/lib/perl5/5.8.8/ExtUtils/typemap -typemap
    ../../typemap App.xs > App.xsc && mv App.xsc App.c
    i686-pc-linux-gnu-gcc -c
    -I/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0
    -I/usr/include/apache2 -I/usr/include/apache2/regex
    -I/usr/include/apache2/os/unix -I/usr/include/apr-1
    -I/usr/include/libxml2 -I/usr/include/libxml2
    -I/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/x
    s -fno-strict-aliasing -pipe -Wdeclaration-after-statement
    -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
    -I/usr/include/gdbm -march=prescott -O2 -pipe
    -fomit-frame-pointer -DVERSION=\"2.2.0\"
    -DXS_VERSION=\"2.2.0\" -fPIC
    "-I/usr/lib/perl5/5.8.8/i686-linux/CORE" -DAPACHE -DAPACHE2
    -DEP2 -DLIBXSLT App.c
    In file included from /usr/include/apache2/ap_config.h:25,
    from /usr/include/apache2/httpd.h:43,
    from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
    from App.xs:13:
    /usr/include/apr-1/apr.h:270: error: expected '=', ',', ';',
    'asm' or '__attribute__' before 'apr_off_t'
    In file included from /usr/include/apr-1/apr_file_io.h:29,
    from /usr/include/apr-1/apr_network_io.h:26,
    from /usr/include/apache2/httpd.h:53,
    from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
    from App.xs:13:
    /usr/include/apr-1/apr_file_info.h:204: error: expected
    specifier-qualifier-list before 'apr_off_t'
    In file included from /usr/include/apr-1/apr_network_io.h:26,
    from /usr/include/apache2/httpd.h:53,
    from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
    from App.xs:13:
    /usr/include/apr-1/apr_file_io.h:551: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_file_io.h:746: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    In file included from /usr/include/apache2/httpd.h:53,
    from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
    from App.xs:13:
    /usr/include/apr-1/apr_network_io.h:545: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    In file included from /usr/include/apr-1/apr_buckets.h:32,
    from /usr/include/apache2/httpd.h:54,
    from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
    from App.xs:13:
    /usr/include/apr-1/apr_mmap.h:134: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_mmap.h:161: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    In file included from /usr/include/apache2/httpd.h:54,
    from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
    from App.xs:13:
    /usr/include/apr-1/apr_buckets.h:242: error: expected
    specifier-qualifier-list before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:706: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:718: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:754: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:890: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:891: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:1168: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:1367: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:1381: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:1431: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_buckets.h:1447: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    In file included from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:148,
    from App.xs:13:
    /usr/include/apache2/httpd.h:848: error: expected
    specifier-qualifier-list before 'apr_off_t'
    In file included from /usr/include/apache2/http_protocol.h:34,
    from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:150,
    from App.xs:13:
    /usr/include/apache2/util_filter.h:142: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apache2/util_filter.h:299: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    In file included from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:150,
    from App.xs:13:
    /usr/include/apache2/http_protocol.h:111: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apache2/http_protocol.h:203: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    In file included from
    /var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/ep.h:159,
    from App.xs:13:
    /usr/include/apr-1/apr_strings.h:299: error: expected
    declaration specifiers or '...' before 'apr_off_t'
    /usr/include/apr-1/apr_strings.h:315: error: expected ')'
    before '*' token
    /usr/include/apr-1/apr_strings.h:351: error: expected ')'
    before 'size'
    make[3]: *** [App.o] Error 1
    make[3]: Leaving directory
    `/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/xs
    /Embperl/App'
    make[2]: *** [subdirs] Error 2
    make[2]: Leaving directory
    `/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/xs
    /Embperl'
    make[1]: *** [subdirs] Error 2
    make[1]: Leaving directory
    `/var/tmp/portage/www-apps/Embperl-2.2.0/work/Embperl-2.2.0/xs'
    make: *** [subdirs] Error 2
    ---------------------------------------------------------------

    Help!
    My website is now completely broken because I no longer have
    a working Embperl. Trying to downgrade didn't work.

    Kathryn Andersen
    --
    _--_|\ | Kathryn Andersen <http://www.katspace.com>
    / \ |
    \_.--.*/ | GenFicCrit mailing list
    <http://www.katspace.com/gen_fic_crit/>
    v |
    ------------| Melbourne -> Victoria -> Australia -> Southern
    Hemisphere
    Maranatha! | -> Earth -> Sol -> Milky Way Galaxy -> Universe

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org


    ** Virus checked by BB-5000 Mailfilter **
    !DSPAM:416,46e86aca165981673413608!
    ** Virus checked by BB-5000 Mailfilter **

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupembperl @
categoriesmodperl, perl
postedSep 12, '07 at 10:33p
activeSep 28, '07 at 10:01p
posts10
users4
websiteperl.apache.org

People

Translate

site design / logo © 2022 Grokbase