FAQ
Hi,
What is actually happeing is, that mod_perl.pm is not found on your
system.
Shouldn't this be looking for mod_perl2.pm, not mod_perl.pm?
Yes, it should. Seems like most people have mod_perl.pm installed from
time before it was renamed.

To fix it goto Makefile.PL line 1058 and change CheckModule line to
"mod_perl2"

Gerald

So maybe you should reinstall/fully install mod_perl

Gerald


[Fri Aug 10 12:13:00 clawson@rebus
/usr/local/src/Embperl-2.2.0-build/Embperl-2.2.0:11] $ perl
Makefile.PL Found mod_perl 2.0 Build with support for Apache
mod_perl?(y/n) [y] Use /opt/apache2 as Apache source(y/n) [y] Will
use /opt/apache2 for Apache Headers Apache Version Server version:
Apache/2.2.4 (Unix) + Load dynamic module mod_actions.c
(/opt/apache2/modules/mod_actions.so)
+ Load dynamic module mod_cgi.c
(/opt/apache2/modules/mod_cgi.so)
+ Load dynamic module mod_alias.c
(/opt/apache2/modules/mod_alias.so)
+ Load dynamic module mod_env.c
(/opt/apache2/modules/mod_env.so)
+ Load dynamic module mod_perl.c
(/opt/apache2/modules/mod_perl.so)
+ Load dynamic module mod_mime.c
(/opt/apache2/modules/mod_mime.so)
+ Load dynamic module mod_dir.c
(/opt/apache2/modules/mod_dir.so)
+ mod_perl was build with USE_DSO
Test start /opt/apache2/bin/httpd
Test httpd will run as user clawson and group sorcerer Test httpd
will listen on port 8531 mod_perl not installed on this system
-> Cannot build for mod_perl without mod_perl installed!!
Found LWP::UserAgent Version 2.033
Found HTML::HeadParser Version 2.22
Apache::Session not installed on this system
-> Disable tests for persistent data storage
Found File::Spec Version 3.12
Found CGI Version 3.15
Found libxml2 2.6.10 installed under /usr Found libxslt 1.1.7
installed under /usr Enter path of XALAN base directory or
single dot
for not using XALAN [.] Xalan will not be linked into
Embperl Writing
Makefile for Embperl::App::Config Writing Makefile for
Embperl::App
Writing Makefile for Embperl::Component::Config Writing
Makefile for
Embperl::Component::Output Writing Makefile for
Embperl::Component::Param Writing Makefile for Embperl::Component
Writing Makefile for Embperl::Req::Config Writing Makefile for
Embperl::Req::Param Writing Makefile for Embperl::Req Writing
Makefile for Embperl::Syntax Writing Makefile for Embperl::Thread
Writing Makefile for Embperl Writing Makefile for WrapXS Writing
Makefile for Embperl


I have a fresh install of Apache/2.2.4 installed in /opt/apache2:

[Fri Aug 10 12:17:29 clawson@rebus /opt/apache2/bin:16]
$ ./httpd
-l Compiled in modules:
core.c
prefork.c
http_core.c
mod_so.c

mod_perl-2.0.3 is installed (after a successful make, make
test) as a DSO and is loaded in Apache:

[Fri Aug 10 12:18:03 clawson@rebus /opt/apache2/bin:18]
$ ./httpd
-M Loaded Modules:
core_module (static)
mpm_prefork_module (static)
http_module (static)
so_module (static)

....

perl_module (shared)
Syntax OK


Have I provided you enough information to help me get around this
error?

Thanks,
Dan


Dan Clawson
Office of Information Technology
University of Utah
(e) dan.clawson@utah.edu

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


** Virus checked by BB-5000 Mailfilter **
!DSPAM:416,46bcb0ce300257520495175!
** Virus checked by BB-5000 Mailfilter **
--
Dan

** Virus checked by BB-5000 Mailfilter **
!DSPAM:416,46c2ca39232831153946092!
** Virus checked by BB-5000 Mailfilter **

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupembperl @
categoriesmodperl, perl
postedAug 15, '07 at 11:02a
activeAug 15, '07 at 11:02a
posts1
users1
websiteperl.apache.org

1 user in discussion

Gerald Richter - ECOS GmbH: 1 post

People

Translate

site design / logo © 2022 Grokbase