FAQ
I have recently migrated a "legacy" embperl 1.3.4 application to embperl2c
running on Apache2. Most things run ok with a little bit of tweaking but
there is one annoying difference and it has to do with the behavior of
%fdat.

According to Gerald (and the way that %fdat behaved under 1.3.4):

"If you do not specify a default value for an input tag and a value for that
input tag is available in %fdat, Embperl will automatically insert this
value and send it to the browser. This is similar to the behavior of CGI.pm.
This means that if you post a form to itself, the browser will display the
values you just entered"

My problem is that where my form fields used to automatically display values
from %fdat, now they don't and I find myself writing value="[+
$fdat{fieldname} +]" into my input tags.

Is this a known bug and is there a workaround?
Is it a bug or a feature?

Thanks for your help!



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org

Search Discussions

  • Gerald Richter at Dec 5, 2002 at 5:03 am

    My problem is that where my form fields used to automatically display values
    from %fdat, now they don't and I find myself writing value="[+
    $fdat{fieldname} +]" into my input tags.
    This works the same way as in 1.3.4. I am not aware of a bug with input tags
    (2.0b8 has a bug with escaping inside of values, which is fixed in the
    current cvs version, but it still works). If it doesn't work for you, can
    you make a small example page that shows the problem?

    Gerald


    -------------------------------------------------------------
    Gerald Richter ecos electronic communication services gmbh
    Internetconnect * Webserver/-design/-datenbanken * Consulting

    Post: Tulpenstrasse 5 D-55276 Dienheim b. Mainz
    E-Mail: richter@ecos.de Voice: +49 6133 925131
    WWW: http://www.ecos.de Fax: +49 6133 925152
    -------------------------------------------------------------


    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • David G. Williams at Dec 5, 2002 at 3:33 pm
    Gerald et al,

    Here's a page that demonstrates the behavior I described in my previous
    post:
    http://dev.cogenttechnology.com/epl/gerald.html

    And here's the code:

    [$syntax EmbperlBlocks$]
    <html><head><title>Gerald</title></head>
    <body>
    <h1>Hi Gerald!</h1>
    The input field below doesn't retain the value stored in %fdat. Type
    something in there and then click "Submit Query".
    <form method="post">
    <input type="text" name="myfield">
    <input type="submit" name="submit">
    </form>
    </body>
    </html>


    -----Original Message-----
    From: Gerald Richter
    Sent: Thursday, December 05, 2002 12:03 AM
    To: dwilliams@ifmp.nasa.gov; embperl@perl.apache.org
    Subject: Re: Behavior of %fdat in embperl2c

    My problem is that where my form fields used to automatically display values
    from %fdat, now they don't and I find myself writing value="[+
    $fdat{fieldname} +]" into my input tags.
    This works the same way as in 1.3.4. I am not aware of a bug with input tags
    (2.0b8 has a bug with escaping inside of values, which is fixed in the
    current cvs version, but it still works). If it doesn't work for you, can
    you make a small example page that shows the problem?

    Gerald


    -------------------------------------------------------------
    Gerald Richter ecos electronic communication services gmbh
    Internetconnect * Webserver/-design/-datenbanken * Consulting

    Post: Tulpenstrasse 5 D-55276 Dienheim b. Mainz
    E-Mail: richter@ecos.de Voice: +49 6133 925131
    WWW: http://www.ecos.de Fax: +49 6133 925152
    -------------------------------------------------------------



    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Gerald Richter at Dec 5, 2002 at 7:27 pm

    Here's a page that demonstrates the behavior I described in my previous
    post:
    http://dev.cogenttechnology.com/epl/gerald.html
    I get "server not found"
    And here's the code:

    [$syntax EmbperlBlocks$]
    Yes, of course if you turn off the processing of html tags, Embperl will not
    touch them.
    Remove the [$syntax EmbperlBlocks$] and it will work again.

    Gerald

    -------------------------------------------------------------
    Gerald Richter ecos electronic communication services gmbh
    Internetconnect * Webserver/-design/-datenbanken * Consulting

    Post: Tulpenstrasse 5 D-55276 Dienheim b. Mainz
    E-Mail: richter@ecos.de Voice: +49 6133 925131
    WWW: http://www.ecos.de Fax: +49 6133 925152
    -------------------------------------------------------------


    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • David G. Williams at Dec 6, 2002 at 2:44 pm
    The page is there.

    True, the problem is solved if you remove the [$syntax EmbperlBlocks$]. The
    problem is that my legacy html (and there's a lot of it) does not have tag
    attributes in quotes. e.g.
    instead of <input type="text" name="gerald"> my legacy code looks like this:
    <input type=text name=gerald>. Embperl 1.3.4 didn't mind but it looks as
    though 2.0 does. Do you have any workarounds other than just going back
    through all the code and enclosing all my attributes in double-quotes?

    -----Original Message-----
    From: Gerald Richter
    Sent: Thursday, December 05, 2002 2:28 PM
    To: dwilliams@ifmp.nasa.gov
    Cc: embperl@perl.apache.org
    Subject: Re: Behavior of %fdat in embperl2c

    Here's a page that demonstrates the behavior I described in my previous
    post:
    http://dev.cogenttechnology.com/epl/gerald.html
    I get "server not found"
    And here's the code:

    [$syntax EmbperlBlocks$]
    Yes, of course if you turn off the processing of html tags, Embperl will not
    touch them.
    Remove the [$syntax EmbperlBlocks$] and it will work again.

    Gerald

    -------------------------------------------------------------
    Gerald Richter ecos electronic communication services gmbh
    Internetconnect * Webserver/-design/-datenbanken * Consulting

    Post: Tulpenstrasse 5 D-55276 Dienheim b. Mainz
    E-Mail: richter@ecos.de Voice: +49 6133 925131
    WWW: http://www.ecos.de Fax: +49 6133 925152
    -------------------------------------------------------------



    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org
  • Gerald Richter at Dec 6, 2002 at 6:42 pm

    The page is there.
    But at least today morning the server wasn't found....
    True, the problem is solved if you remove the [$syntax EmbperlBlocks$]. The
    problem is that my legacy html (and there's a lot of it) does not have tag
    attributes in quotes. e.g.
    instead of <input type="text" name="gerald"> my legacy code looks like this:
    <input type=text name=gerald>. Embperl 1.3.4 didn't mind but it looks as
    though 2.0 does. Do you have any workarounds other than just going back
    through all the code and enclosing all my attributes in double-quotes?
    Embperl handle these too, as long as your attribte values only contains
    numbers and charaters. You can change the chars that are recognized in
    Embperl/Syntax/HTML.pm

    Gerald


    -----Original Message-----
    From: Gerald Richter
    Sent: Thursday, December 05, 2002 2:28 PM
    To: dwilliams@ifmp.nasa.gov
    Cc: embperl@perl.apache.org
    Subject: Re: Behavior of %fdat in embperl2c

    Here's a page that demonstrates the behavior I described in my previous
    post:
    http://dev.cogenttechnology.com/epl/gerald.html
    I get "server not found"
    And here's the code:

    [$syntax EmbperlBlocks$]
    Yes, of course if you turn off the processing of html tags, Embperl will not
    touch them.
    Remove the [$syntax EmbperlBlocks$] and it will work again.

    Gerald

    -------------------------------------------------------------
    Gerald Richter ecos electronic communication services gmbh
    Internetconnect * Webserver/-design/-datenbanken * Consulting

    Post: Tulpenstrasse 5 D-55276 Dienheim b. Mainz
    E-Mail: richter@ecos.de Voice: +49 6133 925131
    WWW: http://www.ecos.de Fax: +49 6133 925152
    -------------------------------------------------------------



    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
    For additional commands, e-mail: embperl-help@perl.apache.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupembperl @
categoriesmodperl, perl
postedDec 4, '02 at 11:46p
activeDec 6, '02 at 6:42p
posts6
users2
websiteperl.apache.org

People

Translate

site design / logo © 2022 Grokbase