Grokbase Groups Maven users May 2003
FAQ
Has anyone successfully used site:deploy on sourceforge?

_____

Matthew Wilson

Object Venture Inc.
703.689.0740 x104 Office
703.689.0868 Fax
804.301.5409 Cell

Search Discussions

  • Dion at May 7, 2003 at 2:21 pm
    I have. see http://maven-plugins.sourceforge.net/aptdoc/ for an example.
    --
    dIon Gillard, Multitask Consulting
    Blog: http://www.freeroller.net/page/dion/Weblog
    Work: http://www.multitask.com.au


    "Matthew Wilson" <mwilson@objectventure.com> wrote on 08/05/2003 12:11:50
    AM:
    Has anyone successfully used site:deploy on sourceforge?


    [image removed]
    [image removed] Matthew Wilson

    Object Venture Inc.
    703.689.0740 x104 Office
    703.689.0868 Fax
    804.301.5409 Cell
    ---------------------------------------------------------------------
    To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
    For additional commands, e-mail: users-help@maven.apache.org
  • Mark R. Diggory at May 7, 2003 at 2:49 pm
    I've used it as well. The big thing was getting the following correct in
    project.xml. For example in my project.xml I have:

    <siteAddress>repast-jellytag.sourceforge.net</siteAddress>
    <siteDirectory>/home/groups/r/re/repast-jellytag/htdocs/</siteDirectory>

    and the getting the the following properties set in maven properly.

    maven.username=
    maven.ssh.executable=
    maven.scp.executable=

    Note: On windows, I've never been able to get the prompt to enter a
    password, on linux this works fine. I ended up setting up public/private
    ssh keys for my sourceforge account which got me around the issue.

    -Mark



    dion@multitask.com.au wrote:
    I have. see http://maven-plugins.sourceforge.net/aptdoc/ for an example.
    --
    dIon Gillard, Multitask Consulting
    Blog: http://www.freeroller.net/page/dion/Weblog
    Work: http://www.multitask.com.au


    "Matthew Wilson" <mwilson@objectventure.com> wrote on 08/05/2003 12:11:50
    AM:

    Has anyone successfully used site:deploy on sourceforge?


    [image removed]
    [image removed] Matthew Wilson

    Object Venture Inc.
    703.689.0740 x104 Office
    703.689.0868 Fax
    804.301.5409 Cell

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
    For additional commands, e-mail: users-help@maven.apache.org

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
    For additional commands, e-mail: users-help@maven.apache.org
  • Matthew Wilson at May 7, 2003 at 3:11 pm
    Thanks, it is the prompt issue that I am running into. I just
    posted my public/private ssh keys, hopping that it will resolve my
    problems. I'll know in 6 hours:(

    Thanks.

    _____

    Matthew Wilson



    -----Original Message-----
    From: Mark R. Diggory
    Sent: Wednesday, May 07, 2003 10:51 AM
    To: Maven Users List
    Subject: Re: site deploy on sourceforge

    I've used it as well. The big thing was getting the following correct in

    project.xml. For example in my project.xml I have:

    <siteAddress>repast-jellytag.sourceforge.net</siteAddress>
    <siteDirectory>/home/groups/r/re/repast-jellytag/htdocs/</siteDirectory>

    and the getting the the following properties set in maven properly.

    maven.username=
    maven.ssh.executable=
    maven.scp.executable=

    Note: On windows, I've never been able to get the prompt to enter a
    password, on linux this works fine. I ended up setting up public/private

    ssh keys for my sourceforge account which got me around the issue.

    -Mark



    dion@multitask.com.au wrote:
    I have. see http://maven-plugins.sourceforge.net/aptdoc/ for an example.
    --
    dIon Gillard, Multitask Consulting
    Blog: http://www.freeroller.net/page/dion/Weblog
    Work: http://www.multitask.com.au


    "Matthew Wilson" <mwilson@objectventure.com> wrote on 08/05/2003 12:11:50
    AM:

    Has anyone successfully used site:deploy on sourceforge?


    [image removed]
    [image removed] Matthew Wilson

    Object Venture Inc.
    703.689.0740 x104 Office
    703.689.0868 Fax
    804.301.5409 Cell

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
    For additional commands, e-mail: users-help@maven.apache.org

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
    For additional commands, e-mail: users-help@maven.apache.org



    ---------------------------------------------------------------------
    To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
    For additional commands, e-mail: users-help@maven.apache.org
  • Fabian Ritzmann at May 7, 2003 at 3:30 pm

    Matthew Wilson wrote:

    Thanks, it is the prompt issue that I am running into. I just
    posted my public/private ssh keys, hopping that it will resolve my
    problems. I'll know in 6 hours:(
    If you don't want to wait, create a file authorized_keys in the
    directory .ssh on your SF shell account and paste the public key into
    it.

    Fabian

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
    For additional commands, e-mail: users-help@maven.apache.org
  • Fabian Ritzmann at May 7, 2003 at 2:41 pm

    Matthew Wilson wrote:

    Has anyone successfully used site:deploy on sourceforge?
    Yes, with beta-8, haven't tried newer versions. I had some issues with
    my SSH client (Putty) and had to make code changes to get Putty to work.
    The non-Putty related problems were all fixed in the mean-time. All my
    code changes were reported to the bug tracking system. Take a look at my
    project.properties, that might help:

    http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/ebxmlrr/maven/project.properties?rev=1.1.1.1&content-type=text/vnd.viewcvs-markup

    Fabian

    ---------------------------------------------------------------------
    To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
    For additional commands, e-mail: users-help@maven.apache.org

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupusers @
categoriesmaven
postedMay 7, '03 at 2:11p
activeMay 7, '03 at 3:30p
posts6
users5
websitemaven.apache.org
irc#maven

People

Translate

site design / logo © 2019 Grokbase