FAQ
Hi,

I encountered this error when I tried to search with special characters,
like "&" and "#".

{
   "responseHeader":{
     "status":400,
     "QTime":0},
   "error":{
     "msg":"org.apache.solr.search.SyntaxError: Cannot parse
'\"Research ': Lexical error at line 1, column 11. Encountered: <EOF>
after : \"\\\"Research \"",
     "code":400}}


I have done the search by putting inverted commands, like: q="Research &
Development"

What could be the issue here?

I'm facing this problem in both Solr 5.4.0 and Solr 6.0.1.


Regards,
Edwin

Search Discussions

  • Ahmet Arslan at Jun 17, 2016 at 5:05 pm
    Hi,

    May be URL encoding issue?
    By the way, I would use back slash to escape special characters.

    Ahmet

    On Friday, June 17, 2016 10:08 AM, Zheng Lin Edwin Yeo wrote:



    Hi,

    I encountered this error when I tried to search with special characters,
    like "&" and "#".

    {
       "responseHeader":{
         "status":400,
         "QTime":0},
       "error":{
         "msg":"org.apache.solr.search.SyntaxError: Cannot parse
    '\"Research ': Lexical error at line 1, column 11. Encountered: <EOF>
    after : \"\\\"Research \"",
         "code":400}}


    I have done the search by putting inverted commands, like: q="Research &
    Development"

    What could be the issue here?

    I'm facing this problem in both Solr 5.4.0 and Solr 6.0.1.


    Regards,
    Edwin
  • Zheng Lin Edwin Yeo at Jun 18, 2016 at 4:12 pm
    Hi,

    It does not work with the back slash too.

    But I found that it does not work for defType=lucene.
    It will work if the defType=dismax or edismax.

    What could be the reason that it did not work with the default
    defType=lucene?

    Regards,
    Edwin

    On 18 June 2016 at 01:04, Ahmet Arslan wrote:

    Hi,

    May be URL encoding issue?
    By the way, I would use back slash to escape special characters.

    Ahmet

    On Friday, June 17, 2016 10:08 AM, Zheng Lin Edwin Yeo <
    edwinyeozl@gmail.com> wrote:



    Hi,

    I encountered this error when I tried to search with special characters,
    like "&" and "#".

    {
    "responseHeader":{
    "status":400,
    "QTime":0},
    "error":{
    "msg":"org.apache.solr.search.SyntaxError: Cannot parse
    '\"Research ': Lexical error at line 1, column 11. Encountered: <EOF>
    after : \"\\\"Research \"",
    "code":400}}


    I have done the search by putting inverted commands, like: q="Research &
    Development"

    What could be the issue here?

    I'm facing this problem in both Solr 5.4.0 and Solr 6.0.1.


    Regards,
    Edwin

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupsolr-user @
categorieslucene
postedJun 17, '16 at 7:08a
activeJun 18, '16 at 4:12p
posts3
users2
websitelucene.apache.org...

People

Translate

site design / logo © 2019 Grokbase