FAQ
OK. I am trying it out. Please disregard any error messages in the
meantime.

-Grant
On Mar 14, 2008, at 11:20 PM, Hoss Man (JIRA) wrote:


[ https://issues.apache.org/jira/browse/LUCENE-1202?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hoss Man reassigned LUCENE-1202:
--------------------------------

Assignee: Grant Ingersoll


I was hoping seeing it again would jog your memory : )

i committed the changes to the build files, if the hudson problem
was related to the classpath for clover this may magically solve
that problem -- if not, just makesure whatever directory clover is
in gets added to the CLASSPATH before running ant.

Committed revision 637344.

assigning to you to track the hudson config fiddling

Clover setup currently has some problems
----------------------------------------

Key: LUCENE-1202
URL: https://issues.apache.org/jira/browse/LUCENE-1202
Project: Lucene - Java
Issue Type: Bug
Reporter: Hoss Man
Assignee: Grant Ingersoll
Attachments: LUCENE-1202.db-contrib-instrumentation.patch,
LUCENE-1202.patch


(tracking as a bug before it get lost in email...
http://www.nabble.com/Clover-reports-missing-from-hudson--to15510616.html#a15510616
)
The clover setup for Lucene currently has some problems, 3 i think...
1) instrumentation fails on contrib/db/ because it contains java
packages the ASF Clover lscence doesn't allow instrumentation of.
i have a patch for this.
2) running instrumented contrib tests for other contribs produce
strange errors...
{{monospaced}}
[junit] Testsuite: org.apache.lucene.analysis.el.GreekAnalyzerTest
[junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed:
0.126 sec
[junit]
[junit] ------------- Standard Error -----------------
[junit] [CLOVER] FATAL ERROR: Clover could not be initialised.
Are you sure you have Clover
in the runtime classpath? (class
java.lang.NoClassDefFoundError:com_cenqua_clover/CloverVersionInfo)
[junit] ------------- ---------------- ---------------
[junit] Testcase:
testAnalyzer(org.apache.lucene.analysis.el.GreekAnalyzerTest):
Caused
an ERROR
[junit] com_cenqua_clover/g
[junit] java.lang.NoClassDefFoundError: com_cenqua_clover/g
[junit] at
org
.apache.lucene.analysis.el.GreekAnalyzer.<init>(GreekAnalyzer.java:
157)
[junit] at
org
.apache
.lucene
.analysis.el.GreekAnalyzerTest.testAnalyzer(GreekAnalyzerTest.java:
60)
[junit]
[junit]
[junit] Test org.apache.lucene.analysis.el.GreekAnalyzerTest
FAILED
{{monospaced}}
...i'm not sure what's going on here. the error seems to happen
both when
trying to run clover on just a single contrib, or when doing the full
build ... i suspect there is an issue with the way the batchtests
fork
off, but I can't see why it would only happen to contribs (the
regular
tests fork as well)
3) according to Grant...
{{quote}}
...There is also a bit of a change on Hudson during the migration
to the new servers that needs to be ironed out.
{{quote}}
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
--------------------------
Grant Ingersoll
http://www.lucenebootcamp.com
Next Training: April 7, 2008 at ApacheCon Europe in Amsterdam

Lucene Helpful Hints:
http://wiki.apache.org/lucene-java/BasicsOfPerformance
http://wiki.apache.org/lucene-java/LuceneFAQ






---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupjava-dev @
categorieslucene
postedMar 15, '08 at 5:49p
activeMar 15, '08 at 5:49p
posts1
users1
websitelucene.apache.org

1 user in discussion

Grant Ingersoll: 1 post

People

Translate

site design / logo © 2022 Grokbase