Grokbase Groups Lucene dev July 2004
Date: 2004-07-15T05:54:42
Editor: ErikHatcher <>
Wiki: Jakarta Lucene Wiki
Page: Lucene2Whiteboard

no comment

New Page:

1. Replace Field factory methods (Field.Text, Field.Keyword, etc.) with a few methods that use type-safe enumerations, as described in:

2. Similarly, replace BooleanQuery.add() with a type-safe enumeration, also as described in:

3. Replace public IndexWriter fields (mergeFactor, minMergeDocs, etc.) with get/set accessors. Also, minMergeDocs should be renamed maxBufferedDocs.

4. Rename PhrasePrefixQuery to be something like MultiPhraseQuery. Also make MultipleTermPositions a private nested class of this, as this is the only place MultipleTermPositions is used.

5. Rename InputSteam to IndexInput and OutputStream to IndexOutput. Also make both of these interfaces and add BufferedIndexInput and BufferedIndexOutput as the implementation used by FSDirectory, RAMDirectory, etc. This would permit unbuffered and native implementations (e.g., that use mmap) that could potentially speed things considerably.

6. Replace DateField with something that formats dates suitably for RangeQuery.

7. Move language-specific analyzers into separate downloads?

8. Add support for span queries to query parser?

To unsubscribe, e-mail:
For additional commands, e-mail:

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
postedJul 15, '04 at 12:54p
activeJul 15, '04 at 12:54p

1 user in discussion

Lucene-cvs: 1 post



site design / logo © 2022 Grokbase