Grokbase Groups Hive user March 2011
FAQ
Hi!

I'm trying to set up a test environment locally on my laptop and it
works if I use the standard embedded derby driver. As soon as I add a
hive-site.xml, I tried both MySQL and Derby with servers definitely
running and the respective parameters set in that hive-site.xml, I get
the following exception:

FAILED: Error in metadata: javax.jdo.JDOFatalDataStoreException:
Communications link failure

The last packet sent successfully to the server was 0 milliseconds ago.
The driver has not received any packets from the server.
NestedThrowables:
com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications
link failure

The last packet sent successfully to the server was 0 milliseconds ago.
The driver has not received any packets from the server.
FAILED: Execution Error, return code 1 from
org.apache.hadoop.hive.ql.exec.DDLTask

If I switch back to the embedded driver by erasing hive-site and
restarting hadoop, it works again.

Does anyone have any idea why that error occurs?

Thanks,
Anja

Search Discussions

  • Christopher, Pat at Mar 21, 2011 at 4:25 pm
    That message is saying, 'found all drivers, trying to connect to specified metastore db. Can't'.

    Check the following:
    - MySQL/Derby server running
    - correct ip/hostname specified (I've had troubles with dynamic ips)
    - userid/pwd exists on server and has correct grants
    - will need create database, create table, insert, update, select, delete

    You shouldn't need to restart hadoop to test these changes or for swapping in a hive-site.xml, you should only need to restart hive.

    If all of those are correct, shoot me your hive-site.xml and I'll take a look.

    Pat

    -----Original Message-----
    From: Anja Gruenheid
    Sent: Sunday, March 20, 2011 12:17 PM
    To: user@hive.apache.org
    Subject: Problems with MetaStore

    Hi!

    I'm trying to set up a test environment locally on my laptop and it
    works if I use the standard embedded derby driver. As soon as I add a
    hive-site.xml, I tried both MySQL and Derby with servers definitely
    running and the respective parameters set in that hive-site.xml, I get
    the following exception:

    FAILED: Error in metadata: javax.jdo.JDOFatalDataStoreException:
    Communications link failure

    The last packet sent successfully to the server was 0 milliseconds ago.
    The driver has not received any packets from the server.
    NestedThrowables:
    com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications
    link failure

    The last packet sent successfully to the server was 0 milliseconds ago.
    The driver has not received any packets from the server.
    FAILED: Execution Error, return code 1 from
    org.apache.hadoop.hive.ql.exec.DDLTask

    If I switch back to the embedded driver by erasing hive-site and
    restarting hadoop, it works again.

    Does anyone have any idea why that error occurs?

    Thanks,
    Anja

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categorieshive, hadoop
postedMar 20, '11 at 7:17p
activeMar 21, '11 at 4:25p
posts2
users2
websitehive.apache.org

People

Translate

site design / logo © 2022 Grokbase