Grokbase Groups Hive user August 2010
FAQ
I've try to compile hive downloaded from svn,but always failed. I've tried to change the maven repository(hadoop.mirror) configurated in file build.properties to "http://labs.renren.com/" as I can't access the original mirror provided by facebook "http://mirror.facebook.net/facebook/hive-deps". I don't know why it tries to download all the hadoop versions from 0.17 to 0.20 rather than one version available. It seems no site provides all the versions,can anyone explain this,the following is the compiling log:

D:\setup\hive>ant
Buildfile: D:\setup\hive\build.xml
jar:
create-dirs:
compile-ant-tasks:
create-dirs:
init:
compile:
[echo] Compiling: anttasks
[javac] D:\setup\hive\ant\build.xml:40: warning: 'includeantruntime' was not
set, defaulting to build.sysclasspath=last; set to false for repeatable builds
deploy-ant-tasks:
create-dirs:
init:
compile:
[echo] Compiling: anttasks
[javac] D:\setup\hive\ant\build.xml:40: warning: 'includeantruntime' was not
set, defaulting to build.sysclasspath=last; set to false for repeatable builds
jar:
init:
compile:
ivy-init-dirs:
ivy-download:
[get] Getting: http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.1.0/ivy-
2.1.0.jar
[get] To: D:\setup\hive\build\ivy\lib\ivy-2.1.0.jar
[get] Not modified - so not downloaded
ivy-probe-antlib:
ivy-init-antlib:
ivy-init:
ivy-retrieve-hadoop-source:
[ivy:retrieve] :: Ivy 2.1.0 - 20090925235825 :: http://ant.apache.org/ivy/ ::
[ivy:retrieve] :: loading settings :: file = D:\setup\hive\ivy\ivysettings.xml
[ivy:retrieve] :: resolving dependencies :: org.apache.hadoop.hive#shims;working
@shangan
[ivy:retrieve] confs: [default]
[ivy:retrieve] found hadoop#core;0.18.3 in hadoop-source
[ivy:retrieve] :: resolution report :: resolve 8250ms :: artifacts dl 0ms
---------------------------------------------------------------------
modules || artifacts |
conf | number| search|dwnlded|evicted|| number|dwnlded|
---------------------------------------------------------------------
default | 4 | 0 | 0 | 0 || 1 | 0 |
---------------------------------------------------------------------
[ivy:retrieve]
[ivy:retrieve] :: problems summary ::
[ivy:retrieve] :::: WARNINGS
[ivy:retrieve] module not found: hadoop#core;0.17.2.1
[ivy:retrieve] ==== hadoop-source: tried
[ivy:retrieve] -- artifact hadoop#core;0.17.2.1!hadoop.tar.gz(source):
[ivy:retrieve] http://labs.renren.com//hadoop/core/hadoop-0.17.2.1/hadoop-0.1
7.2.1.tar.gz
[ivy:retrieve] ==== apache-snapshot: tried
[ivy:retrieve] https://repository.apache.org/content/repositories/snapshots/h
adoop/core/0.17.2.1/core-0.17.2.1.pom
[ivy:retrieve] -- artifact hadoop#core;0.17.2.1!hadoop.tar.gz(source):
[ivy:retrieve] https://repository.apache.org/content/repositories/snapshots/h
adoop/core/0.17.2.1/hadoop-0.17.2.1.tar.gz
[ivy:retrieve] ==== maven2: tried
[ivy:retrieve] http://repo1.maven.org/maven2/hadoop/core/0.17.2.1/core-0.17.2
.1.pom
[ivy:retrieve] -- artifact hadoop#core;0.17.2.1!hadoop.tar.gz(source):
[ivy:retrieve] http://repo1.maven.org/maven2/hadoop/core/0.17.2.1/core-0.17.2
.1.tar.gz
[ivy:retrieve] ==== datanucleus-repo: tried
[ivy:retrieve] -- artifact hadoop#core;0.17.2.1!hadoop.tar.gz(source):
[ivy:retrieve] http://www.datanucleus.org/downloads/maven2/hadoop/core/0.17.2
.1/core-0.17.2.1.tar.gz
[ivy:retrieve] module not found: hadoop#core;0.19.0
[ivy:retrieve] ==== hadoop-source: tried
[ivy:retrieve] -- artifact hadoop#core;0.19.0!hadoop.tar.gz(source):
[ivy:retrieve] http://labs.renren.com//hadoop/core/hadoop-0.19.0/hadoop-0.19.
0.tar.gz
[ivy:retrieve] ==== apache-snapshot: tried
[ivy:retrieve] https://repository.apache.org/content/repositories/snapshots/h
adoop/core/0.19.0/core-0.19.0.pom
[ivy:retrieve] -- artifact hadoop#core;0.19.0!hadoop.tar.gz(source):
[ivy:retrieve] https://repository.apache.org/content/repositories/snapshots/h
adoop/core/0.19.0/hadoop-0.19.0.tar.gz
[ivy:retrieve] ==== maven2: tried
[ivy:retrieve] http://repo1.maven.org/maven2/hadoop/core/0.19.0/core-0.19.0.p
om
[ivy:retrieve] -- artifact hadoop#core;0.19.0!hadoop.tar.gz(source):
[ivy:retrieve] http://repo1.maven.org/maven2/hadoop/core/0.19.0/core-0.19.0.t
ar.gz
[ivy:retrieve] ==== datanucleus-repo: tried
[ivy:retrieve] -- artifact hadoop#core;0.19.0!hadoop.tar.gz(source):
[ivy:retrieve] http://www.datanucleus.org/downloads/maven2/hadoop/core/0.19.0
/core-0.19.0.tar.gz
[ivy:retrieve] module not found: hadoop#core;0.20.0
[ivy:retrieve] ==== hadoop-source: tried
[ivy:retrieve] -- artifact hadoop#core;0.20.0!hadoop.tar.gz(source):
[ivy:retrieve] http://labs.renren.com//hadoop/core/hadoop-0.20.0/hadoop-0.20.
0.tar.gz
[ivy:retrieve] ==== apache-snapshot: tried
[ivy:retrieve] https://repository.apache.org/content/repositories/snapshots/h
adoop/core/0.20.0/core-0.20.0.pom
[ivy:retrieve] -- artifact hadoop#core;0.20.0!hadoop.tar.gz(source):
[ivy:retrieve] https://repository.apache.org/content/repositories/snapshots/h
adoop/core/0.20.0/hadoop-0.20.0.tar.gz
[ivy:retrieve] ==== maven2: tried
[ivy:retrieve] http://repo1.maven.org/maven2/hadoop/core/0.20.0/core-0.20.0.p
om
[ivy:retrieve] -- artifact hadoop#core;0.20.0!hadoop.tar.gz(source):
[ivy:retrieve] http://repo1.maven.org/maven2/hadoop/core/0.20.0/core-0.20.0.t
ar.gz
[ivy:retrieve] ==== datanucleus-repo: tried
[ivy:retrieve] -- artifact hadoop#core;0.20.0!hadoop.tar.gz(source):
[ivy:retrieve] http://www.datanucleus.org/downloads/maven2/hadoop/core/0.20.0
/core-0.20.0.tar.gz
[ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve] :: UNRESOLVED DEPENDENCIES ::
[ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve] :: hadoop#core;0.17.2.1: not found
[ivy:retrieve] :: hadoop#core;0.19.0: not found
[ivy:retrieve] :: hadoop#core;0.20.0: not found
[ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]
[ivy:retrieve]
[ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
BUILD FAILED
D:\setup\hive\build.xml:162: The following error occurred while executing this l
ine:
D:\setup\hive\build.xml:105: The following error occurred while executing this l
ine:
D:\setup\hive\shims\build.xml:57: The following error occurred while executing t
his line:
D:\setup\hive\build-common.xml:179: impossible to resolve dependencies:
resolve failed - see output for details
Total time: 10 seconds
D:\setup\hive>


2010-08-24



shangan

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categorieshive, hadoop
postedAug 24, '10 at 9:33a
activeAug 24, '10 at 9:33a
posts1
users1
websitehive.apache.org

1 user in discussion

Shangan: 1 post

People

Translate

site design / logo © 2022 Grokbase