FAQ
Hey guys,

It looks like Hive 0.5.0 is not working with our existing table definitions
that have a column named "first".

When we try to reference this column or create a new table with this column,
Hive fails and says that there is a missing column identifier.

I think that Hive 0.5.0 may now have "first" as a reserved keyword of some
sort?

Is there a way to get around this? Would really like to keep this column
name if at all possible?

Thanks,
Ryan

Search Discussions

  • Edward Capriolo at Feb 25, 2010 at 2:51 pm

    On Thu, Feb 25, 2010 at 7:22 AM, Ryan LeCompte wrote:
    Hey guys,

    It looks like Hive 0.5.0 is not working with our existing table definitions
    that have a column named "first".

    When we try to reference this column or create a new table with this column,
    Hive fails and says that there is a missing column identifier.

    I think that Hive 0.5.0 may now have "first" as a reserved keyword of some
    sort?

    Is there a way to get around this? Would really like to keep this column
    name if at all possible?

    Thanks,
    Ryan
    I noticed this as well. Good catch Ryan
  • Edward Capriolo at Feb 25, 2010 at 2:59 pm

    On Thu, Feb 25, 2010 at 9:51 AM, Edward Capriolo wrote:
    On Thu, Feb 25, 2010 at 7:22 AM, Ryan LeCompte wrote:
    Hey guys,

    It looks like Hive 0.5.0 is not working with our existing table definitions
    that have a column named "first".

    When we try to reference this column or create a new table with this column,
    Hive fails and says that there is a missing column identifier.

    I think that Hive 0.5.0 may now have "first" as a reserved keyword of some
    sort?

    Is there a way to get around this? Would really like to keep this column
    name if at all possible?

    Thanks,
    Ryan
    I noticed this as well. Good catch Ryan
    Forgot to mention the workaround. I believe you can

    select `first`

    using backticks
  • Ryan LeCompte at Feb 25, 2010 at 3:14 pm
    Thanks! That allows me to change the column.

    Ryan

    On Thu, Feb 25, 2010 at 9:59 AM, Edward Capriolo wrote:
    On Thu, Feb 25, 2010 at 9:51 AM, Edward Capriolo wrote:
    On Thu, Feb 25, 2010 at 7:22 AM, Ryan LeCompte wrote:
    Hey guys,

    It looks like Hive 0.5.0 is not working with our existing table
    definitions
    that have a column named "first".

    When we try to reference this column or create a new table with this
    column,
    Hive fails and says that there is a missing column identifier.

    I think that Hive 0.5.0 may now have "first" as a reserved keyword of
    some
    sort?

    Is there a way to get around this? Would really like to keep this column
    name if at all possible?

    Thanks,
    Ryan
    I noticed this as well. Good catch Ryan
    Forgot to mention the workaround. I believe you can

    select `first`

    using backticks

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categorieshive, hadoop
postedFeb 25, '10 at 12:22p
activeFeb 25, '10 at 3:14p
posts4
users2
websitehive.apache.org

2 users in discussion

Edward Capriolo: 2 posts Ryan LeCompte: 2 posts

People

Translate

site design / logo © 2021 Grokbase