FAQ
Hey,

I've executed this "LOAD DATA" statement a number of times before and never
had this issue. When I drop into the shell, I can see the file I'm trying to
load. Hive can't, however; any ideas on what's going on? I'd love to get
tips on how to debug this problem as well.

hive > LOAD DATA LOCAL INPATH 'ml-data/u.data' OVERWRITE INTO TABLE
u_data;
FAILED: Error in semantic analysis: line 3:23 Invalid Path 'ml-data/u.data':
No files matching path
hive > !ls ml-data;
...
u.data
...

Thanks,
Jeff

Search Discussions

  • Ashish Thusoo at Jan 23, 2009 at 11:45 am
    Can you try giving the complete path instead of the relative path?

    Ashish
    ________________________________________
    From: Jeff Hammerbacher [hammer@cloudera.com]
    Sent: Friday, January 23, 2009 12:49 AM
    To: hive-user@hadoop.apache.org
    Subject: Problem loading data from local file

    Hey,

    I've executed this "LOAD DATA" statement a number of times before and never had this issue. When I drop into the shell, I can see the file I'm trying to load. Hive can't, however; any ideas on what's going on? I'd love to get tips on how to debug this problem as well.

    hive > LOAD DATA LOCAL INPATH 'ml-data/u.data' OVERWRITE INTO TABLE u_data;
    FAILED: Error in semantic analysis: line 3:23 Invalid Path 'ml-data/u.data': No files matching path
    hive > !ls ml-data;
    ...
    u.data
    ...

    Thanks,
    Jeff
  • Joydeep Sen Sarma at Jan 23, 2009 at 4:40 pm
    There was a small change to the Load command a couple of days back (to fix a different problem) and it's triggering this.

    Can you apply the attached patch and check that it works.

    There's no extra logging here - so looking at the code was the only option ..

    ________________________________
    From: Jeff Hammerbacher
    Sent: Friday, January 23, 2009 12:50 AM
    To: hive-user@hadoop.apache.org
    Subject: Problem loading data from local file

    Hey,

    I've executed this "LOAD DATA" statement a number of times before and never had this issue. When I drop into the shell, I can see the file I'm trying to load. Hive can't, however; any ideas on what's going on? I'd love to get tips on how to debug this problem as well.

    hive > LOAD DATA LOCAL INPATH 'ml-data/u.data' OVERWRITE INTO TABLE u_data;
    FAILED: Error in semantic analysis: line 3:23 Invalid Path 'ml-data/u.data': No files matching path
    hive > !ls ml-data;
    ...
    u.data
    ...

    Thanks,
    Jeff
  • Prasad Chakka at Jan 23, 2009 at 4:53 pm
    What is the value of config param fs.default.name?


    ________________________________
    From: Joydeep Sen Sarma <jssarma@facebook.com>
    Reply-To: <hive-user@hadoop.apache.org>
    Date: Fri, 23 Jan 2009 08:39:56 -0800
    To: <hive-user@hadoop.apache.org>
    Subject: RE: Problem loading data from local file

    There was a small change to the Load command a couple of days back (to fix a different problem) and it's triggering this.

    Can you apply the attached patch and check that it works.

    There's no extra logging here - so looking at the code was the only option ..


    ________________________________

    From: Jeff Hammerbacher
    Sent: Friday, January 23, 2009 12:50 AM
    To: hive-user@hadoop.apache.org
    Subject: Problem loading data from local file

    Hey,

    I've executed this "LOAD DATA" statement a number of times before and never had this issue. When I drop into the shell, I can see the file I'm trying to load. Hive can't, however; any ideas on what's going on? I'd love to get tips on how to debug this problem as well.

    hive > LOAD DATA LOCAL INPATH 'ml-data/u.data' OVERWRITE INTO TABLE u_data;
    FAILED: Error in semantic analysis: line 3:23 Invalid Path 'ml-data/u.data': No files matching path
    hive > !ls ml-data;
    ...
    u.data
    ...

    Thanks,
    Jeff
  • Jeff Hammerbacher at Jan 24, 2009 at 11:26 pm
    Hey Joy and Prasad,

    The value of fs.default.name was:

    hive> SET fs.default.name;
    fs.default.name=hdfs://localhost:9000

    After applying Joy's patch, things worked. I get it now, thanks for the
    reference on where to check when this isn't working.

    Later,
    Jeff
    On Fri, Jan 23, 2009 at 8:52 AM, Prasad Chakka wrote:

    What is the value of config param fs.default.name?


    ------------------------------
    *From: *Joydeep Sen Sarma <jssarma@facebook.com>
    *Reply-To: *<hive-user@hadoop.apache.org>
    *Date: *Fri, 23 Jan 2009 08:39:56 -0800
    *To: *<hive-user@hadoop.apache.org>
    *Subject: *RE: Problem loading data from local file

    There was a small change to the Load command a couple of days back (to fix
    a different problem) and it's triggering this.

    Can you apply the attached patch and check that it works.

    There's no extra logging here – so looking at the code was the only option
    ..


    ------------------------------

    *From:* Jeff Hammerbacher [mailto:hammer@cloudera.com<hammer@cloudera.com>]

    *Sent:* Friday, January 23, 2009 12:50 AM
    *To:* hive-user@hadoop.apache.org
    *Subject:* Problem loading data from local file

    Hey,

    I've executed this "LOAD DATA" statement a number of times before and never
    had this issue. When I drop into the shell, I can see the file I'm trying to
    load. Hive can't, however; any ideas on what's going on? I'd love to get
    tips on how to debug this problem as well.

    hive > LOAD DATA LOCAL INPATH 'ml-data/u.data' OVERWRITE INTO TABLE u_data;

    FAILED: Error in semantic analysis: line 3:23 Invalid Path
    'ml-data/u.data': No files matching path
    hive > !ls ml-data;
    ...
    u.data
    ...

    Thanks,
    Jeff

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categorieshive, hadoop
postedJan 23, '09 at 8:50a
activeJan 24, '09 at 11:26p
posts5
users4
websitehive.apache.org

People

Translate

site design / logo © 2021 Grokbase