FAQ
Hi Friends,

I am newbee in Hbase. I was trying to setup Hbase with Quick start tutorial. But facing issues in creating the table :

Below is the error on Hbase shell :

hbase(main):001:0> create 'test','cf'

ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is able to connect to ZooKeeper but the connection closes immediately. This could be a sign that the server has too many connections (30 is the default). Consider inspecting your ZK server logs for that error and then make sure you are reusing HBaseConfiguration as often as you can. See HTable's javadoc for more information.

Here is some help for this command:
Create table; pass table name, a dictionary of specifications per
column family, and optionally a dictionary of table configuration.
Dictionaries are described below in the GENERAL NOTES section.
Examples:

hbase> create 't1', {NAME => 'f1', VERSIONS => 5}
hbase> create 't1', {NAME => 'f1'}, {NAME => 'f2'}, {NAME => 'f3'}
hbase> # The above in shorthand would be the following:
hbase> create 't1', 'f1', 'f2', 'f3'
hbase> create 't1', {NAME => 'f1', VERSIONS => 1, TTL => 2592000, BLOCKCACHE => true}

Contents of my /etc/hosts :

127.0.0.1 localhost
<IP> localhost

Contents of hbase-site.xml :

<configuration>
<property>
<name>hbase.rootdir</name>
<value>/opt/Hbase/hbase-root1</value>
</property>
</configuration>

Please Help

Stuti

________________________________
::DISCLAIMER::
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

Search Discussions

  • Stack at Aug 13, 2011 at 11:01 pm
    So, could the below ERROR be indeed your case? What if you try and
    connect to zk with the zk shell: ./bin/hbase zkcli? You get similar
    experience. Is hbase managing zk or not? If you bounce zk and retry
    the below, you get same error?

    St.Ack
    On Fri, Aug 12, 2011 at 10:52 PM, Stuti Awasthi wrote:
    Hi Friends,

    I am newbee in Hbase. I was trying to setup Hbase with Quick start tutorial. But facing issues in creating the table :

    Below is the error on Hbase shell :

    hbase(main):001:0> create 'test','cf'

    ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is able to connect to ZooKeeper but the connection closes immediately. This could be a sign that the server has too many connections (30 is the default). Consider inspecting your ZK server logs for that error and then make sure you are reusing HBaseConfiguration as often as you can. See HTable's javadoc for more information.

    Here is some help for this command:
    Create table; pass table name, a dictionary of specifications per
    column family, and optionally a dictionary of table configuration.
    Dictionaries are described below in the GENERAL NOTES section.
    Examples:

    hbase> create 't1', {NAME => 'f1', VERSIONS => 5}
    hbase> create 't1', {NAME => 'f1'}, {NAME => 'f2'}, {NAME => 'f3'}
    hbase> # The above in shorthand would be the following:
    hbase> create 't1', 'f1', 'f2', 'f3'
    hbase> create 't1', {NAME => 'f1', VERSIONS => 1, TTL => 2592000, BLOCKCACHE => true}

    Contents of my /etc/hosts :

    127.0.0.1   localhost
    <IP> localhost

    Contents of hbase-site.xml :

    <configuration>
    <property>
    <name>hbase.rootdir</name>
    <value>/opt/Hbase/hbase-root1</value>
    </property>
    </configuration>

    Please Help

    Stuti

    ________________________________
    ::DISCLAIMER::
    -----------------------------------------------------------------------------------------------------------------------

    The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
    It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in
    this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
    Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of
    this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
    received this email in error please delete it and notify the sender immediately. Before opening any mail and
    attachments please check them for viruses and defect.

    -----------------------------------------------------------------------------------------------------------------------
  • Stuti Awasthi at Aug 14, 2011 at 3:30 am
    Hi Friends ,

    Any thoughts over this issue ?

    From: Stuti Awasthi
    Sent: Saturday, August 13, 2011 11:22 AM
    To: 'user@hbase.apache.org'
    Subject: ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException:

    Hi Friends,

    I am newbee in Hbase. I was trying to setup Hbase with Quick start tutorial. But facing issues in creating the table :

    Below is the error on Hbase shell :

    hbase(main):001:0> create 'test','cf'

    ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is able to connect to ZooKeeper but the connection closes immediately. This could be a sign that the server has too many connections (30 is the default). Consider inspecting your ZK server logs for that error and then make sure you are reusing HBaseConfiguration as often as you can. See HTable's javadoc for more information.

    Here is some help for this command:
    Create table; pass table name, a dictionary of specifications per
    column family, and optionally a dictionary of table configuration.
    Dictionaries are described below in the GENERAL NOTES section.
    Examples:

    hbase> create 't1', {NAME => 'f1', VERSIONS => 5}
    hbase> create 't1', {NAME => 'f1'}, {NAME => 'f2'}, {NAME => 'f3'}
    hbase> # The above in shorthand would be the following:
    hbase> create 't1', 'f1', 'f2', 'f3'
    hbase> create 't1', {NAME => 'f1', VERSIONS => 1, TTL => 2592000, BLOCKCACHE => true}

    Contents of my /etc/hosts :

    127.0.0.1 localhost
    <IP> localhost

    Contents of hbase-site.xml :

    <configuration>
    <property>
    <name>hbase.rootdir</name>
    <value>/opt/Hbase/hbase-root1</value>
    </property>
    </configuration>

    Please Help

    Stuti

    ________________________________
    ::DISCLAIMER::
    -----------------------------------------------------------------------------------------------------------------------

    The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
    It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in
    this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
    Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of
    this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
    received this email in error please delete it and notify the sender immediately. Before opening any mail and
    attachments please check them for viruses and defect.

    -----------------------------------------------------------------------------------------------------------------------
  • Mayuresh at Aug 14, 2011 at 6:27 am
    I was able to solve the issue by setting the appropriate system limits in
    the system files. I dont remember the file name right now, but you can find
    that in the hbase setup docs and restart the machine once. I set it on all
    the master and the slaves.
    On Aug 14, 2011 9:00 AM, "Stuti Awasthi" wrote:
    Hi Friends ,

    Any thoughts over this issue ?

    From: Stuti Awasthi
    Sent: Saturday, August 13, 2011 11:22 AM
    To: 'user@hbase.apache.org'
    Subject: ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException:

    Hi Friends,

    I am newbee in Hbase. I was trying to setup Hbase with Quick start
    tutorial. But facing issues in creating the table :
    Below is the error on Hbase shell :

    hbase(main):001:0> create 'test','cf'

    ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is able
    to connect to ZooKeeper but the connection closes immediately. This could be
    a sign that the server has too many connections (30 is the default).
    Consider inspecting your ZK server logs for that error and then make sure
    you are reusing HBaseConfiguration as often as you can. See HTable's javadoc
    for more information.
    Here is some help for this command:
    Create table; pass table name, a dictionary of specifications per
    column family, and optionally a dictionary of table configuration.
    Dictionaries are described below in the GENERAL NOTES section.
    Examples:

    hbase> create 't1', {NAME => 'f1', VERSIONS => 5}
    hbase> create 't1', {NAME => 'f1'}, {NAME => 'f2'}, {NAME => 'f3'}
    hbase> # The above in shorthand would be the following:
    hbase> create 't1', 'f1', 'f2', 'f3'
    hbase> create 't1', {NAME => 'f1', VERSIONS => 1, TTL => 2592000,
    BLOCKCACHE => true}
    Contents of my /etc/hosts :

    127.0.0.1 localhost
    <IP> localhost

    Contents of hbase-site.xml :

    <configuration>
    <property>
    <name>hbase.rootdir</name>
    <value>/opt/Hbase/hbase-root1</value>
    </property>
    </configuration>

    Please Help

    Stuti

    ________________________________
    ::DISCLAIMER::
    -----------------------------------------------------------------------------------------------------------------------
    The contents of this e-mail and any attachment(s) are confidential and
    intended for the named recipient(s) only.
    It shall not attach any liability on the originator or HCL or its
    affiliates. Any views or opinions presented in
    this email are solely those of the author and may not necessarily reflect
    the opinions of HCL or its affiliates.
    Any form of reproduction, dissemination, copying, disclosure,
    modification, distribution and / or publication of
    this message without the prior written consent of the author of this
    e-mail is strictly prohibited. If you have
    received this email in error please delete it and notify the sender
    immediately. Before opening any mail and
    attachments please check them for viruses and defect.
    -----------------------------------------------------------------------------------------------------------------------
  • Mayuresh at Aug 14, 2011 at 7:02 am
    Check out the setting user limits section at
    https://ccp.cloudera.com/display/CDHDOC/HBase+Installation#HBaseInstallation-SettingUserLimitsforHBase
    .
    On Aug 14, 2011 11:56 AM, "Mayuresh" wrote:
    I was able to solve the issue by setting the appropriate system limits in
    the system files. I dont remember the file name right now, but you can find
    that in the hbase setup docs and restart the machine once. I set it on all
    the master and the slaves.
    On Aug 14, 2011 9:00 AM, "Stuti Awasthi" wrote:
    Hi Friends ,

    Any thoughts over this issue ?

    From: Stuti Awasthi
    Sent: Saturday, August 13, 2011 11:22 AM
    To: 'user@hbase.apache.org'
    Subject: ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException:

    Hi Friends,

    I am newbee in Hbase. I was trying to setup Hbase with Quick start
    tutorial. But facing issues in creating the table :
    Below is the error on Hbase shell :

    hbase(main):001:0> create 'test','cf'

    ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase is
    able
    to connect to ZooKeeper but the connection closes immediately. This could be
    a sign that the server has too many connections (30 is the default).
    Consider inspecting your ZK server logs for that error and then make sure
    you are reusing HBaseConfiguration as often as you can. See HTable's javadoc
    for more information.
    Here is some help for this command:
    Create table; pass table name, a dictionary of specifications per
    column family, and optionally a dictionary of table configuration.
    Dictionaries are described below in the GENERAL NOTES section.
    Examples:

    hbase> create 't1', {NAME => 'f1', VERSIONS => 5}
    hbase> create 't1', {NAME => 'f1'}, {NAME => 'f2'}, {NAME => 'f3'}
    hbase> # The above in shorthand would be the following:
    hbase> create 't1', 'f1', 'f2', 'f3'
    hbase> create 't1', {NAME => 'f1', VERSIONS => 1, TTL => 2592000,
    BLOCKCACHE => true}
    Contents of my /etc/hosts :

    127.0.0.1 localhost
    <IP> localhost

    Contents of hbase-site.xml :

    <configuration>
    <property>
    <name>hbase.rootdir</name>
    <value>/opt/Hbase/hbase-root1</value>
    </property>
    </configuration>

    Please Help

    Stuti

    ________________________________
    ::DISCLAIMER::
    -----------------------------------------------------------------------------------------------------------------------
    The contents of this e-mail and any attachment(s) are confidential and
    intended for the named recipient(s) only.
    It shall not attach any liability on the originator or HCL or its
    affiliates. Any views or opinions presented in
    this email are solely those of the author and may not necessarily reflect
    the opinions of HCL or its affiliates.
    Any form of reproduction, dissemination, copying, disclosure,
    modification, distribution and / or publication of
    this message without the prior written consent of the author of this
    e-mail is strictly prohibited. If you have
    received this email in error please delete it and notify the sender
    immediately. Before opening any mail and
    attachments please check them for viruses and defect.
    -----------------------------------------------------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categorieshbase, hadoop
postedAug 13, '11 at 9:04p
activeAug 14, '11 at 7:02a
posts5
users3
websitehbase.apache.org

3 users in discussion

Mayuresh: 2 posts Stuti Awasthi: 2 posts Stack: 1 post

People

Translate

site design / logo © 2022 Grokbase