Grokbase Groups HBase user July 2011
FAQ
Hi,

We have a hbase + hadoop setup that we have. Its 10 machines cluster.

In my earlier tests we had the default region size (256M) and the insertion
of 10,000,000 rows into hbase table took around 23 minutes. For the new
tests, I changed the region size to 128 M. Now the insertions are going
extremely slow. Infact its been a couple of hours now and the insertions
have still not completed yet. Any idea how I can improve the performance? Is
there any configuration setting that I am missing?

Thanks,
Mayuresh

Search Discussions

  • Doug Meil at Jul 14, 2011 at 6:55 pm
    Hi there-

    You probably want to read this...

    http://hbase.apache.org/book.html#performance

    As you've already noticed, going with regions smaller than the default
    isn't a good idea for large/large-ish tables.



    On 7/14/11 2:49 PM, "Mayuresh" wrote:

    Hi,

    We have a hbase + hadoop setup that we have. Its 10 machines cluster.

    In my earlier tests we had the default region size (256M) and the
    insertion
    of 10,000,000 rows into hbase table took around 23 minutes. For the new
    tests, I changed the region size to 128 M. Now the insertions are going
    extremely slow. Infact its been a couple of hours now and the insertions
    have still not completed yet. Any idea how I can improve the performance?
    Is
    there any configuration setting that I am missing?

    Thanks,
    Mayuresh

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categorieshbase, hadoop
postedJul 14, '11 at 6:50p
activeJul 14, '11 at 6:55p
posts2
users2
websitehbase.apache.org

2 users in discussion

Mayuresh: 1 post Doug Meil: 1 post

People

Translate

site design / logo © 2022 Grokbase