Grokbase Groups HBase user June 2011
FAQ
While monitoring JMX attributes via JConsole I observed that there are some
VM arguments being reported multiple times, see example below.

VM arguments: -Xmx32768m -ea -XX:+UseConcMarkSweepGC
-XX:+CMSIncrementalMode -ea -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode
-ea -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode
-Dcom.sun.management.jmxremote.ssl=false
-Dcom.sun.management.jmxremote.authenticate=false
-Dcom.sun.management.jmxremote.port=9097
-Dcom.sun.management.jmxremote.ssl=false
-Dcom.sun.management.jmxremote.authenticate=false
-Dcom.sun.management.jmxremote.port=9097
-Dcom.sun.management.jmxremote.ssl=false
-Dcom.sun.management.jmxremote.authenticate=false
-Dcom.sun.management.jmxremote.port=9097 -Dhbase.log.dir=/usr/lib/hbase/logs
-Dhbase.log.file=hbase-hbase-regionserver-hb2.log
-Dhbase.home.dir=/usr/lib/hbase -Dhbase.id.str=hbase
-Dhbase.root.logger=INFO,DRFA
-Djava.library.path=/usr/lib/hbase/lib/native/Linux-amd64-64
This is for regionserver, but I see similar results for HMaster, NameNode,
DN, etc. Is it normal or its because something is not setup properly ?

Search Discussions

  • Suraj Varma at Jun 23, 2011 at 7:19 pm
    Check your regionserver's hbase-env.sh to see if you have accidentally
    duplicated the jmx lines in there.
    --Suraj
    On Thu, Jun 23, 2011 at 8:45 AM, sulabh choudhury wrote:
    While monitoring JMX attributes via JConsole I observed that there are some
    VM arguments being reported multiple times, see example below.

    VM arguments:   -Xmx32768m -ea -XX:+UseConcMarkSweepGC
    -XX:+CMSIncrementalMode -ea -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode
    -ea -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode
    -Dcom.sun.management.jmxremote.ssl=false
    -Dcom.sun.management.jmxremote.authenticate=false
    -Dcom.sun.management.jmxremote.port=9097
    -Dcom.sun.management.jmxremote.ssl=false
    -Dcom.sun.management.jmxremote.authenticate=false
    -Dcom.sun.management.jmxremote.port=9097
    -Dcom.sun.management.jmxremote.ssl=false
    -Dcom.sun.management.jmxremote.authenticate=false
    -Dcom.sun.management.jmxremote.port=9097 -Dhbase.log.dir=/usr/lib/hbase/logs
    -Dhbase.log.file=hbase-hbase-regionserver-hb2.log
    -Dhbase.home.dir=/usr/lib/hbase -Dhbase.id.str=hbase
    -Dhbase.root.logger=INFO,DRFA
    -Djava.library.path=/usr/lib/hbase/lib/native/Linux-amd64-64
    This is for regionserver, but I see similar results for HMaster, NameNode,
    DN, etc.  Is it normal or its because something is not setup properly ?

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categorieshbase, hadoop
postedJun 23, '11 at 3:46p
activeJun 23, '11 at 7:19p
posts2
users2
websitehbase.apache.org

2 users in discussion

Sulabh choudhury: 1 post Suraj Varma: 1 post

People

Translate

site design / logo © 2022 Grokbase