Grokbase Groups HBase user May 2011
FAQ
Hi everyone,

I've just installing hadoop and hbase from cloudera (3) but when I try to go
to http://localhost:60010 it just sits there continually loading.

I can get to the regionserver fine - http://localhost:60030... Looking at
the master hbase server logs I can see the following log output below.

Looks like a problem with the root region.

All of this is installed on a ext4 1TB partition running Ubuntu (Natty) 11.
No cluster/other boxes).
Any help would be greatly appreciated!

This thing is driving me crazy...

LOG:

*11/05/15 19:58:27 WARN master.AssignmentManager: Failed assignment of
-ROOT-,,0.70236052 to serverName=localhost,60020,1305452402149,
load=(requests=0, regions=0, usedHeap=24, maxHeap=995), trying to assign
elsewhere instead; retry=0*
org.apache.hadoop.hbase.client.RetriesExhaustedException: *Failed setting up
proxy interface org.apache.hadoop.hbase.ipc.HRegionInterface to /
127.0.0.1:60020 after attempts=1 at
org.apache.hadoop.hbase.ipc.HBaseRPC.waitForProxy(HBaseRPC.java:355)
at*org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.getHRegionConnection(HConnectionManager.java:957)
at
org.apache.hadoop.hbase.master.ServerManager.getServerConnection(ServerManager.java:606)
at
org.apache.hadoop.hbase.master.ServerManager.sendRegionOpen(ServerManager.java:541)
at
org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:901)
at
org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:730)
at
org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:710)
at
org.apache.hadoop.hbase.master.AssignmentManager$TimeoutMonitor.chore(AssignmentManager.java:1605)
at
org.apache.hadoop.hbase.Chore.run(Chore.java:66) Caused by:
java.net.ConnectException: Connection refused at
sun.nio.ch.SocketChannelImpl.checkConnect(Native Method) at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567) at
org.apache.hadoop.net.SocketIOWithTimeout.connect(SocketIOWithTimeout.java:206)
at
org.apache.hadoop.net.NetUtils.connect(NetUtils.java:408) at
org.apache.hadoop.hbase.ipc.HBaseClient$Connection.setupIOstreams(HBaseClient.java:328)
at
org.apache.hadoop.hbase.ipc.HBaseClient.getConnection(HBaseClient.java:883)
at org.apache.hadoop.hbase.ipc.HBaseClient.call(HBaseClient.java:750) at
org.apache.hadoop.hbase.ipc.HBaseRPC$Invoker.invoke(HBaseRPC.java:257) at
$Proxy6.getProtocolVersion(Unknown Source) at
org.apache.hadoop.hbase.ipc.HBaseRPC.getProxy(HBaseRPC.java:419) at
org.apache.hadoop.hbase.ipc.HBaseRPC.getProxy(HBaseRPC.java:393) at
org.apache.hadoop.hbase.ipc.HBaseRPC.getProxy(HBaseRPC.java:444) at
org.apache.hadoop.hbase.ipc.HBaseRPC.waitForProxy(HBaseRPC.java:349) ... 8
more

*11/05/15 19:58:27 WARN master.AssignmentManager: Unable to find a viable
location to assign region -ROOT-,,0.70236052*
**
Cheers,
NW

Search Discussions

  • Stack at May 16, 2011 at 5:37 pm

    On Sun, May 15, 2011 at 6:10 AM, Nightie Wolfi wrote:
    org.apache.hadoop.hbase.Chore.run(Chore.java:66) Caused by:
    java.net.ConnectException: Connection refused at
    sun.nio.ch.SocketChannelImpl.checkConnect(Native Method) at
    sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567) at
    org.apache.hadoop.net.SocketIOWithTimeout.connect(SocketIOWithTimeout.java:206)

    Master is trying to assign region but its getting connection refused
    trying to assign the region to localhost,60020. Is the RegionServer
    running on localhost? If not, its likely the naming needs fixin on
    your hosts.

    St.Ack
    P.S. Don't go crazy.
  • Sepideh at Aug 15, 2011 at 9:36 am
    Hi all,

    I have the same problem while installing hbase on ubuntu 11.04.
    I've tried everything and still getting that error.
    Stack, I did'nt get what you mean and what should I do.
    would you guys please help me to make it run?

    Thanks in advanced
  • Stack at Aug 16, 2011 at 4:04 am
    Sorry. I lost context. What is the issue? If I search the mailing
    list I see you had issues w/ versions. Is this what you are asking
    about?
    St.Ack
    On Mon, Aug 15, 2011 at 2:34 AM, sepideh wrote:

    Hi all,

    I have the same problem while installing hbase on ubuntu 11.04.
    I've tried everything and still getting that error.
    Stack, I did'nt get what you mean and what should I do.
    would you guys please help me to make it run?

    Thanks in advanced
  • Pavan at May 25, 2011 at 8:45 pm
    In case you are trying it on a virtual machine.
    I changed my networking options from NAT to Bridged
    and it started working.
    I am guessing it has problems accessing the network interface otherwise maybe.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categorieshbase, hadoop
postedMay 16, '11 at 4:59p
activeAug 16, '11 at 4:04a
posts5
users4
websitehbase.apache.org

People

Translate

site design / logo © 2022 Grokbase