FAQ
Ted Yu created HBASE-13972:
------------------------------

              Summary: Hanging test finder should report killed test
                  Key: HBASE-13972
                  URL: https://issues.apache.org/jira/browse/HBASE-13972
              Project: HBase
           Issue Type: Bug
             Reporter: Ted Yu
             Assignee: Ted Yu
             Priority: Minor


I was looking at https://builds.apache.org/job/PreCommit-HBASE-Build/14576/console and found that findHangingTests.py didn't report any hanging / failing test.
{code}
Running org.apache.hadoop.hbase.procedure2.store.TestProcedureStoreTracker
Killed
{code}
It turns out that findHangingTests.py didn't distinguish the state for tests that were killed.
Patch coming shortly which allows printing of killed test(s)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Search Discussions

  • Ted Yu (JIRA) at Jun 25, 2015 at 8:56 pm
    [ https://issues.apache.org/jira/browse/HBASE-13972?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

    Ted Yu resolved HBASE-13972.
    ----------------------------
         Resolution: Cannot Reproduce

    Subsequent run of findHangingTests.py reported TestProcedureStoreTracker as hanging test.
    Hanging test finder should report killed test
    ---------------------------------------------

    Key: HBASE-13972
    URL: https://issues.apache.org/jira/browse/HBASE-13972
    Project: HBase
    Issue Type: Bug
    Reporter: Ted Yu
    Assignee: Ted Yu
    Priority: Minor

    I was looking at https://builds.apache.org/job/PreCommit-HBASE-Build/14576/console and found that findHangingTests.py didn't report any hanging / failing test.
    {code}
    Running org.apache.hadoop.hbase.procedure2.store.TestProcedureStoreTracker
    Killed
    {code}
    It turns out that findHangingTests.py didn't distinguish the state for tests that were killed.
    Patch coming shortly which allows printing of killed test(s)


    --
    This message was sent by Atlassian JIRA
    (v6.3.4#6332)

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupissues @
categorieshbase, hadoop
postedJun 25, '15 at 8:47p
activeJun 25, '15 at 8:56p
posts2
users1
websitehbase.apache.org

1 user in discussion

Ted Yu (JIRA): 2 posts

People

Translate

site design / logo © 2021 Grokbase