FAQ
[ https://issues.apache.org/jira/browse/HBASE-4264?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Cosmin Lehene updated HBASE-4264:
---------------------------------
     Labels: delete (was: )
TestMergeTool is too sensitive to hanging HBase cluster from other test
-----------------------------------------------------------------------

Key: HBASE-4264
URL: https://issues.apache.org/jira/browse/HBASE-4264
Project: HBase
Issue Type: Bug
Reporter: Ted Yu
Labels: delete

The TestMergeTool.testMergeTool failure in build 2154 was due to the following check:
{noformat}
HBaseAdmin.checkHBaseAvailable(getConf());
LOG.fatal("HBase cluster must be off-line.");
{noformat}
HBase cluster from some other test(s) was hanging since "merging regions 0 and 1" is the first merge.
The test can be made more robust by calling HBaseAdmin.shutdown() before making the first merge.
In Merge.java, -1 is returned in 5 places. I think we should return different values so that it is more obvious what the cause was.


--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Search Discussions

  • Cosmin Lehene (JIRA) at Jan 6, 2015 at 3:53 pm
    [ https://issues.apache.org/jira/browse/HBASE-4264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14266295#comment-14266295 ]

    Cosmin Lehene commented on HBASE-4264:
    --------------------------------------

    [~apurtell] please review
    TestMergeTool is too sensitive to hanging HBase cluster from other test
    -----------------------------------------------------------------------

    Key: HBASE-4264
    URL: https://issues.apache.org/jira/browse/HBASE-4264
    Project: HBase
    Issue Type: Bug
    Reporter: Ted Yu
    Labels: delete

    The TestMergeTool.testMergeTool failure in build 2154 was due to the following check:
    {noformat}
    HBaseAdmin.checkHBaseAvailable(getConf());
    LOG.fatal("HBase cluster must be off-line.");
    {noformat}
    HBase cluster from some other test(s) was hanging since "merging regions 0 and 1" is the first merge.
    The test can be made more robust by calling HBaseAdmin.shutdown() before making the first merge.
    In Merge.java, -1 is returned in 5 places. I think we should return different values so that it is more obvious what the cause was.


    --
    This message was sent by Atlassian JIRA
    (v6.3.4#6332)
  • Andrew Purtell (JIRA) at Jan 6, 2015 at 4:42 pm
    [ https://issues.apache.org/jira/browse/HBASE-4264?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

    Andrew Purtell resolved HBASE-4264.
    -----------------------------------
         Resolution: Invalid

    Resolving as invalid.

    Thanks for the nudge [~clehene]
    TestMergeTool is too sensitive to hanging HBase cluster from other test
    -----------------------------------------------------------------------

    Key: HBASE-4264
    URL: https://issues.apache.org/jira/browse/HBASE-4264
    Project: HBase
    Issue Type: Bug
    Reporter: Ted Yu
    Labels: delete

    The TestMergeTool.testMergeTool failure in build 2154 was due to the following check:
    {noformat}
    HBaseAdmin.checkHBaseAvailable(getConf());
    LOG.fatal("HBase cluster must be off-line.");
    {noformat}
    HBase cluster from some other test(s) was hanging since "merging regions 0 and 1" is the first merge.
    The test can be made more robust by calling HBaseAdmin.shutdown() before making the first merge.
    In Merge.java, -1 is returned in 5 places. I think we should return different values so that it is more obvious what the cause was.


    --
    This message was sent by Atlassian JIRA
    (v6.3.4#6332)

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupissues @
categorieshbase, hadoop
postedJan 6, '15 at 3:53p
activeJan 6, '15 at 4:42p
posts3
users1
websitehbase.apache.org

1 user in discussion

Andrew Purtell (JIRA): 3 posts

People

Translate

site design / logo © 2021 Grokbase