On Wed, Jul 18, 2012 at 5:09 PM, Stack wrote:
On Wed, Jul 18, 2012 at 9:58 PM, Jonathan Hsieh wrote:
I'm trying to get a feel to see how affected folks would be if we
potentially only had hbase support a hadoop 1.0 build and a hadoop 2.0
build profile (and perhaps a hadoop 3.0-SNAPSHOT proflile).
does anyone use hbase on top of hadoop 0.21.x, 0.22.x, or 0.23.x (which
became hadoop 2.0.x recently)
Jon, what versions of HBase are you asking about? A while back we
said that HBase 0.96.0 would be the first release that could assume
for a minimum a 1.0.x API . Previous releases we postulated
(though probably haven't tested much) could be run on versions as old
as branch-0.20-append. We might want to reexamine this "decision" if
we we are talking HBase 0.94 (or even HBase 0.92)?
Its in the the title -- I was asking about specifically about hbase
0.92.0+/0.94.0+. I should have also included 0.20-append in the list of
I don't think this affects the decision you refer to. I'm not trying to age
off older versions -- I'm trying find out from this discussion which
"newer" versions we should have HBase work/compile against, and if we can
just say 1.x and 2.x and not include the 0.21, 0.22, and now 0.23 branches.
We've found out along the way that while different Hadoop versions are
"source-compatible" (no source change but requires recompile), they are not
"binary-compatible" (one hbase jar for all hadoop versions).
As examples, an hbase compiled against a hadoop 1.0 hdfs doesn't work ontop
of a hadoop 2.0 hdfs, and that a hbase compiled against hadoop 2.0 hdfs
doesn't work on a hadoop 1.0 cluster. To add to the mix, today we learned
that an hbase compiled against a hadoop 23 doesn't work on a hadoop 2.0
// Jonathan Hsieh (shay)
// Software Engineer, Cloudera