Working on HBASE-4454 and HBASE-4336, and the last major blocker seems to be
naming of integration tests. Like with unit tests, we should probably just
pick a single naming convention, and roll with it.
The default schema from failsafe is:
There was also discussion about alternatives do to some issues (my favorite
conversion was something like "ITHCM.java").
The proposed alternatives were:
I was thinking we would just go with IntegrationTest*.java. This avoids
consecutive capitalization ugliness, keeps a similar format to the unit
tests (kinda), and helps to avoid people forgetting to include the 'I' in
specifying their tests. Also, test names are long anyways, so its not a big
deal if they are a little longer.
Does anyone have any strong feels either way?