Grokbase Groups HBase dev July 2011
FAQ
The first hbase 0.90.4 release candidate is available for download:

http://people.apache.org/~stack/hbase-0.90.4-candidate-0/

Release notes are available here, [1]. ~sixty issues have been
resolved since 0.90.3

Should we release this candidate as hbase 0.90.4?

Please vote +1/-1 by next Friday, July 29th.

Yours,
The HBasers

1. https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12310753&version=12316406

Search Discussions

  • Ted Yu at Jul 22, 2011 at 10:40 pm
    The latest 0.90 build on builds.apache.org wasn't successful:
    https://builds.apache.org/view/G-L/view/HBase/job/hbase-0.90/239/console

    Shall we investigate why TestShell hung ?
    On Fri, Jul 22, 2011 at 3:34 PM, Stack wrote:

    The first hbase 0.90.4 release candidate is available for download:

    http://people.apache.org/~stack/hbase-0.90.4-candidate-0/

    Release notes are available here, [1]. ~sixty issues have been
    resolved since 0.90.3

    Should we release this candidate as hbase 0.90.4?

    Please vote +1/-1 by next Friday, July 29th.

    Yours,
    The HBasers

    1.
    https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12310753&version=12316406
  • Stack at Jul 22, 2011 at 11:05 pm

    On Fri, Jul 22, 2011 at 3:40 PM, Ted Yu wrote:
    The latest 0.90 build on builds.apache.org wasn't successful:
    https://builds.apache.org/view/G-L/view/HBase/job/hbase-0.90/239/console
    I ran tests locally multiple times. Seems fine.
    Shall we investigate why TestShell hung ?
    It was speculated that this was because a zk was left over from
    previous build (Eric Charles?)

    St.Ack
  • Ted Yu at Jul 22, 2011 at 11:11 pm
    It was speculated that this was because a zk was left over from previous
    build
    Looks like we should detect (and terminate, if possible) the hanging zk from
    previous build as the first step in current build.
    On Fri, Jul 22, 2011 at 4:04 PM, Stack wrote:
    On Fri, Jul 22, 2011 at 3:40 PM, Ted Yu wrote:
    The latest 0.90 build on builds.apache.org wasn't successful:
    https://builds.apache.org/view/G-L/view/HBase/job/hbase-0.90/239/console
    I ran tests locally multiple times. Seems fine.
    Shall we investigate why TestShell hung ?
    It was speculated that this was because a zk was left over from
    previous build (Eric Charles?)

    St.Ack
  • Stack at Jul 22, 2011 at 11:18 pm
    Sounds good. Make an issue Ted? Should at least probe for existing
    zk ensemble (I used to have access to this build box but no longer)
    St.Ack
    On Fri, Jul 22, 2011 at 4:11 PM, Ted Yu wrote:
    It was speculated that this was because a zk was left over from previous
    build
    Looks like we should detect (and terminate, if possible) the hanging zk from
    previous build as the first step in current build.
    On Fri, Jul 22, 2011 at 4:04 PM, Stack wrote:
    On Fri, Jul 22, 2011 at 3:40 PM, Ted Yu wrote:
    The latest 0.90 build on builds.apache.org wasn't successful:
    https://builds.apache.org/view/G-L/view/HBase/job/hbase-0.90/239/console
    I ran tests locally multiple times.  Seems fine.
    Shall we investigate why TestShell hung ?
    It was speculated that this was because a zk was left over from
    previous build (Eric Charles?)

    St.Ack
  • Ted Yu at Jul 22, 2011 at 11:40 pm
    I am not sure if all timeouts were due to hanging zk.

    0.90 build 238 started at Jul 21, 2011 12:16:20
    AM<https://builds.apache.org/view/G-L/view/HBase/job/hbase-0.90/238/>and
    failed

    But TRUNK build 2045, starting at Jul 21, 2011 1:34:20
    AM<https://builds.apache.org/view/G-L/view/HBase/job/HBase-TRUNK/2045/>,
    succeeded.

    Or maybe there were built on different boxes.
    On Fri, Jul 22, 2011 at 4:18 PM, Stack wrote:

    Sounds good. Make an issue Ted? Should at least probe for existing
    zk ensemble (I used to have access to this build box but no longer)
    St.Ack
    On Fri, Jul 22, 2011 at 4:11 PM, Ted Yu wrote:
    It was speculated that this was because a zk was left over from
    previous
    build
    Looks like we should detect (and terminate, if possible) the hanging zk from
    previous build as the first step in current build.
    On Fri, Jul 22, 2011 at 4:04 PM, Stack wrote:
    On Fri, Jul 22, 2011 at 3:40 PM, Ted Yu wrote:
    The latest 0.90 build on builds.apache.org wasn't successful:
    https://builds.apache.org/view/G-L/view/HBase/job/hbase-0.90/239/console
    I ran tests locally multiple times. Seems fine.
    Shall we investigate why TestShell hung ?
    It was speculated that this was because a zk was left over from
    previous build (Eric Charles?)

    St.Ack
  • Stack at Jul 23, 2011 at 4:14 am
    Our build box is set to use 'ubuntu2'. IIRC, the wiki for
    jenkins/hudson says its a single box but I've learned that the wiki is
    stale after my recent interaction with infrastructure around ulimits.
    It could be more than one machine. We just hit a successful build
    and its the head of the branch, where I built 0.90.4 from so we're not
    too bad off.

    St.Ack
    On Fri, Jul 22, 2011 at 4:39 PM, Ted Yu wrote:
    I am not sure if all timeouts were due to hanging zk.

    0.90 build 238 started at Jul 21, 2011 12:16:20
    AM<https://builds.apache.org/view/G-L/view/HBase/job/hbase-0.90/238/>and
    failed

    But TRUNK build 2045, starting at Jul 21, 2011 1:34:20
    AM<https://builds.apache.org/view/G-L/view/HBase/job/HBase-TRUNK/2045/>,
    succeeded.

    Or maybe there were built on different boxes.
    On Fri, Jul 22, 2011 at 4:18 PM, Stack wrote:

    Sounds good.  Make an issue Ted?  Should at least probe for existing
    zk ensemble (I used to have access to this build box but no longer)
    St.Ack
    On Fri, Jul 22, 2011 at 4:11 PM, Ted Yu wrote:
    It was speculated that this was because a zk was left over from
    previous
    build
    Looks like we should detect (and terminate, if possible) the hanging zk from
    previous build as the first step in current build.
    On Fri, Jul 22, 2011 at 4:04 PM, Stack wrote:
    On Fri, Jul 22, 2011 at 3:40 PM, Ted Yu wrote:
    The latest 0.90 build on builds.apache.org wasn't successful:
    https://builds.apache.org/view/G-L/view/HBase/job/hbase-0.90/239/console
    I ran tests locally multiple times.  Seems fine.
    Shall we investigate why TestShell hung ?
    It was speculated that this was because a zk was left over from
    previous build (Eric Charles?)

    St.Ack
  • Eric Charles at Jul 23, 2011 at 3:01 pm

    On 23/07/11 01:04, Stack wrote:
    Shall we investigate why TestShell hung ?
    It was speculated that this was because a zk was left over from
    previous build (Eric Charles?)
    There were 2 java processes left-over from a previous timed-out Test.
    I didn't have the reflex to look for open ports.
    Could have been a MiniHBaseCluster also with master and region servers.

    Btw, running 'mvn test' on 0.90.4 release candidate gives here 1 failure:
    testWritesWhileGetting(org.apache.hadoop.hbase.regionserver.TestHRegion)
    Time elapsed: 0.19 sec <<< FAILURE!
    junit.framework.AssertionFailedError: expected:<\x00\x00\x00<> but
    was:<\x00\x00\x00:>

    Thx.
  • Stack at Jul 23, 2011 at 3:59 pm

    On Sat, Jul 23, 2011 at 8:01 AM, Eric Charles wrote:
    There were 2 java processes left-over from a previous timed-out Test.
    I didn't have the reflex to look for open ports.
    Could have been a MiniHBaseCluster also with master and region servers.
    Good on you Eric. Some test must not be cleaning up after itself. If
    a failed build because of TestShell failures, seems like we should
    look at previous build to see what failed there and check that it is
    cleaning up minihbasecluster after itself.
    Btw, running 'mvn test' on 0.90.4 release candidate gives here 1 failure:
    testWritesWhileGetting(org.apache.hadoop.hbase.regionserver.TestHRegion)
    Time elapsed: 0.19 sec  <<< FAILURE!
    junit.framework.AssertionFailedError: expected:<\x00\x00\x00<> but
    was:<\x00\x00\x00:>
    I just tried it and it passed for me. It failed though up on jenkins
    on the above test,
    https://builds.apache.org/view/G-L/view/HBase/job/hbase-0.90/242/testReport/,
    though it just passed.

    I think this RC is going down though. I see in cluster testing that
    my fix for HBASE-3872 adds an ugly WARN to the master logs
    (HBASE-4129). We should also get in Andrew's REST fixes.

    Good stuff,
    St.Ack

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categorieshbase, hadoop
postedJul 22, '11 at 10:34p
activeJul 23, '11 at 3:59p
posts9
users3
websitehbase.apache.org

3 users in discussion

Stack: 5 posts Ted Yu: 3 posts Eric Charles: 1 post

People

Translate

site design / logo © 2022 Grokbase