Grokbase Groups HBase dev July 2011
FAQ

On Tue, Jul 12, 2011 at 8:50 PM, Gaojinchao wrote:
In hbase book, It recommends the zookeeper.session.timeout is default 60s.  but, the default value is configured for 18000 in Hbase-default.xml.

Should we modify the Hbase-default.xml or book ?
The book.
St.Ack

Search Discussions

  • Jonathan Gray at Jul 13, 2011 at 5:23 am
    The default in 90 branch and trunk is 180000 (3 minutes) not 18000.

    <name>zookeeper.session.timeout</name>
    <value>180000</value>
    -----Original Message-----
    From: saint.ack@gmail.com On Behalf Of Stack
    Sent: Tuesday, July 12, 2011 8:56 PM
    To: dev@hbase.apache.org
    Subject: Edit for your book Lars. WAS --> Re: A question about
    zookeeper.session.timeout
    On Tue, Jul 12, 2011 at 8:50 PM, Gaojinchao wrote:
    In hbase book, It recommends the zookeeper.session.timeout is default
    60s.  but, the default value is configured for 18000 in Hbase-default.xml.
    Should we modify the Hbase-default.xml or book ?
    The book.
    St.Ack
  • Lars George at Jul 15, 2011 at 6:36 pm
    We also figured that you MUST set the maxSessionTimeout to the same value
    when using a stand alone ZooKeeper ensemble. The managed is fine, but the
    stand alone without that extra option in the zoo.cfg will negotiate the
    timeout to be a maximum of 20 x tickTime, so 40-60 seconds. In that case the
    3 minutes value set in the hbase-default.xml is useless.
    On Wed, Jul 13, 2011 at 7:22 AM, Jonathan Gray wrote:

    The default in 90 branch and trunk is 180000 (3 minutes) not 18000.

    <name>zookeeper.session.timeout</name>
    <value>180000</value>
    -----Original Message-----
    From: saint.ack@gmail.com On Behalf Of Stack
    Sent: Tuesday, July 12, 2011 8:56 PM
    To: dev@hbase.apache.org
    Subject: Edit for your book Lars. WAS --> Re: A question about
    zookeeper.session.timeout

    On Tue, Jul 12, 2011 at 8:50 PM, Gaojinchao <gaojinchao@huawei.com>
    wrote:
    In hbase book, It recommends the zookeeper.session.timeout is default
    60s. but, the default value is configured for 18000 in
    Hbase-default.xml.
    Should we modify the Hbase-default.xml or book ?
    The book.
    St.Ack

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categorieshbase, hadoop
postedJul 13, '11 at 3:56a
activeJul 15, '11 at 6:36p
posts3
users3
websitehbase.apache.org

People

Translate

site design / logo © 2022 Grokbase