Grokbase Groups HBase dev June 2011
FAQ
Hi! I am new to HBase development and tried running unit tests after
checking out HBase trunk. I am see'ing the following failures (pasted
below).

Is there any setup required before running the unit test? For example, do I
need to start zoo-keeper cluster manually before running the tests?

Thanks

-Rakesh

=======================================================================
rakesh@ubuntu:~/Hbasewrk/hbase-core-trunk$ mvn test
[INFO] Scanning for projects...
[INFO]
------------------------------------------------------------------------
[INFO] Building HBase
[INFO] task-segment: [test]
[INFO]
------------------------------------------------------------------------
[INFO] [antrun:run {execution: generate}]
[INFO] Executing tasks
...[snipped]
Running org.apache.hadoop.hbase.coprocessor.TestCoprocessorInterface
Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 1.849 sec
<<< FAILURE!
Running org.apache.hadoop.hbase.TestZooKeeper
Tests run: 7, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 453.877 sec
....[snipped]
Tests run: 11, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.56 sec
Running org.apache.hadoop.hbase.zookeeper.TestHQuorumPeer
Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.182 sec
Running org.apache.hadoop.hbase.regionserver.TestSplitTransactionOnCluster
killed.
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error while executing forked tests.; nested exception is
org.apache.maven.surefire.booter.shade.org.codehaus.plexus.util.cli.CommandLineException:
Error while executing external command, process killed.

Process timeout out after 900 seconds

Search Discussions

  • Jean-Daniel Cryans at Jun 5, 2011 at 11:00 pm
    Nothing is required, look at the log of the first test and see what
    it's complaining on.

    J-D

    On Sun, Jun 5, 2011 at 3:58 PM, Rakesh Aggarwal
    wrote:
    Hi! I am new to HBase development and tried running unit tests after
    checking out HBase trunk. I am see'ing the following failures (pasted
    below).

    Is there any setup required before running the unit test? For example, do I
    need to start zoo-keeper cluster manually before running the tests?

    Thanks

    -Rakesh

    =======================================================================
    rakesh@ubuntu:~/Hbasewrk/hbase-core-trunk$ mvn test
    [INFO] Scanning for projects...
    [INFO]
    ------------------------------------------------------------------------
    [INFO] Building HBase
    [INFO]    task-segment: [test]
    [INFO]
    ------------------------------------------------------------------------
    [INFO] [antrun:run {execution: generate}]
    [INFO] Executing tasks
    ...[snipped]
    Running org.apache.hadoop.hbase.coprocessor.TestCoprocessorInterface
    Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 1.849 sec
    <<< FAILURE!
    Running org.apache.hadoop.hbase.TestZooKeeper
    Tests run: 7, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 453.877 sec
    ....[snipped]
    Tests run: 11, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.56 sec
    Running org.apache.hadoop.hbase.zookeeper.TestHQuorumPeer
    Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.182 sec
    Running org.apache.hadoop.hbase.regionserver.TestSplitTransactionOnCluster
    killed.
    [INFO]
    ------------------------------------------------------------------------
    [ERROR] BUILD ERROR
    [INFO]
    ------------------------------------------------------------------------
    [INFO] Error while executing forked tests.; nested exception is
    org.apache.maven.surefire.booter.shade.org.codehaus.plexus.util.cli.CommandLineException:
    Error while executing external command, process killed.

    Process timeout out after 900 seconds
  • Stack at Jun 6, 2011 at 4:57 pm
    On TRUNK, usually all tests pass but intermittently some are broken.
    The best gauge for the current state of trunk can be found here,
    https://builds.apache.org//job/HBase-TRUNK/, on the Apache CI server.

    As J-D says, there is nothing special that you need to do to run the
    tests other than 'mvn clean test'.

    St.Ack

    On Sun, Jun 5, 2011 at 3:58 PM, Rakesh Aggarwal
    wrote:
    Hi! I am new to HBase development and tried running unit tests after
    checking out HBase trunk. I am see'ing the following failures (pasted
    below).

    Is there any setup required before running the unit test? For example, do I
    need to start zoo-keeper cluster manually before running the tests?

    Thanks

    -Rakesh

    =======================================================================
    rakesh@ubuntu:~/Hbasewrk/hbase-core-trunk$ mvn test
    [INFO] Scanning for projects...
    [INFO]
    ------------------------------------------------------------------------
    [INFO] Building HBase
    [INFO]    task-segment: [test]
    [INFO]
    ------------------------------------------------------------------------
    [INFO] [antrun:run {execution: generate}]
    [INFO] Executing tasks
    ...[snipped]
    Running org.apache.hadoop.hbase.coprocessor.TestCoprocessorInterface
    Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 1.849 sec
    <<< FAILURE!
    Running org.apache.hadoop.hbase.TestZooKeeper
    Tests run: 7, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 453.877 sec
    ....[snipped]
    Tests run: 11, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.56 sec
    Running org.apache.hadoop.hbase.zookeeper.TestHQuorumPeer
    Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.182 sec
    Running org.apache.hadoop.hbase.regionserver.TestSplitTransactionOnCluster
    killed.
    [INFO]
    ------------------------------------------------------------------------
    [ERROR] BUILD ERROR
    [INFO]
    ------------------------------------------------------------------------
    [INFO] Error while executing forked tests.; nested exception is
    org.apache.maven.surefire.booter.shade.org.codehaus.plexus.util.cli.CommandLineException:
    Error while executing external command, process killed.

    Process timeout out after 900 seconds

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categorieshbase, hadoop
postedJun 5, '11 at 10:58p
activeJun 6, '11 at 4:57p
posts3
users3
websitehbase.apache.org

People

Translate

site design / logo © 2021 Grokbase