Grokbase Groups HBase dev April 2010
FAQ
Fix our Maven dependencies
--------------------------

Key: HBASE-2452
URL: https://issues.apache.org/jira/browse/HBASE-2452
Project: Hadoop HBase
Issue Type: Improvement
Components: build
Affects Versions: 0.21.0
Reporter: Lars Francke
Assignee: Lars Francke
Attachments: HBASE-2452-1.patch

There are quite a few implicit dependencies or dependencies which could be moved to our parent's dependencyManagement section. This patch cleans all that up.

There are a few dependencies where newer versions are available and trunk might be the correct place and time to upgrade if needed. Here is a list:

commons-logging 1.0.4 (2004) -> 1.1.1 (2007)
commons-lang 2.4 (2008) -> 2.5 (2010)
commons-math 2.0 (2009) -> 2.1 (2010)
jasper-runtime 5.5.12 (2007) -> 5.5.23 (2008)
jetty 6.1.14 (2008) -> 6.1.23 (2010) | 7.0.2 (2010)
log4j 1.2.15 (2007) -> 1.2.16 (2010)

Stargate:
commons-httpclient 3.0.1 (2006) -> 3.1 (2007)
hsqldb 1.8.0.10 (2008) -> 1.8.1.2 (2010)

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

Search Discussions

  • stack (JIRA) at Apr 20, 2010 at 9:12 pm
    [ https://issues.apache.org/jira/browse/HBASE-2452?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

    stack resolved HBASE-2452.
    --------------------------

    Hadoop Flags: [Reviewed]
    Fix Version/s: 0.21.0
    Resolution: Fixed

    Committed to TRUNK. Thanks for the patch Lars Francke.
    Fix our Maven dependencies
    --------------------------

    Key: HBASE-2452
    URL: https://issues.apache.org/jira/browse/HBASE-2452
    Project: Hadoop HBase
    Issue Type: Improvement
    Components: build
    Affects Versions: 0.21.0
    Reporter: Lars Francke
    Assignee: Lars Francke
    Fix For: 0.21.0

    Attachments: HBASE-2452-1.patch, HBASE-2452-2.patch


    There are quite a few implicit dependencies or dependencies which could be moved to our parent's dependencyManagement section. This patch cleans all that up.
    There are a few dependencies where newer versions are available and trunk might be the correct place and time to upgrade if needed. Here is a list:
    commons-logging 1.0.4 (2004) -> 1.1.1 (2007)
    commons-lang 2.4 (2008) -> 2.5 (2010)
    commons-math 2.0 (2009) -> 2.1 (2010)
    jasper-runtime 5.5.12 (2007) -> 5.5.23 (2008)
    jetty 6.1.14 (2008) -> 6.1.23 (2010) | 7.0.2 (2010)
    log4j 1.2.15 (2007) -> 1.2.16 (2010)
    Stargate:
    commons-httpclient 3.0.1 (2006) -> 3.1 (2007)
    hsqldb 1.8.0.10 (2008) -> 1.8.1.2 (2010)
    --
    This message is automatically generated by JIRA.
    -
    You can reply to this email to add a comment to the issue online.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categorieshbase, hadoop
postedApr 15, '10 at 12:51p
activeApr 20, '10 at 9:12p
posts2
users1
websitehbase.apache.org

1 user in discussion

stack (JIRA): 2 posts

People

Translate

site design / logo © 2022 Grokbase