FAQ
Hi,

My new adding datanodes are working well.

But I just use start-dfs.sh in the namenode and hadoop-daemons.sh start
datanode in the namenode can start the new adding datanode, I can't use
hadoop-daemon.sh start datanode in the new adding datanode to start itself,
and when I do that it will return a null pointer exception.

I have read the mail-archives "New Datanode won't start, null pointer
exception" reported by Scott, and the url is:
http://www.mail-archive.com/hdfs-user@hadoop.apache.org/msg00271.html

But there has not have a really result. Scott at last just said:"A stop-all/
*start*-all on the cluster got it to *start*."

Thanks,
Jameson.

Search Discussions

  • James Ram at Feb 17, 2011 at 4:13 am
    Hi

    Try formating the new datanode and then run the hadoop-daemon.sh.

    With Regards,
    RJ
    On Wed, Feb 16, 2011 at 3:50 PM, Jameson Li wrote:

    Hi,

    My new adding datanodes are working well.

    But I just use start-dfs.sh in the namenode and hadoop-daemons.sh start
    datanode in the namenode can start the new adding datanode, I can't use
    hadoop-daemon.sh start datanode in the new adding datanode to start itself,
    and when I do that it will return a null pointer exception.

    I have read the mail-archives "New Datanode won't start, null pointer
    exception" reported by Scott, and the url is:
    http://www.mail-archive.com/hdfs-user@hadoop.apache.org/msg00271.html

    But there has not have a really result. Scott at last just said:"A
    stop-all/*start*-all on the cluster got it to *start*."

    Thanks,
    Jameson.
  • Jameson Li at Feb 18, 2011 at 3:38 am
    I have found the problem.
    There has a error global parameter “HADOOP_CONF_DIR” in "/etc/profile" that
    is configed by others, and this parameter “HADOOP_CONF_DIR” lead to an
    unexpected path.
    So I got the error, even I use “hadoop fs -ls” in these new-adding machine,
    it shows files in the local file system.
    When I cancelled this parameter, all works normal.

    Thanks.

    2011/2/17 James Ram <hadooprj@gmail.com>
    Hi

    Try formating the new datanode and then run the hadoop-daemon.sh.

    With Regards,
    RJ

    On Wed, Feb 16, 2011 at 3:50 PM, Jameson Li wrote:

    Hi,

    My new adding datanodes are working well.

    But I just use start-dfs.sh in the namenode and hadoop-daemons.sh start
    datanode in the namenode can start the new adding datanode, I can't use
    hadoop-daemon.sh start datanode in the new adding datanode to start itself,
    and when I do that it will return a null pointer exception.

    I have read the mail-archives "New Datanode won't start, null pointer
    exception" reported by Scott, and the url is:
    http://www.mail-archive.com/hdfs-user@hadoop.apache.org/msg00271.html

    But there has not have a really result. Scott at last just said:"A
    stop-all/*start*-all on the cluster got it to *start*."

    Thanks,
    Jameson.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouphdfs-user @
categorieshadoop
postedFeb 16, '11 at 10:21a
activeFeb 18, '11 at 3:38a
posts3
users2
websitehadoop.apache.org...
irc#hadoop

2 users in discussion

Jameson Li: 2 posts James Ram: 1 post

People

Translate

site design / logo © 2022 Grokbase