FAQ
Hi,

I am using Hadoop 0.20.203 with the new API ( mapreduce package) . I want to
use Jobpriority, but unfortunately there is no option to set that in Job (
the option is there in 0.21.0). Can somebody plz tell me is there is a
walkaround to set job priority?

Thanks,

--

Nitin Khandelwal

Search Discussions

  • Harsh J at Jul 6, 2011 at 12:38 pm
    Nitin,

    Workaround is to set "mapred.job.priority" to the JobPriority Enum
    string (#toString is sufficient) in your Job's Configuration instance.

    On Wed, Jul 6, 2011 at 5:52 PM, Nitin Khandelwal
    wrote:
    Hi,

    I am using Hadoop 0.20.203 with the new API ( mapreduce package) . I want to
    use Jobpriority, but unfortunately there is no option to set that in Job (
    the option is there in 0.21.0). Can somebody plz tell me is there is a
    walkaround to set job priority?

    Thanks,

    --

    Nitin Khandelwal


    --
    Harsh J
  • Allen Wittenauer at Jul 7, 2011 at 1:09 am

    On Jul 6, 2011, at 5:22 AM, Nitin Khandelwal wrote:

    Hi,

    I am using Hadoop 0.20.203 with the new API ( mapreduce package) . I want to
    use Jobpriority, but unfortunately there is no option to set that in Job (
    the option is there in 0.21.0). Can somebody plz tell me is there is a
    walkaround to set job priority?

    Job priority is slowly (read: unofficially) on its way to getting deprecated, if one takes the fact that cap sched now completely ignores it in 203. I, too, am sad about this.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-user @
categorieshadoop
postedJul 6, '11 at 12:23p
activeJul 7, '11 at 1:09a
posts3
users3
websitehadoop.apache.org...
irc#hadoop

People

Translate

site design / logo © 2021 Grokbase