FAQ
To Whom It May Concern,

When trying to run Hadoop 0.21 with JDK 1.6_23 I get an error:
java.lang.NoClassDefFoundError: org/apache/hadoop/util/PlatformName.
The full error log is in the attached .png
Can you help me? I'd be grateful.


Yours faithfully,
Witold Januszewski

Search Discussions

  • Tom White at Apr 8, 2011 at 4:52 pm
    Hi Witold,

    Is this on Windows? The scripts were re-structured after Hadoop 0.20,
    and looking at them now I notice that the cygwin path translation for
    the classpath seems to be missing. You could try adding the following
    line to the "if $cygwin" clause in bin/hadoop-config.sh:

    CLASSPATH=`cygpath -p -w "$CLASSPATH"`

    It's worth filing a bug for this too.

    Cheers,
    Tom
    On Thu, Apr 7, 2011 at 1:24 PM, Witold Januszewski wrote:
    To Whom It May Concern,

    When trying to run Hadoop 0.21 with JDK 1.6_23 I get an error:
    java.lang.NoClassDefFoundError: org/apache/hadoop/util/PlatformName.
    The full error log is in the attached .png
    Can you help me? I'd be grateful.


    Yours faithfully,
    Witold Januszewski

  • Witold Januszewski at Apr 8, 2011 at 7:14 pm
    Hi Tom,

    Thanks for your anwser. Yet after adding the suggested line I get another
    bug (enclosed in .png).

    Yes, it's Windows 7. I'm considering switching to Linux now :-) There's also
    a virtual machine with Hadoop provided by Yahoo!, but I don't know if I can
    install Mahout there. That's my goal actually - doing a collaborative
    filtering project with Mahout for my classes. The trouble is, I chose the
    technology and the project leader couldn't help me with it. Also the project
    topics were assigned individually. So if you offer me some more help I'd be
    grateful.

    Best Wishes,
    Witold


    2011/4/8 Tom White <tom@cloudera.com>
    Hi Witold,

    Is this on Windows? The scripts were re-structured after Hadoop 0.20,
    and looking at them now I notice that the cygwin path translation for
    the classpath seems to be missing. You could try adding the following
    line to the "if $cygwin" clause in bin/hadoop-config.sh:

    CLASSPATH=`cygpath -p -w "$CLASSPATH"`

    It's worth filing a bug for this too.

    Cheers,
    Tom
    On Thu, Apr 7, 2011 at 1:24 PM, Witold Januszewski wrote:
    To Whom It May Concern,

    When trying to run Hadoop 0.21 with JDK 1.6_23 I get an error:
    java.lang.NoClassDefFoundError: org/apache/hadoop/util/PlatformName.
    The full error log is in the attached .png
    Can you help me? I'd be grateful.


    Yours faithfully,
    Witold Januszewski

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-user @
categorieshadoop
postedApr 7, '11 at 8:28p
activeApr 8, '11 at 7:14p
posts3
users2
websitehadoop.apache.org...
irc#hadoop

2 users in discussion

Witold Januszewski: 2 posts Tom White: 1 post

People

Translate

site design / logo © 2021 Grokbase