FAQ
Hi
I am trying to turn off the safe mode using the following command.

hadoop dfsadmin -safemode leave

but it giving me this error. Anybody here to tell the solution?
Thanks in advance

--
Regards
Shuja-ur-Rehman Baig
<http://pk.linkedin.com/in/shujamughal>

Search Discussions

  • Michael Segel at Nov 6, 2010 at 8:42 pm
    Try running this as user hadoop or hdfs. (Depending on which version you are running.)

    You need to do this on the name node.

    If you're root ...
    # sudo -u hdfs /bin/ksh


    And yes, the fact that I'm still using ksh means I've been around long enough to remember AT&T Unix Sys V. ;-)

    Date: Sat, 6 Nov 2010 22:57:00 +0500
    Subject: safemode: org.apache.hadoop.security.AccessControlException: Access denied for user root. Superuser privilege is required
    From: shujamughal@gmail.com
    To: common-user@hadoop.apache.org

    Hi
    I am trying to turn off the safe mode using the following command.

    hadoop dfsadmin -safemode leave

    but it giving me this error. Anybody here to tell the solution?
    Thanks in advance

    --
    Regards
    Shuja-ur-Rehman Baig
    <http://pk.linkedin.com/in/shujamughal>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-user @
categorieshadoop
postedNov 6, '10 at 5:57p
activeNov 6, '10 at 8:42p
posts2
users2
websitehadoop.apache.org...
irc#hadoop

2 users in discussion

Shuja Rehman: 1 post Michael Segel: 1 post

People

Translate

site design / logo © 2022 Grokbase