FAQ
I follow the instruction at wiki, http://wiki.apache.org/hadoop/EclipseEnvironment, to setup hadoop environment with eclipse. However, when building hdfs and mapreduce project (src both are from trunk), it complains the following error. It looks like the mismatch of the lib version. For instance, jetty-util-6.1.12.jar exists in build/ivy/lib foder, but just the version is not what build tool requests. I search the *.xml (such as build.xml and ivy.xml), but there is not such artifact specified. Where or How can I fix this problem?

Thanks for help.

Description Resource Path Location Type
Project 'hadoop-hdfs' is missing required library: 'build/ivy/lib/Hadoop-Hdfs/common/jetty-util-6.1.14.jar' hadoop-hdfs Build path Build Path Problem
Project 'hadoop-hdfs' is missing required library: 'build/ivy/lib/Hadoop-Hdfs/common/slf4j-api-1.5.8.jar' hadoop-hdfs Build path Build Path Problem
Project 'hadoop-mapreduce' is missing required library: 'build/ivy/lib/Hadoop/common/jackson-core-asl-1.0.1.jar' hadoop-mapreduce Build path Build Path Problem
Project 'hadoop-mapreduce' is missing required library: 'build/ivy/lib/Hadoop/common/jackson-mapper-asl-1.0.1.jar' hadoop-mapreduce Build path Build Path Problem
Project 'hadoop-mapreduce' is missing required library: 'build/ivy/lib/Hadoop/common/paranamer-1.5.jar' hadoop-mapreduce Build path Build Path Problem
Project 'hadoop-mapreduce' is missing required library: 'build/ivy/lib/Hadoop/common/slf4j-simple-1.5.8.jar' hadoop-mapreduce Build path Build Path Problem
Project 'hadoop-mapreduce' is missing required library: 'build/ivy/lib/sqoop/common/commons-io-1.4.jar' hadoop-mapreduce Build path Build Path Problem
Project 'hadoop-mapreduce' is missing required source folder: 'src/contrib/sqoop/src/java' hadoop-mapreduce Build path Build Path Problem
Project 'hadoop-mapreduce' is missing required source folder: 'src/contrib/sqoop/src/test' hadoop-mapreduce Build path Build Path Problem
Project 'hadoop-hdfs' is missing required library: 'build/ivy/lib/Hadoop-Hdfs/common/jetty-6.1.14.jar' hadoop-hdfs Build path Build Path Problem

Search Discussions

  • Chaitanya krishna at Apr 19, 2010 at 8:40 am
    Hi Neo,

    One way to get out of this problem (may not be the precise solution
    though) is to include the corresponding jars from the local ivy cache, i.e.,
    from .ivy2/cache.

    Hope this helps.

    -V.V.Chaitanya.

    On Sat, Apr 17, 2010 at 9:22 PM, Neo Anderson
    wrote:
    I follow the instruction at wiki,
    http://wiki.apache.org/hadoop/EclipseEnvironment, to setup hadoop
    environment with eclipse. However, when building hdfs and mapreduce project
    (src both are from trunk), it complains the following error. It looks like
    the mismatch of the lib version. For instance, jetty-util-6.1.12.jar exists
    in build/ivy/lib foder, but just the version is not what build tool
    requests. I search the *.xml (such as build.xml and ivy.xml), but there is
    not such artifact specified. Where or How can I fix this problem?

    Thanks for help.

    Description Resource Path Location Type
    Project 'hadoop-hdfs' is missing required library:
    'build/ivy/lib/Hadoop-Hdfs/common/jetty-util-6.1.14.jar' hadoop-hdfs
    Build path Build Path Problem
    Project 'hadoop-hdfs' is missing required library:
    'build/ivy/lib/Hadoop-Hdfs/common/slf4j-api-1.5.8.jar' hadoop-hdfs
    Build path Build Path Problem
    Project 'hadoop-mapreduce' is missing required library:
    'build/ivy/lib/Hadoop/common/jackson-core-asl-1.0.1.jar'
    hadoop-mapreduce Build path Build Path Problem
    Project 'hadoop-mapreduce' is missing required library:
    'build/ivy/lib/Hadoop/common/jackson-mapper-asl-1.0.1.jar'
    hadoop-mapreduce Build path Build Path Problem
    Project 'hadoop-mapreduce' is missing required library:
    'build/ivy/lib/Hadoop/common/paranamer-1.5.jar' hadoop-mapreduce
    Build path Build Path Problem
    Project 'hadoop-mapreduce' is missing required library:
    'build/ivy/lib/Hadoop/common/slf4j-simple-1.5.8.jar' hadoop-mapreduce
    Build path Build Path Problem
    Project 'hadoop-mapreduce' is missing required library:
    'build/ivy/lib/sqoop/common/commons-io-1.4.jar' hadoop-mapreduce
    Build path Build Path Problem
    Project 'hadoop-mapreduce' is missing required source folder:
    'src/contrib/sqoop/src/java' hadoop-mapreduce Build path
    Build Path Problem
    Project 'hadoop-mapreduce' is missing required source folder:
    'src/contrib/sqoop/src/test' hadoop-mapreduce Build path
    Build Path Problem
    Project 'hadoop-hdfs' is missing required library:
    'build/ivy/lib/Hadoop-Hdfs/common/jetty-6.1.14.jar' hadoop-hdfs
    Build path Build Path Problem




Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-user @
categorieshadoop
postedApr 17, '10 at 3:53p
activeApr 19, '10 at 8:40a
posts2
users2
websitehadoop.apache.org...
irc#hadoop

2 users in discussion

Chaitanya krishna: 1 post Neo Anderson: 1 post

People

Translate

site design / logo © 2022 Grokbase