FAQ
1. When I build hive-0.4.0, ivy would try to download hadoop 0.17.2.1,
0.18.3, 0.19.0 and 0.20.0. But always fail for 0.17.2.1.
2. Then I modified shims/ivy.xml and shims/build.xml to remove dependencies
of 0.17.2.1, 0.18.3, 0.19.0. It works find to only download hadoop-0.20.0.

3. Now, I want do depend hadoop-0.20.1, I modified the above two xml to add
0.20.1, but failed for md5, following is the errors.

[ivy:retrieve]
[ivy:retrieve] :: problems summary ::
[ivy:retrieve] :::: WARNINGS
[ivy:retrieve] [FAILED ]
hadoop#core;0.20.1!hadoop.tar.gz(source): invalid md5:
expected=hadoop-0.20.1.tar.gz: computed=719e169b7760c168441b49f405855b72
(138662ms)
[ivy:retrieve] [FAILED ]
hadoop#core;0.20.1!hadoop.tar.gz(source): invalid md5:
expected=hadoop-0.20.1.tar.gz: computed=719e169b7760c168441b49f405855b72
(138662ms)
[ivy:retrieve] ==== hadoop-resolver: tried
[ivy:retrieve]
http://archive.apache.org/dist/hadoop/core/hadoop-0.20.1/hadoop-0.20.1.tar.gz
[ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve] :: FAILED DOWNLOADS ::
[ivy:retrieve] :: ^ see resolution messages for details ^ ::
[ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve] :: hadoop#core;0.20.1!hadoop.tar.gz(source)
[ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:retrieve]
[ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

I checked the
http://archive.apache.org/dist/hadoop/core/hadoop-0.20.1/hadoop-0.20.1.tar.gz.md5,
and found the format of this file is different from other hadoop releases.

Please the releaser of hadoop and hive to have a check.

Schubert

Search Discussions

  • Todd Lipcon at Oct 19, 2009 at 5:12 pm
    Hi Schubert,

    Regarding the Hive problem - you should be able to build against 0.20.0 and
    then run against 0.20.1. Within a release (0.20.*) the APIs are completely
    compatible, so you can compile any external application against one and run
    against another.

    Regarding the format of the md5 file, I'll defer to Owen who I believe cut
    the release.

    -Todd
    On Mon, Oct 19, 2009 at 10:02 AM, Schubert Zhang wrote:

    1. When I build hive-0.4.0, ivy would try to download hadoop 0.17.2.1,
    0.18.3, 0.19.0 and 0.20.0. But always fail for 0.17.2.1.
    2. Then I modified shims/ivy.xml and shims/build.xml to remove dependencies
    of 0.17.2.1, 0.18.3, 0.19.0. It works find to only download hadoop-0.20.0.

    3. Now, I want do depend hadoop-0.20.1, I modified the above two xml to add
    0.20.1, but failed for md5, following is the errors.

    [ivy:retrieve]
    [ivy:retrieve] :: problems summary ::
    [ivy:retrieve] :::: WARNINGS
    [ivy:retrieve] [FAILED ]
    hadoop#core;0.20.1!hadoop.tar.gz(source): invalid md5:
    expected=hadoop-0.20.1.tar.gz: computed=719e169b7760c168441b49f405855b72
    (138662ms)
    [ivy:retrieve] [FAILED ]
    hadoop#core;0.20.1!hadoop.tar.gz(source): invalid md5:
    expected=hadoop-0.20.1.tar.gz: computed=719e169b7760c168441b49f405855b72
    (138662ms)
    [ivy:retrieve] ==== hadoop-resolver: tried
    [ivy:retrieve]

    http://archive.apache.org/dist/hadoop/core/hadoop-0.20.1/hadoop-0.20.1.tar.gz
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] :: FAILED DOWNLOADS ::
    [ivy:retrieve] :: ^ see resolution messages for details ^ ::
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] :: hadoop#core;0.20.1!hadoop.tar.gz(source)
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve]
    [ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

    I checked the

    http://archive.apache.org/dist/hadoop/core/hadoop-0.20.1/hadoop-0.20.1.tar.gz.md5
    ,
    and found the format of this file is different from other hadoop releases.

    Please the releaser of hadoop and hive to have a check.

    Schubert
  • Schubert Zhang at Oct 19, 2009 at 5:28 pm
    Todd,

    Yes, it works when build against 0.20.0. I just mention this issue for your
    check.
    Thanks.

    Schubert
    On Tue, Oct 20, 2009 at 1:12 AM, Todd Lipcon wrote:

    Hi Schubert,

    Regarding the Hive problem - you should be able to build against 0.20.0 and
    then run against 0.20.1. Within a release (0.20.*) the APIs are completely
    compatible, so you can compile any external application against one and run
    against another.

    Regarding the format of the md5 file, I'll defer to Owen who I believe cut
    the release.

    -Todd
    On Mon, Oct 19, 2009 at 10:02 AM, Schubert Zhang wrote:

    1. When I build hive-0.4.0, ivy would try to download hadoop 0.17.2.1,
    0.18.3, 0.19.0 and 0.20.0. But always fail for 0.17.2.1.
    2. Then I modified shims/ivy.xml and shims/build.xml to remove
    dependencies
    of 0.17.2.1, 0.18.3, 0.19.0. It works find to only download
    hadoop-0.20.0.
    3. Now, I want do depend hadoop-0.20.1, I modified the above two xml to add
    0.20.1, but failed for md5, following is the errors.

    [ivy:retrieve]
    [ivy:retrieve] :: problems summary ::
    [ivy:retrieve] :::: WARNINGS
    [ivy:retrieve] [FAILED ]
    hadoop#core;0.20.1!hadoop.tar.gz(source): invalid md5:
    expected=hadoop-0.20.1.tar.gz: computed=719e169b7760c168441b49f405855b72
    (138662ms)
    [ivy:retrieve] [FAILED ]
    hadoop#core;0.20.1!hadoop.tar.gz(source): invalid md5:
    expected=hadoop-0.20.1.tar.gz: computed=719e169b7760c168441b49f405855b72
    (138662ms)
    [ivy:retrieve] ==== hadoop-resolver: tried
    [ivy:retrieve]

    http://archive.apache.org/dist/hadoop/core/hadoop-0.20.1/hadoop-0.20.1.tar.gz
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] :: FAILED DOWNLOADS ::
    [ivy:retrieve] :: ^ see resolution messages for details ^ ::
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] :: hadoop#core;0.20.1!hadoop.tar.gz(source)
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve]
    [ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

    I checked the

    http://archive.apache.org/dist/hadoop/core/hadoop-0.20.1/hadoop-0.20.1.tar.gz.md5
    ,
    and found the format of this file is different from other hadoop releases.
    Please the releaser of hadoop and hive to have a check.

    Schubert
  • Carl Steinbach at Feb 15, 2010 at 10:15 pm
    The MD5 checksum file for the 0.20.1 tarball contains an MD5 checksum along
    with
    various SHA checksums and an RMD160 checksum:

    hadoop-0.20.1.tar.gz: MD5 = 71 9E 16 9B 77 60 C1 68 44 1B 49 F4 05 85 5B
    72
    hadoop-0.20.1.tar.gz: SHA1 = 712A EE9C 279F 1031 1F83 657B 2B82 7ACA 0374
    6613
    hadoop-0.20.1.tar.gz: RMD160 = 4331 4350 27E9 E16D 055C F23F FFEF 1564 E206
    B144
    hadoop-0.20.1.tar.gz: SHA224 = A5E4CBE9 EBBE5FE1 2020F3F1 BFBC6D3C C77A8E9B
    E6C6062C A6484BDB
    ...

    The convention that most tools expect (including Ivy) is that a file named
    xyz.tar.gz.md5 was generated by running the following command:

    % md5sum xyz.tar.gz > xyz.tar.gz.md5

    All of the other Hadoop releases on archive.apache.org follow this
    convention, with
    the exception of hadoop-0.20.1.

    Can someone with access to the Apache archive repository please fix the
    0.20.1
    md5 checksum file?

    Thanks.

    Carl
    On Mon, Oct 19, 2009 at 9:02 AM, Schubert Zhang wrote:

    1. When I build hive-0.4.0, ivy would try to download hadoop 0.17.2.1,
    0.18.3, 0.19.0 and 0.20.0. But always fail for 0.17.2.1.
    2. Then I modified shims/ivy.xml and shims/build.xml to remove dependencies
    of 0.17.2.1, 0.18.3, 0.19.0. It works find to only download hadoop-0.20.0.

    3. Now, I want do depend hadoop-0.20.1, I modified the above two xml to add
    0.20.1, but failed for md5, following is the errors.

    [ivy:retrieve]
    [ivy:retrieve] :: problems summary ::
    [ivy:retrieve] :::: WARNINGS
    [ivy:retrieve] [FAILED ]
    hadoop#core;0.20.1!hadoop.tar.gz(source): invalid md5:
    expected=hadoop-0.20.1.tar.gz: computed=719e169b7760c168441b49f405855b72
    (138662ms)
    [ivy:retrieve] [FAILED ]
    hadoop#core;0.20.1!hadoop.tar.gz(source): invalid md5:
    expected=hadoop-0.20.1.tar.gz: computed=719e169b7760c168441b49f405855b72
    (138662ms)
    [ivy:retrieve] ==== hadoop-resolver: tried
    [ivy:retrieve]

    http://archive.apache.org/dist/hadoop/core/hadoop-0.20.1/hadoop-0.20.1.tar.gz
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] :: FAILED DOWNLOADS ::
    [ivy:retrieve] :: ^ see resolution messages for details ^ ::
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] :: hadoop#core;0.20.1!hadoop.tar.gz(source)
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve]
    [ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

    I checked the

    http://archive.apache.org/dist/hadoop/core/hadoop-0.20.1/hadoop-0.20.1.tar.gz.md5
    ,
    and found the format of this file is different from other hadoop releases.

    Please the releaser of hadoop and hive to have a check.

    Schubert

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-user @
categorieshadoop
postedOct 19, '09 at 5:03p
activeFeb 15, '10 at 10:15p
posts4
users3
websitehadoop.apache.org...
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase