FAQ
Dear Hadoop Developers,

i work on a java 5 project and during upgrade from 0.18.1 to 0.18.2
this error appears:

...
x.java:[11,-1] cannot access org.apache.hadoop.streaming.JarBuilder
bad class file: /Users/jz/.m2/repository/org/apache/hadoop/hadoop-
streaming/0.18.2/hadoop-streaming-0.18.2.jar(org/apache/hadoop/
streaming/JarBuilder.class)
class file has wrong version 50.0, should be 49.0
...

Could it that 0.18.2 is compiled with java 6 whereas 0.18.1 is
compiled with java 5 ?
If so, would there be any plans to republish or do another release ?

thanks
Johannes

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
101tec GmbH
Halle (Saale), Saxony-Anhalt, Germany
http://www.101tec.com

Search Discussions

  • 柳松 at Nov 18, 2008 at 2:31 pm
    You can also rebuild the jar by compiling all the sources in the 'src' folder with your working jdk.





    在2008-11-18?21:38:30,"Johannes?Zillmann"?<jz@101tec.com>?写道:
    Dear?Hadoop?Developers,

    i?work?on?a?java?5?project?and?during?upgrade?from?0.18.1?to?0.18.2??
    this?error?appears:

    ...
    x.java:[11,-1]?cannot?access?org.apache.hadoop.streaming.JarBuilder
    bad?class?file:?/Users/jz/.m2/repository/org/apache/hadoop/hadoop-?
    streaming/0.18.2/hadoop-streaming-0.18.2.jar(org/apache/hadoop/?
    streaming/JarBuilder.class)
    class?file?has?wrong?version?50.0,?should?be?49.0
    ...

    Could?it?that?0.18.2?is?compiled?with?java?6?whereas?0.18.1?is??
    compiled?with?java?5??
    If?so,?would?there?be?any?plans?to?republish?or?do?another?release??

    thanks
    Johannes

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    101tec?GmbH
    Halle?(Saale),?Saxony-Anhalt,?Germany
    http://www.101tec.com
  • Alex Loddengaard at Nov 18, 2008 at 5:56 pm
    Or just run `ant jar` from $HADOOP_HOME and grab the jar (postfixed with
    -dev) in $HADOOP_HOME/build.
    Alex
    On Tue, Nov 18, 2008 at 6:30 AM, 柳松 wrote:

    You can also rebuild the jar by compiling all the sources in the 'src'
    folder with your working jdk.





    在2008-11-18?21:38:30,"Johannes?Zillmann"?<jz@101tec.com>?写道:
    Dear?Hadoop?Developers,

    i?work?on?a?java?5?project?and?during?upgrade?from?0.18.1?to?0.18.2??
    this?error?appears:

    ...
    x.java:[11,-1]?cannot?access?org.apache.hadoop.streaming.JarBuilder
    bad?class?file:?/Users/jz/.m2/repository/org/apache/hadoop/hadoop-?
    streaming/0.18.2/hadoop-streaming-0.18.2.jar(org/apache/hadoop/?
    streaming/JarBuilder.class)
    class?file?has?wrong?version?50.0,?should?be?49.0
    ...

    Could?it?that?0.18.2?is?compiled?with?java?6?whereas?0.18.1?is??
    compiled?with?java?5??
    If?so,?would?there?be?any?plans?to?republish?or?do?another?release??

    thanks
    Johannes

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    101tec?GmbH
    Halle?(Saale),?Saxony-Anhalt,?Germany
    http://www.101tec.com

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-user @
categorieshadoop
postedNov 18, '08 at 1:39p
activeNov 18, '08 at 5:56p
posts3
users3
websitehadoop.apache.org...
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase